Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 5 Vote(s) - 4.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Request] Acer Aspire E5-553-1786
(11-05-2017, 10:17 AM)ep12390 Wrote: Is it possible this could brick my machine at all? I have a E5-553G-F8EF on BIOS 1.19. This machine has 16gb ram so possibly somehow running this mod will set the ram to 8gb?

Thank you for taking the time to write out the instructions by the way.


Attached is my vars.txt if anyone would please like to take a go at this.

I have no idea and will not pretend to. I'm sure there is a chance, but the risk is up to you. I would suggest looking up the vars.txt files others have posted and compare them to the posted vars_mod.txt files that you can find in the thread. You may even get lucky and find one from your laptop version that is already modified (if you do DO NOT DIRECTLY COPY IT -- I can tell you that much). Just run the two files through diffchecker.com and see what value was edited. You can do this for all the vars.txt/vars_mod.txt files you can find. That's what I did and I came up with the value that I show how to edit in my above tutorial.

Do not take my word for it. Do your own research. This is your laptop, not mine. Only make changes you are 100% comfortable with.
If I'm being honest, when I made the change on my laptop I was extremely nervous...but it worked for me and I saw that no one is posting vars_mod.txt files anymore, so I hoped that my tutorial, at the very least, would point everyone in the right direction.

As for the ram issue, I'm not sure since mine is 8gb. You'll have to research that or find out the hard way. It's up to you. Hopefully someone more knowledgeable comes along and gives you better advice than I am.

Good luck, and if you try it let me know if it works.
find
quote
(11-03-2017, 02:15 AM)im_ryan Wrote: @sp1k3y Firstly, I take no responsibility if the instructions I give do not work for you or anyone reading this. Although, I figured out how to enable virtualization on my laptop by reading through this thread, so I will share what I did in hopes that it helps others like yourself.

For reference, my laptop specs:
Aspire E5-553G-1986
Windows 10 (Version 1703)
AMD A12-9700P Processor
8GB RAM
BIOS version 1.19


Step 1: Download this tool: https://drive.google.com/file/d/0B4NHIBM...RtQXM/view
Step 2: Extract the tool into a new folder on your desktop. Name it BIOS.
Step 3: Open Windows start menu, type in "cmd", right click "cmd" and click on "Run as Administrator".
Step 4: In command prompt, type in "cd " and then the directory to your file on the desktop. You can find this by right clicking the folder, clicking on properties and copying the location. Go back into the command prompt and press CTRL and V at the same time on your keyboard to paste it. Then add "\BIOS" and press ENTER. For example:
Code:
cd C:\Users\Ryan\Desktop\BIOS

Step 5: Type in "H2OUVE.exe -gv vars.txt" and press ENTER.
Step 6: Open the newly created vars.txt in the BIOS folder with notepad and press CTRL and F at the same time on your keyboard and search for "Setup". It should look something like this (the numbers will probably be different - note that it may take a few searches, the file is huge):
Code:
 [031] "Setup"
      GUID: A04A27F4-DF00-4D42-B552-39511302113D
      Attributes: 0x7
      DataSize: 0x279
      Data:
            00000000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
            00000010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
            ...

Step 7: Look for the next line that begins with "000000E0:", for example:
Code:
            ...
            000000A0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
            000000B0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
            000000C0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
            000000D0: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 01 00
            000000E0: 00 00 00 02 00 00 00 00 00 00 00 01 01 00 00 00    **This line**
            000000F0: 00 00 00 00 00 00 00 03 00 01 00 00 00 00 01 00
            00000100: 02 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00
            00000110: 00 00 00 00 00 00 00 00 00 01 00 00 00 00 00 00
            ...

Step 8: On this line, change the second to last "00" to "01". For example:
Code:
           000000E0: 00 00 00 02 00 00 00 00 00 00 00 01 01 00 00 00
                             - to -
           000000E0: 00 00 00 02 00 00 00 00 00 00 00 01 01 00 01 00

Step 9: Save your change as a new file called "vars_mod.txt".
Step 10: In the command prompt window (refer to Step 3-4) type "H2OUVE.exe -sv vars_mod.txt".
Step 11: Restart your computer when the command prompt finishes execution (should take only a few seconds).
Step 12: Let Windows do its thing and fully shut down. For me, this took longer than it normally did, just a heads up. If your screen turns black and does not restart, then you can manually power it back up.
Step 13: Open task manager, click "more details", open the "Performance" tab and check that virtualization is enabled. If it is, you're good to go. If not, you either changed the wrong value or something went wrong. If so, then open up command prompt again as admin (Step 3-4), go to your new file and then type "H2OUVE.exe -sv vars.txt" and restart your computer again. This should revert whatever change you did.

As a side note, I saw something about this mod cutting the usable RAM in half... not really sure what they were talking about, but I did not experience this issue using the above steps.
As a second side note, it appears that if you upgrade your BIOS you will lose your virtualization setting. You will have to manually enable it again using the above method to make a new vars.txt and new vars_mod.txt.

Lastly, I made an account on this site to specifically thank mclarkke2355 and others on this thread that allowed me to force enable AMD virtualization on my laptop so I can finally use it for college. Hopefully my instruction set helps others that view this thread in the future.

I can confirm this method works with Acer Aspire E5-553G-T686  Big Grin
Thanks a lot for the guide now I can use amd-v again 
find
quote
Weird question, in fact, I did compare the files, and I found there is also a change in the 00000140 range, according to McCkarke's help:

Original:

Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 01 00 02

Changed:
Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 00 00 02

There is a 01 changed into a 00... can you confirm if this is needed to enable Virtualization or not? Or at least, what does this value do?

Thanks in advance.

Cya!
find
quote
Hello, my laptop is Acer E5-553G-F79R, i want to activate amd-v to run android emu in android studio, this my vars.txt https://drive.google.com/file/d/1lTS4ujs...sp=sharing

I would really grateful if you can help me to unlock amd-v Smile
find
quote
(11-09-2017, 06:10 PM)FerchogtX Wrote: Weird question, in fact, I did compare the files, and I found there is also a change in the 00000140 range, according to McCkarke's help:

Original:

Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 01 00 02

Changed:
Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 00 00 02

There is a 01 changed into a 00... can you confirm if this is needed to enable Virtualization or not? Or at least, what does this value do?

Thanks in advance.

Cya!

I just tried this using both the original change and additionally changing the extra bit above.  In both cases the change was easy enough to make, and after the initial change Task Manager does indeed report virtualization has been enabled.  However, I 'm wondering if that is just changing a flag and not actually changing anything in the machine itself, because VirtualBox is still reporting that I do not have VT-x/AMD-V available on the system.
find
quote
(05-07-2017, 10:15 AM)mclarke2355 Wrote: Hi,
the flashing of the modded BIOS might not work because the recovery checks the signature of the BIOS file.

However, you might be able to enable AMD-V using this method (needs to be adapted): http://www.geektech.co.nz/how-to-unlock-...enovo-y700
This method requires Windows as a system as the necessary tool is only available for Windows.

First, you will need the tool: https://drive.google.com/file/d/0B4NHIBM...RtQXM/view
Extract the archive and go to the folder with the extracted files.
Then, you need to open an administrative command prompt in that folder (google it if you don't know how).
Execute the command from step 1 of the linked guide in that command prompt (H2OUVE.exe -gv vars.txt).
After that, you'll have the file "vars.txt" in that folder.
You need to upload this file, so that I can make the change.

For reference, here's the EFI-table with available settings for this notebook: https://drive.google.com/open?id=0B4NHIB...WI4LW14bE0
And here's the setting that needs to be changed:
0x1C40B             Setting: SVM support, Variable: 0xEE {05 91 54 02 55 02 54 00 34 12 EE 00 00 10 00 01 00}
0x1C41C                 Option: Disabled, Value: 0x0 (default) {09 07 27 00 10 00 00}
0x1C423                 Option: Enabled, Value: 0x1 {09 07 28 00 00 00 01}

Here mine vars.txt
Please enable my V-AMD. Thanks before.

Ven
find
quote
(11-25-2017, 11:51 PM)JoeCaloric Wrote:
(11-09-2017, 06:10 PM)FerchogtX Wrote: Weird question, in fact, I did compare the files, and I found there is also a change in the 00000140 range, according to McCkarke's help:

Original:

Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 01 00 02

Changed:
Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 00 00 02

There is a 01 changed into a 00... can you confirm if this is needed to enable Virtualization or not? Or at least, what does this value do?

Thanks in advance.

Cya!

I just tried this using both the original change and additionally changing the extra bit above.  In both cases the change was easy enough to make, and after the initial change Task Manager does indeed report virtualization has been enabled.  However, I 'm wondering if that is just changing a flag and not actually changing anything in the machine itself, because VirtualBox is still reporting that I do not have VT-x/AMD-V available on the system.

Did changing the 00000140 line fix y our virtual box problem, when the initial change to 000000E0 didn't?

Anyway. I just tried without changing the 00000140 line and my virtual box is working and my memory is still at 16 gigs. The restart took forever, gave me an error message from Windows about restarting after 15 minutes. Then hung on the manufacturer splash screen for 10 more minutes, so I just restarted manually by pressing down the power button, and everything is working fine.

So all I had to do was change the 000000E0 under the Setup Group, line and use the H2OVUE tool and this guide above to change the 2nd to last "00" to "01" and vwala. I'm good. Hope that helps somebody. Thanks for the guide.
find
quote
(12-05-2017, 05:44 PM)rapstar Wrote:
(11-25-2017, 11:51 PM)JoeCaloric Wrote:
(11-09-2017, 06:10 PM)FerchogtX Wrote: Weird question, in fact, I did compare the files, and I found there is also a change in the 00000140 range, according to McCkarke's help:

Original:

Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 01 00 02

Changed:
Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 00 00 02

There is a 01 changed into a 00... can you confirm if this is needed to enable Virtualization or not? Or at least, what does this value do?

Thanks in advance.

Cya!

I just tried this using both the original change and additionally changing the extra bit above.  In both cases the change was easy enough to make, and after the initial change Task Manager does indeed report virtualization has been enabled.  However, I 'm wondering if that is just changing a flag and not actually changing anything in the machine itself, because VirtualBox is still reporting that I do not have VT-x/AMD-V available on the system.

Did changing the 00000140 line fix y our virtual box problem, when the initial change to 000000E0 didn't?

Anyway. I just tried without changing the 00000140 line and my virtual box is working and my memory is still at 16 gigs. The restart took forever, gave me an error message from Windows about restarting after 15 minutes. Then hung on the manufacturer splash screen for 10 more minutes, so I just restarted manually by pressing down the power button, and everything is working fine.

So all I had to do was change the 000000E0 under the Setup Group, line and use the H2OVUE tool and this guide above to change the 2nd to last "00" to "01" and vwala. I'm good. Hope that helps somebody. Thanks for the guide.

No.  Changing the 00000140 line did nothing.  Changing the 000000E0 line causes Windows to report that virtualization is on (whereas before it said it was off). But virtual box is not working on that machine.  It works on other machines I have.  So I don't know.  Maybe the motherboard really doesn't support it, so turning it on in the CPU doesn't do anything?
find
quote
(12-05-2017, 07:42 PM)JoeCaloric Wrote:
(12-05-2017, 05:44 PM)rapstar Wrote:
(11-25-2017, 11:51 PM)JoeCaloric Wrote:
(11-09-2017, 06:10 PM)FerchogtX Wrote: Weird question, in fact, I did compare the files, and I found there is also a change in the 00000140 range, according to McCkarke's help:

Original:

Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 01 00 02

Changed:
Code:
00000140: 00 00 01 00 00 01 00 00 00 00 00 00 00 00 00 02

There is a 01 changed into a 00... can you confirm if this is needed to enable Virtualization or not? Or at least, what does this value do?

Thanks in advance.

Cya!

I just tried this using both the original change and additionally changing the extra bit above.  In both cases the change was easy enough to make, and after the initial change Task Manager does indeed report virtualization has been enabled.  However, I 'm wondering if that is just changing a flag and not actually changing anything in the machine itself, because VirtualBox is still reporting that I do not have VT-x/AMD-V available on the system.

Did changing the 00000140 line fix y our virtual box problem, when the initial change to 000000E0 didn't?

Anyway. I just tried without changing the 00000140 line and my virtual box is working and my memory is still at 16 gigs. The restart took forever, gave me an error message from Windows about restarting after 15 minutes. Then hung on the manufacturer splash screen for 10 more minutes, so I just restarted manually by pressing down the power button, and everything is working fine.

So all I had to do was change the 000000E0 under the Setup Group, line and use the H2OVUE tool and this guide above to change the 2nd to last "00" to "01" and vwala. I'm good. Hope that helps somebody. Thanks for the guide.

No.  Changing the 00000140 line did nothing.  Changing the 000000E0 line causes Windows to report that virtualization is on (whereas before it said it was off). But virtual box is not working on that machine.  It works on other machines I have.  So I don't know.  Maybe the motherboard really doesn't support it, so turning it on in the CPU doesn't do anything?

Try deleting all your vitual sessions uninstall and reinstall VMware. that's what I did before I modded the bios.

Any help for me on unlocking the whole bios hidden menu? I'm just being greedy now lol, sike Fk Acer
find
quote
(05-07-2017, 10:15 AM)mclarke2355 Wrote: Hi,
the flashing of the modded BIOS might not work because the recovery checks the signature of the BIOS file.

However, you might be able to enable AMD-V using this method (needs to be adapted): http://www.geektech.co.nz/how-to-unlock-...enovo-y700
This method requires Windows as a system as the necessary tool is only available for Windows.

First, you will need the tool: https://drive.google.com/file/d/0B4NHIBM...RtQXM/view
Extract the archive and go to the folder with the extracted files.
Then, you need to open an administrative command prompt in that folder (google it if you don't know how).
Execute the command from step 1 of the linked guide in that command prompt (H2OUVE.exe -gv vars.txt).
After that, you'll have the file "vars.txt" in that folder.
You need to upload this file, so that I can make the change.

For reference, here's the EFI-table with available settings for this notebook: https://drive.google.com/open?id=0B4NHIB...WI4LW14bE0
And here's the setting that needs to be changed:
0x1C40B             Setting: SVM support, Variable: 0xEE {05 91 54 02 55 02 54 00 34 12 EE 00 00 10 00 01 00}
0x1C41C                 Option: Disabled, Value: 0x0 (default) {09 07 27 00 10 00 00}
0x1C423                 Option: Enabled, Value: 0x1 {09 07 28 00 00 00 01}

help me please


Attached Files
.txt   vars.txt (Size: 86.91 KB / Downloads: 0)
find
quote


Forum Jump:


Users browsing this thread: 3 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in