Bios Mods -The Best BIOS Update and Modification Source

Full Version: [Request] Agesa update for Asrock M3A770DE
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there!
I don't know if this is the correct place to post it, so move it if it's not.
I need someome kind enough to update the AGESA CODES for my mobo. I think it would make possible to run a Piledriver on it)
I've found that M3A770DE3L (that actually supports FX) has the same layout that DE.

I would appreciate it a lot. BTW, to make you things easier. Here you have the 2 bios:

PS2: If there's anything more to change, please let me know it. I don't want to brick my mobo.
Hi guys, I'm new to this forum but I hope it's the right place for my question: is there any way to make motherboard Asrock M3A770DE compatible with Athlon II x2 280? The MB supports CPUs of that line up to x2 270. I'm using the latest BIOS 1.80 - Any input will be highly appreciated. Rgds
Athlon II X2 270 and Athlon II X2 280 have the same CPUID and core stepping.
So latest BIOS support Athlon II X2 280 too.
Thanks for the prompt reply. When I installed the x2 280 the PC didn't boot, didn't even do the POST, no beeps, nothing, just a black screen. When I reinstalled the previous CPU ( a Phenom II x2 550) everything worked just fine. Then I checked with Asrock's official CPU support list and the x2 280 wasn't listed. If the CPU is supported what could be the reason for the PC not booting? Any tweeks I could do in the BIOS? Thanks once again for the help. Rgds.
Check your new CPU in other system. Probably it's dead.
You can try to use M3A770DE Beta-Bios 1.90. Rename it to *.zip and decompress.
I found an interesting information.
Quote:Nick [D]vB
Re: Bulldozer BIOS update for most Asrock AM3 boards?
It looks like we can add the M3A770DE to that list! 8)

I just flashed mine with the 770DE3L beta bios and it works fine,

(except the white memory slots but that was expected)

I'll test an FX-6100 on it soon, fingers crossed...
Thanks for the suggestions. I've tried it on a GB 970 motherboard and it worked. Anyway I'll try the Beta BIOS and will post the result (hopefully positive)Smile. Rgds.
Updated to the beta BIOS 1.9, everything works, except for the CPU. Same old story: no boot, no POST, no beeps, only black screen. Obviously this MB does not support Athlon II x2 280 even with the latest BIOS available. At the same time in the official CPU support list this version of BIOS is listed as supporting FX CPUs. Go figure.
Sorry, no more ideas.
Thanks for the help anyway.