Bios Mods -The Best BIOS Update and Modification Source

Full Version: [SOLVED] HP d530 CMT microcode addition
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4

I have an HP d530 convertible mini-tower with a Pentium 4 Extreme Edition 3.2ghz installed. The system works, just throws a "Microcode update error" during POST and I need to hit F1 to continue each time, which is an annoyance. This is a 786B2 motherboard and I cannot cross-flash this one to the equivalent Asus (?) motherboard like certain d530 models allow.

I have added the correct microcode for my processor by replacing another unneeded section of microcode in the ROM.bin file with a hex editor, but I'm not sure how to flash the BIOS now since the file seems to have a .sig file signing the ROM.bin file. The DOS flasher seems to use a different file entirely which is smaller than the 512kb BIN file. I'm not sure if I would be able to flash the modified ROM.bin file using the DOS flasher in this case.

Does anyone have any suggestions? Can the HPQFlash.exe Windows flasher be modified to ignore invalid signatures and flash anyway, or can the modified ROM.bin be signed and placed in a new CAB file for HPQFlash to use? Is there an alternate flasher I could use?

Thanks for any assistance.
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z.
Attached are screenshots of the requested CPU-Z tabs, plus output of intelmicrocodelist.exe of the original and my modified BIOS adding the necessary microcode.
Try this method:
1. Download any 786D1 BIOS.
2. Extract file \DOS Flash\FLASHBIN.EXE
3. Download last 786B2 BIOS.
4. Extract all files from folder \DOS Flash\ to DOS USB device, except BLUEFI*.* and FLSHLITE.EXE
5. Copy FLASHBIN.EXE to DOS USB device.
6. Copy modded bios to DOS USB device.
7. Boot from DOS USB device.
I receive the error "Note! There are no image files on the diskette for the device you have selected". Do I need to pass any arguments to FLASHBIN.EXE? I have named the modified BIOS the same as the 786D1 BIOS (7D1_0161.bin) and also left it named as ROM_MOD.bin. When doing "flashbin /?", I see no arguments that will allow me to force-flash a specific file.
Try use FLSH.CPU from 786B2 and 786D1 BIOS with this:
(03-12-2016, 09:53 AM)DeathBringer Wrote: [ -> ]Try use FLSH.CPU from 786B2 and 786D1 BIOS with this:

With 786B2 FLSH.CPU: no change.
With 786D1 FLSH.CPU: "Error! Either there are no valid drivers on the diskette or there are no upgradable devices in this system."
Then my keyboard stops working and I must power off.

Maybe I need to put a supported CPU in the computer and try again?

Also, perhaps I could try the newer flashbin version (1.10.02) in this thread?
Original supported processor installed + 786B2 FLSH.CPU: "Note! There are no image files on the media for the device you have selected." when attempting to run either flashbin or flashbin /F FLSH.CPU DEFAULT.
Try FLSH.CPU from 786B2 and original Rom.bin
Same error. Using FLASHBIN.EXE from 786D1, FLSH.CPU and original Rom.bin from 786D2 on a DOS-bootable floppy disk.

Is there any way to convert ROM.BIN to "BLUEFI" lite version to use with FLSHLITE? Or insert ROM into ROMPAQ (guessing not due to signing)?
Pages: 1 2 3 4