Bios Mods -The Best BIOS Update and Modification Source

Full Version: Adding CPU support for E5-2683V3 to HP ML350 Gen9 server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Just wanted to see if it would be possible/advisable to add support for the stepping of my E5-2683V3 CPU into an HP ML350 Gen9 server.

HP was of course no help, so I was curious if anyone in here had played with the HP Linux that checks the processors prior to BIOS loading? If so, how difficult is it to add the Intel Microcode to support my stepping?

I inherited 4 matching E5-2683V3 processors and would love to upgrade these servers.

Thanks for any assistance.

It's been a while since I hacked a BIOS, but figure if any group can help me out it's right here...... Big Grin
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with native CPU.
Tell sSpec of your new CPU.
Give me link to current BIOS.
(09-26-2016, 11:20 AM)DeathBringer Wrote: [ -> ]Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with native CPU.
Tell sSpec of your new CPU.
Give me link to current BIOS.

Here are the screen caps and a picture of the CPU.
It's ES CPU.
Did you tried to boot your ML350 Gen9 with it? What was a result?
P.S. I still need a link to download current BIOS (2.20_05-05-2016).
Update: from PM
UABMaddog Wrote:The system halts at the Early system initialization screen with a 275 -Unsupported Processor Detected - Processor stepping not supported.
Try to make BIOS backup by Intel Flash Programming Tool
Win x64:
Win x86:

E.g.: fptw64 -BIOS -D c:\Backupbios.bin
From PM
UABMaddog Wrote:The system that has the working processors is running Windows server 2012R2 and gives the following error:
Error 201:  [FPTw64.exe] cannot be run on the current platform.
Please contact your vendor.

I tried all the compatibility modes in Server 2012R2 (Windows 7,8, Vista, Vista SP1 and Vista SP2) no success.
You must boot from DOS usb-stick. Compatibility modes can't help.
Finding an alternative method to flash modded BIOS is very important because of a digital sing in native BIOS.
Ordered a processor to get the second system up and running, so I can work on this BIOS hack uninterrupted.

Got the ML350 running, booting to a FreeDOS USB Stick, still same Error201. Booted off the Windows Server 2012 install DVD and at the Upgrade install/Custom Install screen hit Shift-F10 to go to a command prompt and run the FPTW_64 and get the same Error201. Is the HP BIOS somehow protected? Darn HP!
So I can't help you with using a hardware programmer.
Well, dang! Guess I have $1000 worth of unusable CPU's. Wish I knew then what I know now!!!

Thanks for the time. Guess I'll be getting a couple of Dual socket Motherboards and have some really nice workstations......silver lining!

Of course is anybody needs some E5-2683V3 CPU's, hit me up. I have 4 of them sitting here at the moment. LOL