Bios Mods -The Best BIOS Update and Modification Source

Full Version: [SOLVED] Add AMD FX-9590 support on the motherboard Fatal1ty 990FX Killer / 3.1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I bought a Fatal1ty 990FX Killer / 3.1 believes that supported the cpu
FX9590. Installed the card, boot the PC and find that the CPU is not in the list of supported processors.
I did some research online and it seems that with the latest update has raised the AsRock support for 9xxx CPU does not know why. Is there a way to restore the support or do I have to change the motherboard?

Greetings.
What's happened when you try to boot your motherboard with FX-9590? Describe in details.
BTW: FX-9590 has very high TDP=220W for this motherboard. CPU with TDP higher then 125W isn't recommended.
Two modification requests:

Easy?: Unhide/Unlock any hidden menu's/options (Someone had done one for the NON 3.1 firmware elsewhere, seems to have been a bit that was hidden, wanted to see if anything was there for the +3.1)

Hard!: I have 2 systems, one with an FX8350 one with an FX9590
Details: At launch, 9k series where listed as supported!, after the first BIOS update, the BIOS gave warning, the next it stopped working at all said go puck yourself.
Now, I don't plan to overclock, but I am pissed I have to use OG/Release v1.00 firmware which kills NVMe support on the system with my FX9590 (support/reseller gave no [censored] about initial launch documentation as its "subject to change").
I realize that board "isn't equipped" to handle the 220w CPUs's but it DID Support and it DOES work, almost 2 years now even, STILL ZERO ISSUES WITH RUNNING THE FX9590! (stress test's galore done as well)

Linked are all the firmware release's from ASRock, maybe someone can figure out how to pull out that damned BLACKLIST... I am even ok if a modder wants to keep the WARNING message in, thats fine, I would prefer that just to cover anyone else who uses this and blows their rig up when they try to overclock

http://asrock.pc.cdn.bitgravity.com/BIOS...00)ROM.zip

http://asrock.pc.cdn.bitgravity.com/BIOS...10)ROM.zip

http://asrock.pc.cdn.bitgravity.com/BIOS...20)ROM.zip

http://asrock.pc.cdn.bitgravity.com/BIOS...30)ROM.zip

I also used UBU on the v1.30 rom to update the AMD AHCI and RAID modules if you would prefer to mod that one instead I can send it to you.


I have paid out bounty's beforehand, I am even mentioned on one of those BIOS modder's blog (now closed to public including me Sad) as someone who has paid!
Payment amount is variable, but was usually between $20-80 depending on difficulty.
Explain exactly (with photos) what happens when you try to boot with FX9590 on different version of BIOS.
(12-04-2017, 01:32 PM)DeathBringer Wrote: [ -> ]Explain exactly (with photos) what happens when you try to boot with FX9590 on different version of BIOS.

Cant really get you photo's sadly.

Suffice it to say, with a 9k series FX CPU on the latest firmware when you turn the PC in it stops with a 1 line screen saying the CPU is unsupported, goes no further, cant get into BIOS, or anything else.

I think someone else already put a photo up here for this, I will try to find it.
EDIT: they pulled the picture, but, its a black screen that says: "This CPU is not in the CPU support list" no need for a photo

Suffice it to say, I'd have to swap out the BIOS chips which I cannot do right now as my 8350 is doing some heavy lifting which cannot be pause/resumed.
OK. I'll try to fix it.
The error string is This CPU is not in CPU support list.
(12-04-2017, 02:16 PM)DeathBringer Wrote: [ -> ]OK. I'll try to fix it.
The error string is This CPU is not in CPU support list.

Thanks,

I just checked my ticket to ASRock when the update was released, that is the string as it shows on the monitor.
I need TXT report of CPU-Z on any system with your FX-9590.
I've found it.
Try to flash my mod.
(12-04-2017, 03:42 PM)DeathBringer Wrote: [ -> ]Try to flash my mod.

Sorry for the delayed reply, family use system, had to get over and find some time!

Ok, attempting to flash with built-in BIOS instant flash, system locks up once I select the file and its transferred over (as indicated by flash drive activity light as seen when doing other firmware updates), also tried with Win flash and the same occurs, system locks up

I dont have the time at the moment, but I will try a UEFI or DOS flash to see if more information is provided to help troubleshoot
Pages: 1 2 3