Bios Mods -The Best BIOS Update and Modification Source

Full Version: [SOLVED] MS7589 MSI P55-GD55 v1, Xeon L3426 support
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Would very much appreciate if someone could help me add support for Xeon L3426 SLBN3 into the AMI BIOS for my MSI P55 Express board (P55-GD55), please?

BIOS v1.9. Latest BIOS from MSI

With Xeon installed, board boots then shuts down after 4 or 5 seconds. Also shuts down if I enter BIOS settings. POST screenshot attached

Possible donor BIOS: Gigabyte P55A-UD3R BIOS v F9 (which Gigabyte claims supports the Xeon L3426) or Latest BIOS v F14b

screenshot from aida64 with working i7-870
Anyone please?

I've tried to follow instructions for ' Add CPU microcode for s771 - s775 boards' but the BIOS editors provided won't open the MSI BIOS file.

Thanks in advance
I've been told the BIOS does contain necessary Xeon codes, so will check for dead cpu asap
modified v1.9 BIOS

I have found success with BIOS modified by BIOS guru  genius239, Xeon L3426 runs well, Windows 10 64bit (link above)


Turbo works well too, have seen 1 core upto 3.45Ghz. all 4 cores upto 2.1

To get it working (after many, many attempts), I had to do the following;
After BIOS update, PC reboots with all settings to default. POST stops with following messages:

CMOS Error, Date/Time not set
Press F1 to enter Settings
Press F2 to load Optimized Defaults and continue

When I tried F1, set date/time and other settings, then Save&Exit, the motherboard would repeatedly reboot without POSTing. 
Once it starts this reboot loop, the only way to stop it, is to clear CMOS using motherboard jumper pins. Maybe removing CMOS battery will work too.
Then it will POST again with above messages

Trick is to to press F2 not F1. Then after a few seconds, before Windows starts loading, I hit CTRL-ALT-DEL to reset. (I think the hard reset button would also work)
When PC reboots, I THEN entered BIOS settings and made all changes (date, time, RAID etc). When I did it this way, everything worked great and my RAID arrays were intact and working

Thank you genius239 !
i have MSI P55M-GD41 (MS7588) with bios 1.10, same problem with edit rom file. can you help me?
It's offtopic here. Start new thread.