Bios Mods -The Best BIOS Update and Modification Source

Full Version: [SOLVED] Xeon 771 Microcodes for Intel DG41RQ
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
My dump of the BIOS chip: [attachment=11023]

My Aida64 screenshot. This screenshot is from my current setup with a 775 CPU, so I'm not sure if it's of much use.

Current problems: I'm trying to use a 771 CPU with it. It POSTs fine, but 64-bit Windows will not boot. 32-bit Windows boots, and Linux seems fine. Also, if a "restart" command is issued from anywhere, either from Windows, Linux, or even the BIOS setup, it'll reboot into nothing, forcing me to do a hard reset.

CPU spec code: SLBBR (I also tested it with a SLBBM, same problems)

Potential donor BIOS: ASUS P5G41T-M LX2/GB (same chipset, and it has the latest 771 microcode)

I guess this is an issue of "CMPXCHG16b / CompareExchange128 not being supported". The microcode in the BIOS is from 2008, so I thought updating it to the latest stuff might help. Delidded's guide said that "Intel may be using a secure checksum to prevent people from modifying [their BIOSs]", but I gave it a shot anyway with donovan6000's Insyde BIOS guide.

I updated the microsode in Intel's provided BIO file as described in that guide, but as semi-expected, none of the official BIOS flashing utilities accepted my mod. So I bought a CH341A programmer and SOP-8 test clips to interface with the BIOS chip directly, to bypass the official tools. I quickly found that, whoops, the BIOS chip is a standrd 8 megabit/1 MB thing, but Intel's BIO file was over 3 MB--it had a bunch of other stuff going on with it. I was messing with the wrong file.

So I took the 1 MB dump and tried to modify that with the same procedure, but I guess the BIOS is all compressed? The microcodes are there, but where I was expecting headers like:

01 00 00 00 07 0A 00 00 08 20 09 04 7A 06 01 00

I instead found:

00 68 00 00 E0 00 EB 4C 81 7D F8 7A 06 01 00 72

Which is not obviously updatable, at least not with donovan6000's guide.

So that's where I am right now. We need some way to "decompress" my dump so the microcode can be easily updated, or we need an alternative way to update it directly. Don't know if that's possible, but I figured it was worth an ask! Thanks!
The bio file we download from intel official webpage , i think it seem contain many fake and protect ,and when i modify it any ,it will not pass flash utility check(windows update package,else) ,it cann't  flashing correctly.

So if we want to modify the intel bios,we need direct read data from chip,after modified we rewrite to chip again.
I use a hot air desolder and solder it again.

I try to modified your dump bios file,maybe you can rewrite it and test.
Here is download link.!H0BD0SYC!1ubD9RR_7d1Mb...FNRvTDghGI

My some experience for inject  771 micro code with intel official mainboard,.as follows.
These board i have sold.
dg45fc can boot by a e54xx 771 cpu,but e53xx it show a uncompatible message then shut down.
dg41an i forgot........
Guys, I need help. I have an Intel motherboard (model DG41RQ) and recently I bought a Xeon x5460 cpu, and I have already seen reports of people using the same motherboard with the same cpu, but I do not know how to install the Xeon microcodes on the bios of my motherboard. I know it's very complicated in the intel bios, I'm not even sure if it's possible, but I really need a tutorial. thank you![Image: hfpm80]
Make DOS USB-stick (e.g, by Rufus), download and unzip all files for the modded version of CHECKUP7 to this DOS USB-stick.
Install your X5460, boot from this DOS USB-stick and make a photo of the screen with results.
Sorry, my cpu has not yet arrived, I believe that Wednesday she arrives at my address. As soon as I arrive I will make what you told me. thank you!
Dear all,
  despite the info available regarding compatibility of Intel DG41RQ with all 771 1333 Xeon, it is not working as expected.

The major problems are two:
1) After the first restart video is gone and you can get it back only executing a shutdown;
2) FAN is always running at 100%.

Windows 7 boots correcly, CPU Z identify the CPU correctly.

I'm already using latest BIOS available and I followed the recommendation of :

but without success.

Next step I will do this:

Assuming that I'm capable Sad, but I would like to know if you somebody might have any experience or suggestion:

Thanks a lot, Andrew
Make DOS USB-stick (e.g, by Rufus), download and unzip all files for the modded version of CHECKUP7 to this DOS USB-stick.
Install your Xeon, boot from this DOS USB-stick and make a photo of the screen with results.
DeathBringer you make it! With your provided CHECKUP7 utility, the FreeDOS USB stick booted and informed me that BIOS is capable to support upgrade of Microcode, then it executed and now everything is working perfectly!

Thanks 1.000.000
Dear DeathBringer,
   unfortunately I was too optmistic, the proposed solution works at 98% with my Xeon X5470.

I'm able to install correctly the OS (Windows 7/10/ Ubuntu SRV 17 does not change...), but if I'm removing the DVD installation master and executing a fresh startup from the shut down system, I'm receiving the error
"Boot failure
Press any key"

The system is capable to boot correctly only if:
- Select manually the boot menu and select the right HD (by the way only one HD is installed...);
- Leave the installation Win 7/10 into the DVD and let the "Press any key to boot from CD/DVD" run.

In these cases, the OS is started correctly and everything works smoothly.

If you use PLOP (a boot manager) to start-up the OS,  the system gives an error that the primary partition signature is wrong and it is unable to boot.

I also tried to play with "UEFI boot options in the BIOS, but nothing changed...

Am I missing something?
Thanks, Andrew
I'm not a tutor for OS installation.
Pages: 1 2