Bios Mods -The Best BIOS Update and Modification Source

Full Version: REQUEST New CPU for my FIC GE5
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hey there,
I got this Mini-Pc for a while now.
It worked flawlessly up until a Year ago. Then the cpu's integrated Graphic-chip started doing displaying Pixel-sector-Errors and gave me blue-screens. Even Ubuntu always froze after 30 seconds.
So I decided To swap the i3 340m for a i5-450m, stocked up the RAM to 8gb and got a new ssd, to boost it up a little.
Here's the Problem: At POST it tells me, it's missing the "Microcode for an alternate Processor".
As far as I understood, all there is needed for this mod, is the original BIOS-file, extracting the original Micro-code and replacing it with the new one.
So I tried and searched and did, what i could, but no matter which way i try to go, there's alsways some crucial progam not working.
In addition this PC is kinda rare and there's not much documentation about it, but apparently it would even work with an i7-Mobile-CPU.
To make it short: I tried and failed.^^
Well, apart from that, it's working, but not as smooth, as it could.
The BIOS is still untouched and working fine.

What I need ist a flashable BIOS-Image for Winphlash with the new Processor-Microcode.

PC-Model: FIC GE5 PCF-55
Bios: Phoenix
Date: March 25th, 2010
CPU: Core i5 450m
CPU-ID: 20655

I attached the Rom Bios Explorer -File, a Winphlash Backup, the Microcode for the new CPU and the report-file from CPU-Z (altough it's with the old RAM and SSD).

Thanks ahead.

P.S: I'm german, so my English might be bad.^^
Try to flash my mod.
Thank you for your help, but I tried and failed again. xD

Can you tell me how I could flash this bios nonthelless?
Btw. Uniflash doesn't work at all.
You need original BIOS for modding.
Well in the First post, I uploaded a zip-File containing the Backup-File from Winphlash and the file i saved with Rom Bios Explorer.
Both of those are made from my untouched, original bios, running on my GE5 right now.^^
Mybe the format is the problem? I seriolsy dodn't know how to convert that.
The only option I can give is the original BIOS as Bin-FIle (created with RBE).
You need ful WPH-file, not dump or backup.
Or use hardware programmer to flash ROM-file.
So far so good.
I spend the last hour looking for a way to get the wph-file from my Bios.
And as far as I understood (correct me, if I'm wrong) the winplash-backup-file is a complete wph-file and just needs to be renamed. This is also the way to flash back to a bios-version you had before.
If this isn't what I need, how do I get it?

And this "hardware programmer" you mentioned, can you tell me more about that?

again thanks for your help
Try to flash new mod.
So I've tried and tried again, set up a new windows and tried again I always get the same result as before.
Maybe I'm doing something wrong? Is there a better way to do this?
I don't know what to do anymore...
I was using a win7 Home Premium 64-bit with and without updates, with all drivers installed and a new fresh OS without anything.
I could also try Ubuntu, but since there's no Phoenix Utility for Linux I know of, I didn't try yet.
Schould I do a DOS-Stick? If so, which Program should I use?
I don't know what to do anymore.
Thanks alot for the help so far, I really apprecriate it.^^
Pages: 1 2