Bios Mods -The Best BIOS Update and Modification Source

Full Version: [REQUEST] Asus IPIBL-LA 45-nm CPU support
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
I have three HP IPIBL-LA (Berkeley) boards (Asus OEMs). These boards don't officially support 45nm processors, though there are reports online of BIOS version 5.13 supporting Q8200 before HP pulled it offline and "fixed" it :

Is it possible to mod this board to support 45nm processors ie. processors I could buy from a store today?

Info I've already found online :

This forum mentions a "lock" on the BIOS, but they were talking about SLIC so not sure if it's relevant :

HPs website for this board :
If you tell us which CPU your planning to use with this board we can try and find another board which supports that CPU and port the microcode over to replace the current microcode in your bios. If a previous release contained support then HP "fixed" it to remove the support then hopefully they just removed the microcode so its just a case of putting it back!

Is there a tutorial online for doing this kind of BIOS mod? I'd like to first test this with an old 90nm Pentium 4 650 (SL7z7) - also incompatible with this board - to see if this can work before dropping down $$$'s. This processor also doesn't work on my useless HP Alhena5 socket 775 mobo - it only supports P4s (601's) and Celerons : . Actually, it would be VERY interesting if the Alhena5 board is also capable of supporting anything different.

The world of BIOS modification looks exciting.
OK, my CPU support update failed - boots fine, but still not working with my old 90nm Pentium 4 650 (SL7z7). I used mmtool to add CPUID 0F43 from another BIOS. Does it matter where I pulled the CPU microcode from? Do I need to make any other change?

Other boards with the same chipset seem to support this processor eg. :
Try at your own risk! I ended up taking support from an Asus bios because they use AMI bioses like this one (the gigabyte one was award!)

No go... beeps straight away as before. Anything else I could try?
as in flashed fine and mod doesnt work or as in bricked?

Il have another look

Not bricked... booting fine /w Q6600.
I'm curious about what else could be done. After much googling I haven't found anything else that needs to be modified for adding support for an Intel CPU to an AMI BIOS. Perhaps I am just not searching correctly?

I have some I.T knowledge and am comfortable at a commandline, and have programming experience even including a little x86 assembly. If there are docs online outlining any extra steps required for tricky BIOS's I could perhaps help myself.
I think these CPU Upgrades are a hit and miss , sometimes more than microcode addition is required :S

Still not figured this one out!

Pages: 1 2 3 4 5