Bios Mods -The Best BIOS Update and Modification Source

Full Version: Dell Inspiron 14z 5423 Bios Recovery Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
(12-31-2014, 04:58 AM)BDMaster Wrote: [ -> ]Hi friend,
Steven wrote to me about You !
So I think the best thing is to get a Bios Backup for your laptop !
So if You are trying to Recover your Bios and You have not done a Backup,
It's a little problem as We have to know your serial and to find where is placed
into DMI Data Bios !
Let me know precisely what do You want to get and do !

Happy New year to you all!

Thanks for getting back to me, I have got the Bios up and running again, here's a more detail version how I did it just in case someone else stuck in the same situation:

1) I have downloaded a copy of the official bios .exe from Dell, then get the fd file out of it.

to get the fd file, I ran the exe file from another computer, then go to the temp folder (in my case, it was under c:\user\yourname\appdata\local\temp, you have enable viewing hidden files under your folder settings).

2) I used from here to get the actually BIOS file name.

3) Then I copy the renamed Bios file to a USB stick, pluged in one of the USB port on the laptop (you might need to try different ports if it doesn't work, normally is the USB/Esata or USB 3 port)

4) I take out the battery for this step, then while holding down the "End" button on the keyboard and Plug in the AC power.

5) Wait for the magic to happen, the computer's fan will run in very high speed and lights are flashing. About 3-5 minutes later, the fan go quiet and computer reboots.

There you have it.

Now I am facing another problem though, even I got the computer back up and running again, and installed a copy of windows 8 trial on it, I am trying to get the embedded windows 8 license key back, tried the following programs, 1) get_win8key - returns nothing, 2)Wpkey - got a whole lot of YYYYY characters, 3)RW_everything under ACPI - not responding till it returns with out of memory, and 4)AIDA64 - got nothing.

Do you think some part of the BIOS is still corrupted?

If you have any suggestions, I'd love to hear them.

Thank you in advance for all your help!
Pages: 1 2 3