Bios Mods -The Best BIOS Update and Modification Source

Full Version: Trying to get an i7 3630qm to work with a Toshiba Satellite c55 mobo
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello, i have been trying to upgrade my pentium 2020m to an i7 3630qm for over a week now. When i install the i7 the computer refuses to boot. I have an hm76 chipset and a g2 socket so the i7 is supported by my hardware. I tried updating the microcodes to no avail. I currently have an unlocked bios which I've attached and i have a programmer so i dont care if it gets bricked. CPU spec code is SR0UX. 

http://support.toshiba.com/support/drive...31&osId=38

This is a link to a bios from a satellite model that comes with an i7 3630qm and uses the same chipset and socket as mine

I'm certain that the bios is the only thing keeping me from upgrading. Any help is greatly appreciated
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with supported CPU.
Describe in details the results of this experiment with i7-3630QM.
When  i got this laptop it had an hm70 chipset and a pentium 2020m. After upgrading the RAM i started researching the possibility of a cpu upgrade. After a week or two of research i i learned that Toshina satellite c55 laptops all use the same motherboard, even the model number (db10f-6050a2566201-mb-a02) is the same, but with varying chipsets. Eventually i figured out that the boards part number corresponds to its chipset. A board with part number v000325060 has an hm70 chipset where as a part number v000325050 means it has an hm76 chipset. Besides the chipset and part number the boards looked identical so i concluded that i would be able to swap them out with no compatibility issues. I found an hm76 board on ebay for $48 and also found the i7 3630qm for $70 which i decided to get because it was the cheapest quad core i7 i could find that supports hm76 and socket g2. In theory, everything should have worked perfectly but i figured the bios would get in the way. Sure enough when i put it all together the laptop didn't boot, the board was getting power but it wouldn't activate the cpu no matter what. So i popped the pentium back in and it booted right up as if i'd never changed boards. i figured maybe an unlocked bios would solve the problem but theres nothing in the advanced options that enableds support for more cpus, i figured it wouldnt work but ive wanted a modded bios for a long time anyway. So i started researching how to add support for more cpus, the the best i could come up with was updating the microcode. However, none of the tools i could find would actually insert the new microcode. During this time i found that my current bios has a microcode (cpu000306A9_plat12_ver00000015_date2012-08-07.bin) with the same cpuid as the i7 which happens to be the pentiums cpuid too. Its outdated, the newest microcode for that cpuid is cpu000306A9_plat12_ver0000001C_date2015-02-26.bin. After this i started looking for a satellite model thats sold with an i7 3630qm and found one that has the hm76 chipset. I got its bios from the support page and the extracted its microcodes, turns out their microcode definitions are exactly the same. After discovering this i was stumped, there isnt enough information about this for me to figure out whats wrong
What's the native model of your laptop?
it was originally c55-a5309
Try this algorithm:
1) remove AC jack, Main Battery, and CMOS Battery
2) remove HDD and all DIMMs
3) install new CPU
4) wait 10 mins
5) press and hold power button for 30 sec.
6) install CMOS Battery and one DIMM only, inject AC jack (without Main Battery!)
7) try to boot your laptop.
I tried it and got the same results
I have two versions:
1) your i7-3630QM is dead.
2) power subsystem on this motherboard doesn't support CPUs with TDP=45W.
BTW: part number of this laptop is PSCF6U.
I actually have no idea if the cpu is dead or not. The seller said it was tested working but i dont know how to test it myself. Is there a way to test it with a multimeter or something?
I don't know...
Pages: 1 2