Bios Mods -The Best BIOS Update and Modification Source

Full Version: [REQUEST+REWARD] Add AES-NI support to IBM x3500 M3 firmware
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6

Whilst this forum has proved to be an excellent source of information, I'm afraid that modifying the BIOS to enable AES-NI is beyond me. It's taken me two weeks of research to get the BIOS extracted and to be able to read and play with the contents, but I've hit a brick wall. Therefore I'm happy to provide a $100 reward or make a donation/contribution if someone can help me achieve this.

Download link:

The download link contains:
  • UEFI BIOS version 1.15 build Y4E160AUS date 07/31/2013
  • AIDA64 reports
  • VMWare ESXi hardware report

I tried to follow the post rules, but if I haven't for some reason please let me know and I'll resolve the issue.

Have you a hardware programmer?
Make TXT report of CPU-Z.
Make BIOS backup by Universal BIOS Backup ToolKit 2.0.
BTW: Don't make it from inside virtual machine.
I'm not a hardware programmer

I've added the CPU-Z report to the download link

I'll add the BIOS backup output once I get around my antivirus blocking it. Although shouldn't I run a similar tool from a bootable usb and not a Windows guest VM?

Edit: I ran the tool, but it couldn't identify the BIOS.
I mean a hardware programmer like this - CH341A
[Image: s-l300.jpg]
Your CPU-Z report is useless because of VM.
I don't have a hardware programmer. I can order one.

Yeah I figured the reports would be useless. I tried to run some tools from bootable USB to get the BIOS, but I didn't have any luck. Is there a DOS tool that would work? I can try the bootable USB again.
Try Windows Live DVD. Or install Windows.
I'm downloading what I need to create a Window live dvd. I'll give it a go tomorrow and see if it boots and if I can get the BIOS with Universal BIOS Backup ToolKit 2.0.
If there's a linux or dos version of the program that does the same thing I already have boot disks for those.
(01-11-2018, 09:56 AM)AdamBearWA Wrote: [ -> ]If there's a linux or dos version of the program that does the same thing I already have boot disks for those.

1. Download AMI Flash Utilities
2. Extract and copy files from amiflash\Aptio\afudos\\AfuDos\ to USB stick with native DOS
3. Boot from bootable USB stick with native DOS
4. Run
afudos OLD.ROM /o
I need result file old.rom

Boot into Linux (not VM) and run
sudo modprobe msr
sudo rdmsr 0x13c

Show the result
I have a made a Windows bootable USB a dos bootable USB and an Ubuntu bootable USB.
I'll try them all and see which one works to get the BIOS and other requested items over the next couple of days
Edit: I originally tried with Ubuntu 15.04 and then again with 16.04.03. Both had the same results.

On ubuntu I ran the following commands from a root terminal:
sudo apt-get update
sudo apt-get install msr-tools
sudo modprobe msr
sudo rdmsr 0x13r

The output from the last command is:

rdmsr: CPU 0 cannot read MSR 0x00000013

I tried this command too: sudo strace rdmsr 0x13r and got this result:


open("/dev/cpu/0/msr", O_RDONLY|O_LARGEFILE) = 3
pread64(3,, 0xbf8471c0, 8, 19) = -1 EIO (Input/output error)
Pages: 1 2 3 4 5 6