Bios Mods -The Best BIOS Update and Modification Source

Full Version: [CPU Upgrade] HP ProDesk 400 G1 MT problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi everyone, I'm new here.

I have an HP ProDesk 400 G1 MT with an Intel i3-4130. In order to get a performance improvement, I decided to change the original CPU with an i7-4790. After the CPU change, the computer runs fine... until I reboot it.

During the reboot process, the computer seems to be blocked and the only way to shutdown is to press the power button. Searching the web, I found other people have the this strange behaviour:

Obviously I have installed the latest BIOS version (02.56 Rev.A). You can find it HERE.

The same CPU in another machine works well. I've tried also an i5-4590 but the problem is the same.

This problem is OS indipendent because if I press Ctrl+Alt+Del in the BIOS in order to restart the computer, the problem persist.

It's very hard to believe because this computer is sell with this two processor (i7-4790 and i5-4590). So why there is this problem ? Is it a BIOS lock feature ? Is it possible to have a new BIOS with support both of the CPUs ?
Can you enter in BIOS in your i7-4790?
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with supported CPU.
Make a photo of this motherboard near a socket.
Hi @DeathBringer,

first of all thanks for the answer. Yes, I can enter the BIOS with the i7-4790. Attached a photo take when I had installed the CPU for first time. Also, the power supply is the original HP equipment (300W) and I think is enough considering that this computer have only the integrated graphics.

Can you disable Turbo Boost in BIOS?
Remove heatsink and make photos again.
Have you any discrete graphics card for test?

no, I can't disable the turbo boost from the BIOS (the options available are in the photo below). I've also tried to disable some of them with no luck. The i7-4790 is working great in another computer with the integrated GPU. Anyway yes, the graphics card slot is working (tried some weeks ago just for test with a discrete graphics card).



You need to test your system with i7-4790 and any discrete graphics card.
I've installed the i7-4790 again paired with an AMD 5450 HD. This discrete graphics card have a low TDP, so I don't need to change the PSU. Unfortunately, the problem persist. The computer boots up, recognize the processor, enter in the BIOS and when I try to reboot with the combination Ctrl+Alt+Del the screen became black and nothing happen. I think it should be some BIOS lock feature.
OK. Enter in BIOS with new CPU, then go to Save & Exit and do Restore Defaults, then Save Changes and Exit.
After that procedure, the issue is still present. Also, in order to reset the CMOS values, I've tried to remove and reinsert after a minute the CMOS battery and then press the yellow button on the motherboard. Nothing. It's incredible that only the reboot fail and for the rest it work perfectly.
So I have no more ideas.
Pages: 1 2