Bios Mods -The Best BIOS Update and Modification Source

Full Version: HP DL145 Opteron G3/G4 MicroCode Updates
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
The AGESA is not in the Update00 section. In AMI bioses it is located within the main bios file (1B) which has to be decompressed first.

We can ATTEMPT AMI AGESA upgrades but we never got any feedback.
Hmm. Sounds painful for you all. Do you think I should try this Gigabyte combined I created? At least it lists supporting 6 core. I just don't know if what I was told about the update00.rom section being chipset independent is true.

I ask simply because its 00update was completely different than the hp stock. While comparing to the combined the tyan/hp one it had a few matching areas but most was still new.

In example the text in the hex has "AGEAS" right near the top of the file. The HP has nothing. Which I assume they stripped all information? Anyhow it compiled fine.

Actually I found the Tyan n3600t . Which has the newer AGEAS and is Phoenix - just not the same chipset. So if I don't need to keep any portion of the original cpu update module as its all self contained and same between all Phoenix bioses. I could go this route. So thats the stinker. Can I just totally replace the update00 module?
In theory you can just replace one Update00.ROM with another. However , we have not experimented with this and if you are going to try it we would really appreciate you letting us know how you get on.

When we do AMI and Award Microcodes , we literally rip it out of one bios and insert it / overwrite in another so you could assume same goes for Phoenix (BUT DONT QUOTE ME!)

(08-29-2010, 05:24 PM)TheWiz Wrote: [ -> ]Yes, it is possible that AGESA and or ACPITBL need to be updated. I would first check though to make sure the microcode entries really were updated (check windows timestamp)

from my experience with AMD CPU upgrades, the microcode is merely bug fixes for the newer stuff and doesn't help with detection, so an AGESA update should be considered.

Ok so I used the Tyan Phoenix bios for the s2937 Which had support for Agesa 3.5 and latest Socketf. Simply replaced the whole phoenix update00.rom "Cpu Update" module. I was told elsewhere the microcode and AGESA should not change between chipsets so took the chance and compiled and flashed.

Posts and works fine with the old processor but it wont see the new processor. For [censored] n giggles I also tried the Tyan S4985 which is 4way server since CPU using is meant for 4-8way. Still nothing.

So I guess the final thing to try is ACPITBL. I first don't know what submodule rom in the Phoenix this would be at and I assume unlike the Cpu Update module this will be chipset specific. Thus I will have to use the AMI Tyan S3992-E for this and Hex into the Phoenix.

NO Idea how the begin this. Any help appreciated. Also updated with the new files.


Found a tool that let me extract the ACPI and AGESA files from the 1b module in the Tyan AMI S3992-E Bios. Again this is the Bios using the same chipset unlike rest. Have made a new folder with them all in in the above. Have no idea of how to compile into the HP as some are split or combined depending on which.
dude, props for the testing man, that's nice work! yes you are correct the ACPITBL has to be uber siilar, same chipset, no
exception. Give me time to disassemble your ACPITBl so we can make a rational descision here.

Nice Work!

Thanks Wiz. In the meantime a local reseller is going to let me try this new cpu I bought on one of their used servers. Just so I can scratch off the slim possibility I was sold a dud being why its still not working.
For another option try this:

Theres a universal AMD microcode file found in award bioses which is 28kb and contains all AMD microcode. Ive renamed it to UPDATE00.ROM and completely replaced the old module. If you want to give it a go while you wait for TheWiz to look at your ACPI tables then you do so at your own risk!

Of course. Does it include the newer AGESA as well? From what I have been told the Update00.rom is where they all have to be placed.

Got a local company to test the newer cpu. Posts. So can check that off.
No AGESA , i dont really know where it lives in Phoenix bioses , but ive replaced the entire CPU Microcode module.

Worth a try if your prepared to take the risk

If you look at the Tyan s2937 you will see reference to the Agesa in the Update00. I had also looked at a Gigabyte at one point and it as well has the Agesa. Unless they both were just references to somewhere else? 50k though so somethings got to be in them (even though using the Tyan didnt do squat).
I did try a hex match to the extracted 3992-E AMI. But the Agesa in that is in two portions and thus might be compiled differently when combined. As when I attempted a comparison to the s2937 in Hex Workshop very little matched.

I dont think I could use it alone. However. I wonder if it would be possible to integrate into the Tyan update00 module I included as to keep the AGESA and it changes the microcode. Thoughts?
Pages: 1 2 3 4 5 6