Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASUS UX501JW notebook bios with SSD NVME support
I think I need help again !!!

I followed your last post :
- I did the setup_var command under grub, value was set to 0x0 from 0x1 
- but the flash of the modded BIOS under windows with fpt64w failed again with the error 280
- I then downloaded the prr / prr2 zip, and copied them to a USB dos key
- prr gave a success message
- I launched ftp -bios -f biosregm.bin (the modded bios you prepared for me)
- the flash seemed ok, until the verification phase ended with the following message :
"Error 204 Data verify mismatch found"

And now, I'm afraid my machine is bricked, when I power it on, I only have leds, but blank screen  Sad

I forgot to copy the stock BIOS on the USB key, which I think would have allowed me to reflash stock BIOS after the error above, but it's too late. And I'm not aware of any BIOS recovery method for my laptop ...
Well, I managed to revive the laptop with the following steps :
- download stock bios from Asus Site
- copy it to a USB key under the name N501JW.BIN in my case (this is the "platform name" for Asus)
- put the USB key in the single left-side USB port (don't know if that matters)
- Hold Ctrl+Home keys and power on (Ctrl+Home seems to be the magic combo, provided the bios file is properly named)
- I instantly got an Easy Flash screen which flashed the stock BIOS 
- And there we go again ...

I must admit I was a bit scared to be obliged to go for a RMA, but everything finishes well.

As I'm not the kind of guy to give up, and now have a working recovery method, which btw could be useful for others, I'm ready to keep on trying various methods to flash this ***** modded BIOS with NVMe support  Smile
And finally I think I can proudly report a success  Cool

I decided to redo the whole thing from start, based on AFU 3.0.6 :

- I dumped the stock BIOS with AFUWINx64
- I inserted the NVMe DXE module with UEFItool
- I flashed the modded BIOS with AFUWINx64, no special option like /GAN, no error about write protection
- Reboot OK
- I dumped again and the NVMe DXE module is there !

Obviously FPT is not the most reliable tool for this platform, or I did not use the good version, which is weird as I got the Intel package matching my ME version. Well, BIOS modding is not an exact science for such a noob like me!

Now I can order the Samsung 970 Evo Plus for my laptop, as soon as it is more widely available and reasonably priced in France.

Evil is in the detail ! Before spending 250€ for a high-end component, I double-checked the PCIe speed of the M.2 port on the laptop, and that's bad news ... The HM87 only supports PCIe 2.0, the first Intel chipsets supporting PCIe 3.0 are the Skylake ones of the 100 Series, launched two years after the 8 Series. 
With PCIe 2.0, the data rate per lane is 500 MB/s, minus a 20% overhead due to 8b/10b encoding. On a x4 port the best effective data rate is thus around 1,6 GB/s. PCIe 3.0 has a data rate per lane of 1 GB/s, minus 1,6% overhead (128b/130b encoding), ie 985 MB/s * 4 = 3.94 GB/s effective data rate on a x4 port. It is sadly confirmed by user benchmarks where a Samsung SM951 NVMe SSD on a M.2 PCIe 2.0 x4 port is capped at circa 1600 MB/s R/W, where recent drives reach 3600 MB/s in a PCIe 3.0 port x4... (see
For other "old" Asus Zenbook owners, that means the UX501VW model (opposed to the UX501JW) with its HM170 Skylake chipset would be a far better candidate for an upgrade to a recent NVMe SSD, esp. for those who own a version with 128GB SSD and 1 TB HDD.

You will notice btw that the latest SSDs are close to the theoritical PCIe 3.0 max data rate. So it's clearly time for PCIe 4.0 to be implemented on chipsets and CPUs (AMD X570, Ryzen 3rd gen were announced for "mid-2019" during CES 2019, nothing from Intel afaik) to support the first next-gen PCIe 4.0 SSDs announced well above the sequential R/W 4 GB/s barrier...

Back to my initial subject, my laptop is too old for the upgrade to be fully efficient, only a small half of the SSD speed capacity would be reached. On the other hand, the last SATA M.2 by Samsung (860 Evo) tops at 500/550 MB/s due to SATA 3 limitations. Now the question is, will I see any significant difference in real life on a O/S disk between my stock 128 GB Samsung CM851 SSD (550/130 MB seq R/W), the 860 Evo (550/525) and a 970 Evo Plus (1600/1600) ? I think I will give it a try, but I'm not very confident. And the 970 could probably be reused in a future configuration, but by then PCIe 4.0 will be the standard, and the SSD will be outdated ! Life is not simple for geeks  Wink

Finally, the situation is different for you sonoboyster, as I understand you already have the WD Black NMVe 256 GB drive, which will in any case be an improvement in terms of storage capacity. So keep on trying, I managed to mod my Bios I'm sure you can also !

Thanks again for your time and patience LOST_N_BIOS, and I do hope sonoboyster will also succeed in this project.
Glad you got it all sorted out now! Yes, AFU is sometimes better for Asus BIOS, when you know the AFU version that works with modified BIOS
The FPT issue is more likely related to what the PRR/PRR2 app did, not the FPT operation itself, so the better thought there is PRR/PRR2 is not ideal for this model. Data mismatch is FPT comparing file you gave it to file it read back from memory of that same file, so could also be USB or source (Disk) or system instability etc. I lean more towards PRR/PRR2 causing some issue, either itself being the issue, or causing some issue that messed with FPT

BIOS mod for anyone is an art, not a science, only some things can be done scientifically, many other BIOS modifications are more of an art Big Grin
Thanks for posting your method, can you please link the AFUWin you use, so sonoboyster can also use that too instead of FPT thanks!
Hello again,

I used AFUWINGUI 3.07.00 to both dump and flash the BIOS. I know flashing from Windows is not the safest way, but as I knew I could recover from a bad flash (see Ctrl+Home above), I took the risk.

It was downloaded from this thread :
Download links : or

The AFUWINx64.exe is the same version 3.07.00, so it should work aswell. As for the included AFUDOS.exe, it is version 3.06.01. I haven't tried this DOS version to flash.

I have just dumped my current modded bios from both AFUDOS and AFUWINGUI and then compared the resulting files in HxD. They are not strictly identical but there are very few differences. Maybe that can be explained by the fact that I had to modify bios settings (enable CSM, boot order, ...) to boot from the USB DOS key and run afudos, and then reverted to regular settings to boot into Windows and dump with the Winx64 GUI version ?

So I think sonoboyster could try this AFUDOS  on a USB DOS key prepared by Rufus as I did. Even if the flash were to go wrong, he could anyway recover the stock bios with the Ctrl+Home combo.

As for the insertion of the NVMe module, I used UEFITool as a reminder, not MMTool.

Hope that will help  Wink
Thanks for the info for sonoboyster. I too use UEFITool not MMTool!

Yes, your dump wont match exactly due to checksums, settings changes / NVRAM changes etc
Hey there,
I'm using UX501JW as well and I followed Gnomuz method but still no luck to make my NVMe SSD works.

My new NVMe SSD is Silicon Power P34A80 1TB (

Here is what I did:
1. I dumped the stock BIOS with AFUWINx64.
2. Then I inserted NvmExpressDxe_4 with UEFItool.
3. I flashed the modded BIOS with AFUWINx64 then reboot.
4. I dumped again and found the NVMe DXE module in there.

My NVMe SSD doesn't show in the BIOS or in the Windows 10 setup. I have AHCI on and disabled CMS, secure boot, fast boot but still no luck.

Please help me Sad

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in