Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Corrupted interface descriptors in the new BIOS file"
#1
Howdy!

I'm trying to flash my XPS 15z over to a modded BIOS in order to gain access to a few more features, but haven't had any luck. Seeing as I run Linux, I booted to a freeDOS and tried flashing using Phlash16 with various options, but to no success. Finally after some digging, I found someone saying they had more luck using the Windows app. I installed Win7 to a spare SSD but received the same error message. 

The guide I'm using is:
https://www.bios-mods.com/forum/Thread-U...-and-HOWTO

What I'm unsure of is if I'm supposed to mod my OWN BIOS, or if the files in his attachment can be for any XPS 15z (which is typical of any other BIOS mods I've done).

Here is the full error message:



Corrupted interface descriptors in the new BIOS file
Part Table Signature not found in the interface 
Error code: -161
find
quote
#2
Can you flash a non-modified BIOS file with Phlash16? If stock gives you same hassle, maybe you need winphlash, or just a different version?
There's three different .ini's in this package, try with each one (rename to just PHLASH.INI to use)
http://s000.tinyupload.com/index.php?fil...8305894197

Or, could just be a bad BIOS mod, or possibly a freeDOS Issue (try Win98 SE)

From what I read at a quick glance, that looks like he's sharing the mod BIOS he's already done and updated a few times too. And also tells you how to mod yourself too if you wanted, and it looks like maybe that was written before he added the fully unlocked BIOS.

I don't see anywhere in that first post about how to flash, so you'd have to link me to the exact post so I can see his suggested method. That's a huge thread, surely there is a correct working flash method posted in there somewhere
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in