Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dell Optiplex GX280 NX support

I'm interested in modding my bios to see if I can switch on NX support which is required for Windows 10. The Bios revision is A08 and hasn't been updated for some time (since 2011) and I've flashed it with the latest version available. There is no option to switch in NX support for the CPU.

I'm close to just giving up on the machine for Windows but I'm a tinkerer at heart and it seems like this must be possible somehow. Do I have any hope of unlocking the bios and getting it to support NX? I've been in IT for 20 years, know some programming (PHP, Objective-C, Swift, Javascript) and am not afraid of getting my hands dirty.

I only plan to put on an eval copy of Windows so am not bothered about licensing issues or scoring a free upgrade. The machine will be used as a pen testing target and for (hopefully) running Win 10 & the Edge browser. I can do all of this via Virtualbox but I'd like to just explore whats possible.

Processor is P4 with HT @ 3Ghz

Please tell me S-spec of your CPU or show a screenshot of first tab CPU-Z.
If your BIOS haven't Execute Disable Bit option in Security then BIOS don't control NX bit. So you simply need CPU with NX bit support.
I've analyzed your BIOS (A08) for microcodes:
Version Date       CPUID Core       Stepping  | Version Date       CPUID Core        Stepping
01E     06/05/2003 0F24  Northwood  B0        | 002     12/09/2003 0F37  Prescott    C1
038     06/04/2003 0F27  Northwood  C1        | 017     04/21/2005 0F34  Prescott    D0
02D     08/11/2004 0F29  Northwood  D1        | 016     04/21/2005 0F41  Prescott    E0
029     08/11/2004 0F25  Northwood  M0        | 003     04/21/2005 0F49  Prescott    G1
005     05/08/2003 0F13  Willamette E0        | 005     01/24/2005 0F60  Cedar Mill  A0
012     08/13/2003 0F30  Prescott   A0        | 007     06/10/2005 0F61  Cedar Mill  B0
00B     10/21/2003 0F31  Prescott   B0        | 004     07/20/2005 0F62  Cedar Mill  B1
00A     05/11/2004 0F32  Prescott   B1        | 005     04/21/2005 0F43  Prescott-2M N0
00C     04/21/2005 0F33  Prescott   C0        | 004     12/14/2005 0F4A  Prescott-2M R0
NX bit is supported by these models of Pentium 4: 5xxJ, 5x1, 5x6, 517, 519K, 524, 6xx
and by these models of Celeron D: 3xxJ, 3x1, 3x6, 355

Thanks for your reply. I've done a bit more digging and realised that the processor doesn't support NX. Here's the output from cpuinfo on Linux (I don't have an existing version of Windows on the machine).

I suppose my next question is, If I get one of those processors and I still get the same problem (Windows 10 won't install - there is no error message, the machine just restarts) would it be possible to add the NX flag in the BIOS?

Also, would I be able to push beyond those CPUs that you have listed or do I then hit chipset limitations? The ones you have listed are the officially supported ones I believe.

I think this is probably my one or very close:

Is there another way to get the S-SPEC number other than by looking on the actual physical chip?

processor    : 0
vendor_id    : GenuineIntel
cpu family    : 15
model        : 3
model name    : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping    : 4
microcode    : 0x17
cpu MHz        : 2992.539
cache size    : 1024 KB
physical id    : 0
siblings    : 1
core id        : 0
cpu cores    : 1
apicid        : 0
initial apicid    : 0
fdiv_bug    : no
f00f_bug    : no
coma_bug    : no
fpu        : yes
fpu_exception    : yes
cpuid level    : 5
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pebs bts pni dtes64 monitor ds_cpl cid xtpr
bugs        :
bogomips    : 5985.07
clflush size    : 64
cache_alignment    : 128
address sizes    : 36 bits physical, 32 bits virtual
power management:
Can you take off your CPU and make a foto? Or just writedown all info from it.
What kind of Windows 10 you tried to install - x86 or x64?
(10-24-2015, 05:01 AM)DeathBringer Wrote: Can you take off your CPU and make a foto? Or just writedown all info from it.
What kind of Windows 10 you tried to install - x86 or x64?

Hi. Its x86 Windows (32-bit) as I know its not a 64-bit processor. I've only just put new thermal paste on the CPU so am a bit reluctant to take it out as the heatsink assembly is a bit temperamental.

Another chip I have lying around is this - (S-Spec SL9S8) so it would be useful to know if that might work.

Thanks for your help and replies.
You can't boot CPU with Conroe core on your motherboard. E6600 has Conroe core.
Can you make bootable usb flash drive with Windows 7?
(10-24-2015, 05:25 AM)DeathBringer Wrote: You can't boot CPU with Conroe core on your motherboard. E6600 has Conroe core.
Can you make bootable usb flash drive with Windows 7?

Thanks. I could do that but if it wouldn't get me the S-Spec number then not much point - I specifically wanted to Install Windows 10 so I guess I am out of luck unless I buy another processor.

Thanks again.
Installer with Windows 7 is needed for verifying your processor.
Boot with it and when first interactive window pop up then press Shift-F10 for command line.
Enter a command:
wmic OS Get DataExecutionPrevention_Available

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in