Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 7 Vote(s) - 3.71 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
Need BIOS for ASUS GL10CS
Last Post: Viktorian
Today 02:45 AM
» Replies: 0
» Views: 0
HP MCP61PM-HM (Nettle2) 5.27 With Unlock...
Last Post: TheWiz
Yesterday 09:29 PM
» Replies: 870
» Views: 697175
GA-970A-UD3 back to Award rev 3.0
Last Post: mjd79
Yesterday 05:49 PM
» Replies: 0
» Views: 0
[REQUEST] HP Pavilion G7 unlock bios
Last Post: alpitu21
Yesterday 04:59 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad T540p (GMETxxW...
Last Post: Dudu2002
Yesterday 01:45 PM
» Replies: 108
» Views: 32928
Request: Nitro 5 AN515-45-R0B6 BIOS unlo...
Last Post: Dudu2002
Yesterday 01:42 PM
» Replies: 13
» Views: 1677
Surface Go 2 Bios Password advice please...
Last Post: BlackC4t
Yesterday 10:32 AM
» Replies: 0
» Views: 0
[REQUEST] Acer Aspire 3630 BIOS unlock
Last Post: Alex68
Yesterday 06:55 AM
» Replies: 19
» Views: 5203
[REQUEST] Lenovo G500 (78CNxxWW) Whiteli...
Last Post: jinnfriend
Yesterday 05:19 AM
» Replies: 1268
» Views: 245624
Clevo P775TM1-G BIOS
Last Post: UzY3L
Yesterday 05:04 AM
» Replies: 157
» Views: 53643
[REQUEST] Lenovo Yoga 2 13 (96CNxxWW) WW...
Last Post: Dudu2002
Yesterday 02:46 AM
» Replies: 222
» Views: 56197
( UEFI ) Unlock request for Dell L702x B...
Last Post: Maxinator500
01-27-2023 11:35 PM
» Replies: 69
» Views: 76894
[Request] Lenovo P580 Whitelist Removal
Last Post: olipicadura
01-27-2023 07:24 PM
» Replies: 173
» Views: 39118
[REQUEST] Lenovo B590 (H9ETxxWW) Whiteli...
Last Post: Dudu2002
01-27-2023 03:16 PM
» Replies: 802
» Views: 155190
[REQUEST] Toshiba Satellite L50-B BIOS U...
Last Post: ege231213
01-27-2023 01:17 PM
» Replies: 7
» Views: 1518
[REQUEST] Whitelist Removal Lenovo L440
Last Post: mourgolukos
01-27-2023 01:03 PM
» Replies: 164
» Views: 43522
[REQUEST] Lenovo Thinkpad X240 (GIETxxWW...
Last Post: Innokentiy
01-27-2023 09:03 AM
» Replies: 410
» Views: 111898
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: Dudu2002
01-27-2023 07:08 AM
» Replies: 842
» Views: 176888
ASRock X299 CREATOR
Last Post: BerndVP
01-27-2023 01:45 AM
» Replies: 0
» Views: 0
Cannot find BIOS.cap for Lenovo V145-15A...
Last Post: hippy1970
01-26-2023 11:34 AM
» Replies: 0
» Views: 0

[REQUEST] Lenovo Thinkpad T420 (83ETxxWW) Whitelist Removal
(12-23-2018, 08:23 AM)zmb Wrote: ...
- Re-signed with custom key to get rid of 5 beeps on boot (Does anybody have these beeps? If you get the error 1901: or some nonsense about security after this, you need to reset bios settings to defaults)
...

@WilbertCastro read a bit more before random flashing please.
find
quote
(09-08-2020, 04:24 PM)ZOMG Wrote: Anyone managed to flash this using pflash.exe (the tool supplied on the bootable CD)? I don't run Windows.

When doing

Code:
pflash.exe /sv /sd 83ET82WW\$01C8000.FL1

It tells me "Fail to authenticate image". Used the image linked above.

For anyone struggling with this, I finally managed to flash this using a Windows 10 (20H2) based PE boot disk: c't Notfall Windows 2021 (German description only, sorry).

Important: You need to boot in Legacy (CSM) mode, otherwise the flash will fail.

I used the following command:
Code:
winflash.exe /sv /sd 83ET82WW\$01C8000.FL1
find
quote
I was successful in flashing a Lenovo ThinkPad T420 using the 1.52 flash at https://uc23158c0d1c93ca8cc074b9a29b.dl..../file?dl=1#.

I had already flashed the laptop to the Lenovo-genuine BIOS version 1.52 using the ISO from Lenovo on a burned CD-R.

To flash the BIOS again with this custom 1.52 image, I had to install Windows 7 Pro x64 and did it without entering any product keys or installing drivers. The OS install took less than 15 minutes, then I could flash. If you try to flash on Windows 10, you will get a BSOD on winflash.sys or something.

To flash, I launched an elevated Command Prompt and used cd to set the working directory to the same directory as winflash.exe from the extracted contents of "T420_bios_1.52_NWL_ADV_0xE2_AES-NI_RAM_VBIOS_SIGN.7z".

Then, I executed the following (source: "!HOW_TO_INSTALL.txt"):
Code:
WINUPTP.EXE /S

The program launched but did not have any output and did not hold Command Prompt up until it finished running. The program ran in the background. During this time, do nothing - though feel free to watch Task Manager for WINUPTP.EXE and winflash.exe. Do note that during the flashing it may look like the system freezes, but leave it alone and be patient and WAIT. If you are a careful observer you might notice that it has not frozen and that the timescale of processing has just slowed down to a practically unusable degree. This is normal. Just don't touch.

When you have waited 5 minutes, check the folder that WINUPTP.EXE is in, sorted by Date Modified (newest to oldest). One of the files should be a TXT or LOG file for WINFLASH.EXE. Open that log file and scroll to the bottom. If the flashing is done, there should be a message near the end of the file that plainly says that the flashing is complete and done.

Lastly, for extra measure, check the Details tab of Task Manager to make sure that none of the EXE files from where WINUPTP.EXE and WINFLASH.EXE are running. If anything is still running, continue to wait until all EXEs from the same extracted folder have finished running by themselves.

Then, reboot. Get into BIOS with F1 (setup) or F12 (boot menu) and explore the menus. Confirm the version is 1.52 and confirm that some of the menus now show a crazy number of submenus and settings you didn't have on the Lenovo-genuine BIOS image.

Congrats!
www find
quote
I upgrade my bios to "T420_bios_1.52_NWL_ADV_0xE2_AES-NI_RAM_VBIOS_SIGN.7z". And change cpu from i5 to i7(45w). When i try set cpu current setting and reboot my t420 black screen, and CMOS reset do nothing. I guess im input very low current setting for cpu correct start..

I solder bios chip from another t420 board, and all working fine (except ME, show "Recovery ME state.."). Any idea how i can recover original bios chip?
So i made dump bios with wrong settings with programmer: https://drive.google.com/file/d/1cdcKRL0...sp=sharing
find
quote
Could you please remove the whitelist of my BIOS?

-Manufacturer: Lenovo
-Model: Lenovo T420
-Bios Revision: LENOVO-83ET82WW(1.52)

https://www.sendspace.com/filegroup/vdTg...VhU2Ze4JAw

Thank you very much.
find
quote
Posted by: BlueToast
Junior Member
**
#353 02-12-2021, 03:45 PM (This post was last modified: 02-12-2021, 03:45 PM by BlueToast.)
I was successful in flashing a Lenovo ThinkPad T420 using the 1.52 flash at https://uc23158c0d1c93ca8cc074b9a29b.dl..../file?dl=1#.

I had already flashed the laptop to the Lenovo-genuine BIOS version 1.52 using the ISO from Lenovo on a burned CD-R.

To flash the BIOS again with this custom 1.52 image, I had to install Windows 7 Pro x64 and did it without entering any product keys or installing drivers. The OS install took less than 15 minutes, then I could flash. If you try to flash on Windows 10, you will get a BSOD on winflash.sys or something.

To flash, I launched an elevated Command Prompt and used cd to set the working directory to the same directory as winflash.exe from the extracted contents of "T420_bios_1.52_NWL_ADV_0xE2_AES-NI_RAM_VBIOS_SIGN.7z".

Then, I executed the following (source: "!HOW_TO_INSTALL.txt"):
Code:
WINUPTP.EXE /S

The program launched but did not have any output and did not hold Command Prompt up until it finished running. The program ran in the background. During this time, do nothing - though feel free to watch Task Manager for WINUPTP.EXE and winflash.exe. Do note that during the flashing it may look like the system freezes, but leave it alone and be patient and WAIT. If you are a careful observer you might notice that it has not frozen and that the timescale of processing has just slowed down to a practically unusable degree. This is normal. Just don't touch.

When you have waited 5 minutes, check the folder that WINUPTP.EXE is in, sorted by Date Modified (newest to oldest). One of the files should be a TXT or LOG file for WINFLASH.EXE. Open that log file and scroll to the bottom. If the flashing is done, there should be a message near the end of the file that plainly says that the flashing is complete and done.

Lastly, for extra measure, check the Details tab of Task Manager to make sure that none of the EXE files from where WINUPTP.EXE and WINFLASH.EXE are running. If anything is still running, continue to wait until all EXEs from the same extracted folder have finished running by themselves.

Then, reboot. Get into BIOS with F1 (setup) or F12 (boot menu) and explore the menus. Confirm the version is 1.52 and confirm that some of the menus now show a crazy number of submenus and settings you didn't have on the Lenovo-genuine BIOS image.

Congrats!

**************************************************************************************************************************************

Thank You
BlueToast
Bios 1.52 Success
Mirror BIOS FILE: https://mega.nz/file/2F9z2TTS#H8iVsWSwVc...DuFGUu_O04
find
quote
Greetings,
I'm sorry for my english.

I installed the bios T420_bios_1.52_NWL_ADV_0xE2_AES-NI_RAM_VBIOS_SIGN

Unsupported wifi cards are installed and they work great.
The only thing I can't ... Is to install the WAAN LTE cards (I have tried 3 but nothing ..), the computer does not start and makes several beeps ... The white list remained in the WAAN slot?

Nowhere can I find a person who confirms to me that she managed to get LTE 4g to work on the T420

Have you succeeded?
find
quote


Forum Jump:


Users browsing this thread: 8 Guest(s)