Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo G510 (79CNxxWW) Whiteli...
Last Post: intense
Today 04:48 AM
» Replies: 643
» Views: 158070
HP Proliant Microserver AMI BIOS MOD
Last Post: tarsen
Today 04:42 AM
» Replies: 70
» Views: 333831
[REQUEST] Lenovo B51-35
Last Post: sawex
Today 03:28 AM
» Replies: 0
» Views: 0
About modded bios
Last Post: cecilia
Today 01:46 AM
» Replies: 0
» Views: 0
[REQUEST] Update and Unlock Clevo NP70PN...
Last Post: Camilla
Yesterday 10:27 PM
» Replies: 0
» Views: 0
[REQUEST] Whitelist Removal Lenovo L440
Last Post: janlugt
Yesterday 05:16 PM
» Replies: 154
» Views: 43522
[REQUEST] Acer predator Triton 300se pt3...
Last Post: Dudu2002
Yesterday 03:25 PM
» Replies: 2
» Views: 0
[REQUEST] Lenovo B590 (H5ETxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 03:23 PM
» Replies: 261
» Views: 58545
[REQUEST] Acer Aspire 6935G BIOS Unlock
Last Post: ShinYura
Yesterday 02:47 PM
» Replies: 13
» Views: 6163
[REQUEST] Lenovo Yoga 530-14ikb Replace ...
Last Post: GrafAtRuss
Yesterday 10:23 AM
» Replies: 0
» Views: 0
HP Elitebook 845 G9 Whitelisted WWAN Car...
Last Post: natzzzy9119
Yesterday 02:28 AM
» Replies: 0
» Views: 0
[REQUEST] Sony VAIO VPCS13 Series (R2100...
Last Post: jesusdmc
10-01-2023 09:59 PM
» Replies: 17
» Views: 8137
[REQUEST] MSI Modern 14 B10MW-640 WiFi W...
Last Post: ppujols96
10-01-2023 02:32 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad T500 & W500 (6...
Last Post: Grime1010
10-01-2023 02:30 PM
» Replies: 33
» Views: 10094
[Request] Adding 7th Gen CPU support to ...
Last Post: mihauuu
10-01-2023 11:20 AM
» Replies: 7
» Views: 0
[REQUEST] Lenovo Legion 5 (EFCNxxWW) BIO...
Last Post: Dudu2002
10-01-2023 10:32 AM
» Replies: 30
» Views: 9771
[Request] GB-BRR7H-4800 CPU Power Limit
Last Post: Benchlab432
10-01-2023 09:15 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo IdeaPad Z480 & Z580 (5F...
Last Post: memisb43
10-01-2023 08:04 AM
» Replies: 563
» Views: 137922
[REQUEST] Lenovo Thinkpad X240 (GIETxxWW...
Last Post: lnikon
10-01-2023 06:06 AM
» Replies: 329
» Views: 111898
[REQUEST] Lenovo Ideapad Flex 15 unlock ...
Last Post: Dudu2002
10-01-2023 05:10 AM
» Replies: 1
» Views: 0

[Request] Unlocking Voltages of i7 12700f in Proprietary Bios - HP Victus 15 L Deskto
I have a desktop with 12700F and the bios settings are very limited and OEM locked. I am trying to undervolt the processor using below methods, but the Overclocking Lock is enabled after each reboot and as a result, I can not enable FIVR in Throttlestop.
Please let me know If I need to upload Bios Rom file or any other details. I am willing to work on it and try to find out a solution
Currently HP's bioses can't be modified because the restriction of RSA signature. On operating system you can't reflash a modified bios and even if you could reflash it but you will get a black screen(brick). The same situation(brick) when you tring to reflash bios by using a spi programmer.

The second link you provided is already a detail and correct guide of change variables via Grub shell.

I was actually able to dump everything from BIOS, even the *.txt file. I got the variables also correctly. So, this RSA signature is preventing me to do any permanent changes on the bios? Because using Grub shell, I was able to enter the command line, get the values of Overclocking Lock, and change it to 0x0. But as soon as I restart, that lock is reset. Any way to circumvent? This is a desktop, HP 89B5 Motherboard

Also, I was thinking to go back to old bios. Is it possible?

These are the bios files -
1. The main purpose of RSA signature is block user to modify bios. I think it will not affect you use Grub to change variable. Don't you proved that you can set "Overclocking Lock" to 0x0?? And changes any variable by Grub or Ru.efi is not permanent change ,as long as you load bios default or clear cmos ,it will revert to the default.

2. Option "Overclocking Lock" automatically enabling when every restart or turn on ,this bug i only met in ASUS laptops. The solution is don't let user to touch "OverClocking Feature" and keep it to disable. Have you changed this options??

3. I don't know if it can be downgraded ,you need to test it yourself.

4. Your machine intel 12th gen and it's too new ,so i don't have enough knowledge with it . Maybe it's different with before platforms.

5. Give you a suggestion ,if you want to modify bios ,currently don't purchase Dell(Bios Guard enabled) or HP(RSA signature) machines.

Thank you for your detailed answer. Please see my replies

1. Okay. Now I am clear. That is why it is not working.
2. I Enabled Overclocking Lock as well. Did not work.
3. I tried installing normally. It did not work. So is there any way to flash the bios file? I guess not.
4. Maybe something will be devised.
5. I did not know I could not undervolt this. Else I would not have bought this. Actually, regarding HP bios, I have seen other people successfully doing this, and that is why, I was thinking maybe I can also do that.
This is the reference thread -
1. So ,why it's not work? Could you explain what you understand?

2. Why did you enabled the Overclocking Lock? On normal method to activate Throttlestop is disable "Overclocking Lock" & "CFG Lock".
Your second guide is very detail and it also tell you how to do undervolt manually.

setup_var CpuSetup 0x43 0x0

setup_var CpuSetup 0x10E 0x0

On new 12th gen platform ,there are new p-core and e-core design. So ,maybe you could try to respectively undervolt to e-core or p-core by Grub.
(P-core Voltage Offset & Offset Prefix) (E-core L2 Voltage Offset & Offset Prefix)

Below is Sample for set "E-core L2 Voltage Offset" 85mv & set "Offset Prefix" to -

setup_var CpuSetup 0x2B2 0x55

setup_var CpuSetup 0x2B4 0x1

1. Bios may have some predefined checks where it is comparing with baseline version, and if any value is changed, it is defaulting to the old value.

2. My bad. I meant to say, i enabled overclocking feature. Did not work. Disabled that. That also did not work.

3. I tried these also, direct offsetting values. Not working.

My bad luck. After 4 5 years, I should be changing motherboard, that is the only way out I can see.
Can you please let me know if anything is possible on these roms/iffr txt? I know HP Laptops bios are RSA signed, but maybe they did not touch Desktop. I am attaching Bios Dumps as well as IFRR text files. Kindly take a look and let me know if anything is possible.

Bios Dump -
Unfortunately ,as long as you see a .sig file that usually the same name with bios at the same directory ,it is RSA signature file. All Hp's products are included RSA signature now. The file name of bios update tool from HP is usually such as spxxxx.exe ,only early 2015 , sp5xxxx.exe and before hasn't include RSA signature.

You could try to modify this bios dump and reflash it yourself if you don't believe i said. Then tell me the result.


Forum Jump:

Users browsing this thread: 1 Guest(s)