Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
Request for Memory no memory detected er...
Last Post: Maxinator500
Today 10:35 AM
» Replies: 14
» Views: 710
[REQUEST] Acer Aspire Timeline 5830T
Last Post: bambam22
Today 09:31 AM
» Replies: 2
» Views: 88
[REQUEST] Acer Aspire V3-722G BIOS Unloc...
Last Post: tiarna
Today 04:51 AM
» Replies: 11
» Views: 1684
[REQUEST] asus rog strix scar 2 - bios 3...
Last Post: genius239
Today 02:23 AM
» Replies: 17
» Views: 1266
[REQUEST] ASUS K43sV bios unlock
Last Post: arifr007
Today 12:41 AM
» Replies: 17
» Views: 1264
Asus Strix G512LV Bios Unlock
Last Post: ROGSKILL
Yesterday 09:42 PM
» Replies: 27
» Views: 1506
[REQUEST] Asus ROG Strix GL702ZC BIOS Un...
Last Post: draklrd
Yesterday 05:55 PM
» Replies: 122
» Views: 39698
[REQUEST] Lenovo Ideapad Z585 (60CNxxWW)...
Last Post: space1356
Yesterday 03:35 PM
» Replies: 80
» Views: 16459
[REQUEST] Acer Aspire E1-571(G) BIOS Unl...
Last Post: Bypass1
Yesterday 02:52 PM
» Replies: 129
» Views: 36544
[REQUEST] Lenovo Y50-70 (9ECNxxWW) BIOS ...
Last Post: tunner
Yesterday 02:47 PM
» Replies: 2279
» Views: 511400
[REQUEST] Lenovo Ideapad 320-15ikb (6JCN...
Last Post: Dudu2002
Yesterday 02:05 PM
» Replies: 17
» Views: 2215
lenovo z570 Advanced Menu Unlocked
Last Post: BGG13
Yesterday 12:15 PM
» Replies: 4
» Views: 2171
[REQUEST] Lenovo G480 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 12:09 PM
» Replies: 110
» Views: 28021
[REQUEST] Lenovo Thinkpad X1 Carbon Gen3...
Last Post: Dudu2002
Yesterday 12:06 PM
» Replies: 34
» Views: 6726
[REQUEST] Asus Vivobook X412FLC BIOS Unl...
Last Post: nitsan57
Yesterday 11:26 AM
» Replies: 0
» Views: 139
[Request] Unlock MSI H97M-G43
Last Post: TheMaster
Yesterday 10:55 AM
» Replies: 1
» Views: 1013
New Members Say Hi Here
Last Post: byakinta
Yesterday 09:46 AM
» Replies: 140
» Views: 184975
[REQUEST] HP pavillon 15-cx0xxx BIOS Unl...
Last Post: Breaeth
Yesterday 08:25 AM
» Replies: 6
» Views: 111
MSI MS-9661 bios unlock/mod request
Last Post: CaffeineCode
Yesterday 03:14 AM
» Replies: 1
» Views: 1582
[REQUEST] Acer Swift 3 SF315-51(G) BIOS ...
Last Post: Dudu2002
Yesterday 03:08 AM
» Replies: 5
» Views: 105

TEMP folder doesn't get used...
#1
Hey guys sorry for the probably dumb question. A few years ago, I did a successful mod using Phoenix Bios Editor, but unfortunately I kind of forgot how I did it. Now I'm trying to do it again and I'm stuck on what seems to be the dumbest spot to get stuck... I'm attempting to hex edit some of the files that get extracted tot he TEMP folder by Phoenix Bios Editor, but what's happening is my edits are being over-written when I click the "BUILD" button in Phoenix Bios Editor. I really... strongly... though this was how i did it a few years ago. But it's just not working this time. The file I'm editing is "ROMEXEC0.ROM". Any edits I make to that file, are instantly lost as soon as I click File->Build BIOS. I even tried to mark the file as "read only" to prevent Phoenix Bios Editor from over-writing the changes I made, and that just causes it to fail the build, with a popup error box saying it couldn't write to the file! Ugh. Is there something I'm doing wrong here? I'm using Phoenix Bios Editor Pro version 2.2.1.3

Also, one more question in case anyone drops by... If I do make a change to any of those extracted files, do I also need to recalculate any checksums myself, or does phoenix bios editor calculate ALL checksums automatically for me when I click "build" (including checksums for any edited files in the TEMP folder)? Cuz I don't remember manually calculating any checksums a few years ago when I did this, but it's possible I may have been using some kind of tool that was calculating checksums for me, which don't have now, I just can't remember.

Reason I ask this is... I tried making a change to the ROM file *PRIOR* to loading it into Phoenix Bios Editor. The change I made, was just to edit a single character of a string I was interested in. The bios of course was bricked (I tested it in a VM). But Phoenix Bios Editor had to trouble opening it, and seeing my edited string. Yet, when I clicked "BUILD", it built it with no errors, and yet... it was still bricked. That got me wondering whether or not Phoenix Bios Editor actually calculates the checksums for EVERYTHING. Cuz if it did, it shouldn't have still been bricked after loading it into Phoenix and clicking "build" and seeing no errors. So I'm a little worried that I may be missing some kind of important tool I might have had a few years ago to calculate the checksums, if Phoenix Bios Editor doesn't do it automatically. Any pointers will be greatly appreciated!

But just to clarify.. I *am* able to edit most anything inside of Phoenix Bios Editor itself, such as the strings in the "DMI" window, and build the Bios, and it runs perfectly. So I'm not completely useless here. I just can't edit that "ROMEXEC0.ROM" file that's sitting there in the TEMP folder, because of it over-writing my changes.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)