Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Lenovo IdeaPad U310 & U410 (65...
Last Post: Carell
Today 01:58 PM
» Replies: 1845
» Views: 351120
[Request] Zotac Magnus One AMI Bios unlo...
Last Post: sincrack
Today 11:45 AM
» Replies: 77
» Views: 10931
[REQUEST] Lenovo Thinkpad T440p (GLETxxW...
Last Post: poluyretan
Today 08:43 AM
» Replies: 683
» Views: 154529
[REQUEST] Acer Predator Helios 300 PH315...
Last Post: Dudu2002
Today 08:35 AM
» Replies: 1
» Views: 0
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Today 08:34 AM
» Replies: 2124
» Views: 520365
ASUS A7N8X-X modded BIOS
Last Post: evasive
Today 07:00 AM
» Replies: 1
» Views: 455
[REQUEST] Acer Aspire E5-575(G) BIOS unl...
Last Post: Dudu2002
Today 04:25 AM
» Replies: 138
» Views: 50532
MSI MS-6570 K7N2 Delta L/ILSR BIOS mods
Last Post: chaoshusky
Yesterday 09:19 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad Edge E430 & E5...
Last Post: bob7224
Yesterday 07:48 PM
» Replies: 515
» Views: 120695
2011 MacBookPro8,3 add Ivy Bridge CPU su...
Last Post: dosdude1
Yesterday 04:21 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Z410 & Z510 (8DCNxxWW) ...
Last Post: Dudu2002
Yesterday 12:29 PM
» Replies: 555
» Views: 119784
[Unlocked] Acer Aspire One D250
Last Post: maxluan2709
Yesterday 12:13 PM
» Replies: 2
» Views: 4898
HELP Lenovo ideapad 3 15alc6 crisis reco...
Last Post: dicapo
Yesterday 11:37 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad X1 Carbon Gen ...
Last Post: Dudu2002
Yesterday 06:39 AM
» Replies: 32
» Views: 10072
On site repository for INSYDE unlocked B...
Last Post: happydance
Yesterday 05:21 AM
» Replies: 85
» Views: 204180
[REQUEST] SONY VAIO VPCSE2MFY BIOS
Last Post: rezilienza
Yesterday 01:46 AM
» Replies: 0
» Views: 0
NVMe for ASUS SABERTOOTH Z77
Last Post: derWalter
11-29-2022 06:35 PM
» Replies: 15
» Views: 17472
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: Dudu2002
11-29-2022 04:07 PM
» Replies: 552
» Views: 122407
[REQUEST] Lenovo Y50-70 (9ECNxxWW) White...
Last Post: Dudu2002
11-29-2022 03:17 PM
» Replies: 1970
» Views: 394338
Packard Bell TE11HC: HM70 mod to accept ...
Last Post: Pucel_a
11-29-2022 08:55 AM
» Replies: 7
» Views: 0

Gigabyte EG45M-DS2H - update Intel RAID ROM
#1
Hello
What is the ROM upgrade procedure of the Intel RAID controller? I would like to do it, but I have no idea, and I do not want to damage the board (or the BIOS).
Why do I want to do this? Because my current BIOS has a bug through which it is not possible to start the system with the RAID mode enabled (then a blue screen appears with the error code 0x7B despite the use of the Microsoft recommended configuration in the registry, as well as having an Intel Rapid Storage driver). I would add,
I have RAID already installed and worked correctly in earlier versions of the BIOS. I currently have a BIOS version F5C (this is the beta BIOS)
find
quote
#2
Enable switching between all IDE/AHCI/RAID modes by changing "Start" Values in these keys to 0 in the registry (Then no 0x7B BSOD)
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide\Start
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV\Start

Here is guide on updating RAID Rom on Award BIOS - https://www.win-raid.com/t20f16-Guide-Aw...dding.html
Here is up to date modules - https://www.win-raid.com/t7f13-AHCI-amp-...dules.html

However, your RAID Module is above a "Sensitive" module in the BIOS GV3 - PPMinit, so you cannot easily edit this BIOS. This would involve a very in depth edit, that the above guides do not cover. Best bet is us the older BIOS that you already know works, if the above registry edit still doesn't work for you.

I compared F5c and F4, and both have exact same version RAID Rom - v8.0.0.1039
And it is hex match too, so not different.
[Image: WwLyklE.png]

So you have some other issue, mainly 0x7B is due to the above registry values being incorrect for RAID or whatever setting you are using that windows wasn't installed with BIOS set to originally. Just enable them all as described above, then no issue. If you have to go back to F4 BIOS to do that, then do that, make the edits, then flash back to F5c

I checked the default settings for SATA Modes, and F5c is set to IDE by default. Load optimized defaults, reboot back to BIOS and then load RAID

F4 default - Disabled
Options - Choose SATA mode[
Disabled]Disable both RAID/AHCIfunction
[RAID]Enable SATA asRAID Function
[AHCI]Enable SATA asAHCI Function

F5C default - IDE
Options - Choose SATA mode
[IDE]Enable SATA asIDE Function
[RAID(XHD)]Enable SATA asRAID(XHD) Function
[AHCI]Enable SATA asAHCI Function

So, even with older F4 BIOS, you had to manually set RAID. Did you set that with F5c?
find
quote
#3
Thanks for the answer. Regarding the registry keys that you have indicated to me are set up as recommended by Microsoft (that is, the start key located in these 3 locations is set to 0) so that's not
I will ask you anyway. This new F5C BIOS adds XHD support to RAID. Is it possible to turn it off somehow? In BIOS, I do not see this option, and in my opinion it is the problem
find
quote
#4
Microsoft does not set those keys all to zero, only one would be at zero by default, you have to set the rest yourself, then once you do you can switch IDE, AHCI, RAID in BIOS and you don't get 0x7B error/

XHD means RAID same/same, different text is all. I could change the name back, but that is unnecessary edit and flash, and would not make any difference.
Did you set RAID enabled in the BIOS? Is all registry keys set to Zero? If yes, then some other BIOS issue here, or possibly disk issue. You may need to use BIOS F4 only

Did you move your drives around? Are they on the correct Intel Ports, not J.Micron or other controller?
Are they in the first SATA ports, not last, such as in port 0/1 and not 4/5 (Example, I didn't check board image right now)

* Edit - I looked around for other people with issues and RAID on F5c, looks fine to me, user LPC1 in post 855 here talks about testing it with his RAID5 array and no issues
Also another user on second page RAID5 too, post 876
https://www.avsforum.com/forum/26-home-t...cm-29.html

You can try this F5a mod, it's done by well known modder, but BIOS settings will be same, you'll need to enable RAID, disable Native and make sure drives are on first slots not last -
http://www.mediafire.com/file/xalpf2xhza...5a_mod.zip
Intel RAID ROM 12.7.0.1936
Realtek LAN ROM 2.56

You will need to use updated drivers with that version, and may need to rebuild your array or somehow load the drivers first with the others removed etc.
Maybe you will like it though, it does not say XHD Big Grin and default is IDE like older F4
find
quote
#5
I return to the topic. In the meantime, my disk fail, so I checked with only one disk connected to the computer. Unfortunately, still enabling RAID, AHCI or Native IDE in the BIOS causes a blue screen 0x7B at system startup. The person who confirmed the proper operation of the RAID on this motherboard had Windows 7, and I have Windows 8.1 and maybe this is a problem? Nowhere on the disc can I see another RAID controller besides Intel. It can somehow be sensible to solve or threads with RAID?
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)