Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: Dudu2002
Today 04:36 PM
» Replies: 863
» Views: 177254
Asus N73SM & i7-2920XM
Last Post: uRbAsOn
Today 04:06 PM
» Replies: 2
» Views: 57
Lenovo IdeaPad 3 17ADA05 BIOS Bricked
Last Post: SamyoFox
Today 02:00 PM
» Replies: 0
» Views: 51
[REQUEST] HP Mini 210-4000 series BIOS U...
Last Post: DarioX7
Today 10:28 AM
» Replies: 55
» Views: 18898
HP 17-cn0053CL BIOS Unlock {Request}
Last Post: thetechysasquatch
Today 10:08 AM
» Replies: 0
» Views: 83
[REQUEST] Lenovo G510 (79CNxxWW) Whiteli...
Last Post: Dudu2002
Today 08:08 AM
» Replies: 650
» Views: 158729
Gericom X5 Bios - mod
Last Post: BootlegScarce
Today 07:46 AM
» Replies: 2
» Views: 89
Unlock all hidden options for insydeh20 ...
Last Post: alin.tecsan
Today 06:42 AM
» Replies: 266
» Views: 1012063
[REQUEST] Asus eeepc 1025C
Last Post: Cocones
Today 06:27 AM
» Replies: 85
» Views: 106183
[Request] bc-250 bios unlock
Last Post: Buraz25
Yesterday 03:41 PM
» Replies: 0
» Views: 75
[Request] Lenovo V50t-13imb whitelist re...
Last Post: Tweaknap
03-01-2024 04:44 AM
» Replies: 0
» Views: 60
[REQUEST] Lenovo X270 (R0IETxxW) Whiteli...
Last Post: Dudu2002
02-28-2024 11:36 AM
» Replies: 19
» Views: 2775
Where to safely download AMIBCP?
Last Post: daphnehernandez
02-27-2024 11:55 PM
» Replies: 0
» Views: 65
[REQUEST[ Acer Nitro 5 AN515-46 BIOS Unl...
Last Post: ThuskedHelli
02-27-2024 11:36 AM
» Replies: 8
» Views: 72
[REQUEST] Acer Aspire V3-772G BIOS Unloc...
Last Post: Vln
02-27-2024 08:17 AM
» Replies: 460
» Views: 151150
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: potforiak
02-26-2024 01:20 AM
» Replies: 761
» Views: 151865
Lenovo T480 Bios Mod
Last Post: Dudu2002
02-25-2024 07:24 AM
» Replies: 4
» Views: 96
Last Post: Eclipse1407
02-24-2024 09:18 PM
» Replies: 0
» Views: 50
Core 2 Mobile BSEL mod
Last Post: HorseRider
02-24-2024 11:02 AM
» Replies: 0
» Views: 47
[Request] Lenovo T540p (GMETxxWW) BIOS U...
Last Post: beastie38
02-24-2024 09:49 AM
» Replies: 56
» Views: 28152

[Request] Tongfang GM5MG0Y Unlocked BIOS
      Hi there, new to the forum. I could not came up with a solution myself so I decided to ask for a help.
Here is my situation:  I am using a rebranded Tongfang laptop (GM5MG0Y. My laptop shipped with a bios version of N1.06MON04. This version has a Switchable Graphics Option but the dGPU option is not shown. Only MsHybrid and iGPU are shown. However, the exact same laptop with a BIOS version of 2020 has the option to select dGPU. My laptop is MUX capable but they just hid it with a BIOS update. I asked the support for the Bios file that has the dGPU option and they gave it. I also have my current BIOS file. I tried to rollback the bios by trying flashing it with various ways through EFI Shell, Bat Files, AfuWin64, none of them worked. The error I get was  “cannot update bios with different platform name” in all of them. So I am asking if It is possible to enable this option on my current BIOS or is there a way that I can flash the old BIOS to my device?
Here are the files:
I've checked file "NEW CURRENT GMxMGxxN106MON04.ROM" you attached ,but the result is different with you said.
It should is that when "SG Mode Select"= Muxless ,then Display Mode would show items "iGPU Only" and "dGPU Only"  and "MsHybrid" ,it only hidden "Dynamic(default)" ,so actually it equal that  it didn't hidden any items.

[Image: sgmode.png]
[Image: new.jpg]

Really weird, I dont see dGPU only on my BIOS options while my friend does with the older BIOS version with the exact same machine. (We bought it at the same time)

Another possibility , it's an unsupport on hardware level ,you and your friend bought the same model laptop , but maybe they have different version of motherboard ,it may has different circuit design.
You can do a test ,force set it to "dgpu only" via amibcp then re-flash it ,if it get a black screen ,the large chance is that it didn't support this feature.
(If you can't do clear cmos or don't have spi programmer ,please don't do this test)
Or you can let your friend to dump bios from his machine ,then you can to compare what the different of them.

A question , i saw a option "Core Voltage Offset" under advanced tab ,does it limit on 50mv really ??

The overclocking section is not even shown haha. The BIOS is VERY limited. The advanced tab is hidden. I do my undervolting from ThrottleStop, unfortunately.
Could you re-flash the bios "NEW CURRENT GMxMGxxN106MON04.ROM" yourself ??
If yes ,i attempt to unlock some options in this bios ,here is mod.

Finally I was able to capture the error I get.  This is what I get when trying to flash. Both on EFI, f.nsh or Afuwin64 its the same errror. Do you have any idea how can I fix this?

Attached Files Thumbnail(s)
Use this tool to dump bios and attach.
And capture a screenshot that you can see under advanced tab.

I have uploaded the dump to the same link:

I can not take a screenshot of my "Advanced" tab in the BIOS since its shown but Grayed out(Can not select it.)

Attached Files Thumbnail(s)
So ,the bios dump you provides was different with NEW CURRENT GMxMGxxN106MON04 , you can see their difference items design in amibcp.
This is why you always meet error message "can't update bios with different platform name" in afuefi ,they are used with different laptop model.

If i don't let you to dump bios , you forever didn't found this point.


Forum Jump:

Users browsing this thread: 1 Guest(s)