Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ACER SPIN 5 515-51N BIOS BRICKED
#1
Hello,

I am having trouble with client's laptop, which he allegedly bought online as the title, he tried to RMA it but he wasn't being entertained which i had not further inquired as to why, he brought it to different repair shops and ended up here. So, the said laptop was booting from before but was hanging at the acer logo with the circles going on for a few seconds then hangs, loops again and hang. I pulled out the M2 SSD drive to check if it was faulty or not, same problem. i was able to access the bios and disable the secure boot by putting passwords on it but it doesn't help if i try to boot on any flash drives or so. so i took of the battery and the cmos battery to see what would happen. i booted up, but to my surprise that the keyboard's LED and power LED lights up only a few second and turns off and loops for eternity, no displays also. seems to me i bricked the bios, must've been the same case as some guy which the windows update screws up his bios.

i tried reading around,
i came to a little light of hope that by searching for the right bios name such as <name>.fd and put it to a FAT32 flash drive
press <fn>+<esc> it would then try to recover itself.
i was able to manifest the key pressing and it responds but, it doesn't continue.
so now i need the right name for it to be able to continue.

i would like to seek assistance in this, also i tried the UEFItool to search for the .fd of it,
BuzzKBL.fd but it doesn't work. any inputs please?

Thanks in advance.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in