Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BIOS not working after being flashed
#1
I don't know if this is the correct place to be posting this, so a bit of direction in this regard would not be taken amiss.

I have a socket 775 MSI 7529 motherboard and I am running Win 7.  The BIOS version was AMI 2.60 for this motherboard.

I started having constant BSOD's, and eventually, after mucking about testing and changing drives, and RAM, and other things, decided to flash the BIOS.

I set up a USB flash drive with FreeDOS, loaded the appropriate MSI exe and flash data file (the latest being 2.80), and ran the procedure, which ran correctly, and finished without error.

I rebooted the computer, and the BIOS came up with the usual bits and pieces of what it found, drives etc., and then stopped with the F1 or F2 option.  It also said that the checksum was not valid.

I took the F2 option, and the machine went ahead and loaded Win 7 without any errors or crashes.  I then worked through Win 7 for a while (MS Word and one or two other things), all without incident, and without any crashes or BSOD's.  A refreshing change to the previous few weeks.

However, when I shut the machine down, and then restarted it, it got as far as flashing the HDD and CD ROM drive lights, and then sat and gave me the blank, black , glassy, one-eyed, fishy stare.

I eventually removed the battery, and restarted the machine, and the BIOS again went through telling me what it found, and again gave me the F1 and F2 options, with the checksum message.

And this is what it has been doing.  The moment I switch off, I cannot restart.  I have to remove the battery, take F2, and then the machine loads the OS.

I decided to re-flash back to BIOS v2.6, and am getting the same result.

It also happens if I go into the BIOS on F1 or DELETE.  It won't restart, and I have to do the battery "thing."

The fact that the [censored] thing does work seems to me to indicate that basically the process is correct, but it is entirely possible that there is some setting or tweek or other that I know nothing about that I need to include.

It also does this even if I disconnect all the drives, and try and reboot from the USB flash drive.  I still have to do the battery "thing."

Does anyone have any ideas on this?  For the sake of common humanity and my sanity if nothing else!!! LOL.

Stuart Aitchison
saitchison@telkomsa.net
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in