Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo G500 (78CNxxWW) BIOS Un...
Last Post: Dudu2002
Today 03:52 PM
» Replies: 340
» Views: 115791
[REQ] acer aspire V3-572G bios unlock
Last Post: Dudu2002
Today 03:50 PM
» Replies: 1
» Views: 0
MB (A55M-E33 FM2+)
Last Post: TamoNeki
Today 12:42 PM
» Replies: 4
» Views: 0
[SOLVED] Lenovo E545 (HRETxxWW) WiFi + B...
Last Post: dandycheung
Today 05:17 AM
» Replies: 283
» Views: 69365
HP Pavilion TG01-1000 Need help with dow...
Last Post: kennaanna
Today 02:42 AM
» Replies: 2
» Views: 134
HP BOSTON MS-7525 Xeon MOD Success
Last Post: homepeople
Today 02:41 AM
» Replies: 92
» Views: 61093
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: online-cw
Today 12:04 AM
» Replies: 579
» Views: 122407
Asus PN64-E1 Undervolting / RAM Timing u...
Last Post: loadit
Yesterday 05:03 PM
» Replies: 12
» Views: 0
[REQUEST] Bios Unlock Asus ROG GL552VW
Last Post: corsario28
Yesterday 04:27 PM
» Replies: 118
» Views: 59313
T430 will not flash bios
Last Post: g2s
Yesterday 01:00 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: madxj6
Yesterday 10:34 AM
» Replies: 300
» Views: 85410
[REQUEST] Lenovo Z40-75 & Z50-75 (A4CNxx...
Last Post: nopparatm
Yesterday 10:15 AM
» Replies: 68
» Views: 29032
GigaByte GA-945GZM-S2 rev. 6.6 & Pentium...
Last Post: DeathBringer
Yesterday 07:19 AM
» Replies: 28
» Views: 17640
[REQUEST] Acer Aspire VN7-571G BIOS Unlo...
Last Post: paweltylman
12-05-2023 07:58 PM
» Replies: 70
» Views: 25199
[REQUEST] Acer Swift 3 SF314-42 BIOS Unl...
Last Post: Dudu2002
12-05-2023 04:26 AM
» Replies: 4
» Views: 1184
Z97-PRO(Wi-Fi ac)/USB 3.1
Last Post: Documentary
12-04-2023 04:35 PM
» Replies: 3
» Views: 2053
CLEVO P150EM Bios Mod to add AMD FirePro...
Last Post: TKbiosboi
12-04-2023 03:34 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: LenovoInsydeH2O
12-04-2023 12:34 PM
» Replies: 1724
» Views: 520365
Bricked InsydeH2O BIOS of Acer Aspire 57...
Last Post: MBTech
12-04-2023 09:21 AM
» Replies: 2
» Views: 0
Dell D630 A19 Slic 2.1
Last Post: Aendrous
12-04-2023 05:43 AM
» Replies: 7
» Views: 18309

Bricked my Acer Aspire - plesae help!
Hi all,

Firstly, my apologies if this is posted in the wrong section (or website for that matter!) but I'm kind of desperate to get this thing going again. So I ran a BIOS upgrade exe fgrom within Windows, it rebooted and basically did nothing. Now it doesn't POST.

I extract the BIOS .exe which reveals the following files:


I then opened the original .exe with PhoenixTool.exe and the first window that popped up showed:

http: //

Followed by:

http: //

It created a DUMP folder and inside it 797 .ROM files and a folder called BIOS which contained 256 .BIOS files.

At this point I'm a little bit stuck!! I understand that I ultimately need either BIN or FD file to place on the root of a USB drive and then boot whilst holding down FN + ESC.

Massive thanks in advance to anyone who can help me with this.

Link me to the BIOS

Also it is not the same fd or bin that comes with the exe, you also need to decapsulate it or the Brick will be even worse, link me to the bios and i'll give you the right recovery file

thanks for your reply, I appreciate your help.

This is the latest BIOS version. Not sure if this one will do. It was on 2.15 originally but I tried to update to the one in the link.
Here is the fd file you need

Hidden menus unlocked as a bonus


What can I say? A thousand thank you's kind sir, it worked perfectly. Donation sent. Smile
Very nice!
Be careful with video settings... as it can brick ur nb.


My Acer Aspire E1-531 won t boot BIOS. After pressing start button it starts but screen still black, flashlights shows that it charging and shows that HDD works but only for a few seconds. System FAN shutdown after 3-4 seconds but notebook still on.
I need help
have you changed anything in bios before it starts acting this way?

yes size of vga 64m to 1gb
just that
my best regards
Reset CMOS. Remove notebook battery and CMOS battery and put it back after some minutes, this may clear CMOS settings and reset BIOS to defaults.


Forum Jump:

Users browsing this thread: 7 Guest(s)