Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Enabling E480 Backlit Keyboard on a ThinkPad E485

I've recently purchased a spec'd out ThinkPad E485 with an AMD Ryzen 2500U for my personal use, but one of my biggest gripes with this laptop is the fact that Lenovo chose not to provide an option to add a backlit keyboard to the laptop. However, the Intel version of this ThinkPad (the E480) comes with a backlit keyboard. Strange. I did some more investigating and it turns out both motherboards are nearly identical and they have the same exact connectors for both keyboards. So I decided to pick up a ThinkPad E480 backlit keyboard off eBay to see if it'd just slot in and work. Unsurprisingly, the E480 keyboard I ordered fits in and works flawlessly, except the backlight won't work. This has lead me to believe that something in the laptops BIOS or UEFI prevents people from just installing a backlit E480 keyboard in an E485, others have confirmed this on other fourms site's I've seen thus far. What I'm thinking is all my laptop needs to get this keyboard to light up is the backlit bios code from the E480 patched into the E485 bios.

If anyone has any input on this, I'd greatly appreciate it.

In USB area of BIOS (Maybe config, USB) Security permissions, you don't see keyboard illumination? Under UEFI USB, USB Always on, trackpoint, trackpad, FN key controls (few settings), then Keyboard Illumination Control? You did already try the FN keys I assume?

[Image: kUPOVOm.png]

If you have any of those sections, or settings, show me an image and I will see if I can enable for you.

You can test these settings by booting to grub via "Boot to EFI shell" from BIOS exit page, and then change variable 0x32 to one of the following values. You will need to google how to boot to grub, download a file and on the setting in your BIOS when you select of hover it you should see the "File name" it's looking for, rename the boot.efi file to that name before you boot to USB.

Default should be 0x1, if you enter variable without being followed by a setting then you will see default value
ThinkLight Only, Value (8 bit): 0x0
Keyboard Backlight Only, Value (8 bit): 0x1
Both, Value (8 bit): 0x2

I would test by entering 0x2 to see if "Both" helps.
So at grun prompt type following >> 0x32 0x2

If that has no effect, then BIOS mod I was considering will not either Sad

First off, huge thank you for the reply. I'll attach several pictures of the bios and the keyboards. When I plug in the E480 keyboard and try to press Fn + Space (which is what almost all the ThinkPads use to enable the backlight) it does absolutely nothing, however, the "ThinkLights" (aka the LED under the mute key to show if the system is muted or not) do in fact work. There is a USB section, but the only things listed under that submenu are "USB UEFI BIOS Support", "Always On USB", and "Charge in Battery Mode", all of which I have already enabled. One more thing to note, the E480 backlit keyboard as seen in my last picture has a little icon on the space bar on the left of it to signify pressing Fn + Space to enable the backlight, the keyboard that came with this laptop did not have that icon on the space bar (obviously).

[Image: 7DTaDEx.jpg]
[Image: cuVODw5.jpg]
[Image: fE609bF.jpg]

I'll make a flash drive with grub + the EFI shell on it to test out these tweaks and I'll report back shortly.

Ok, so I loaded up a USB drive with the EFI Shell on it and tried the commands, but I feel like there must be more to the commands than just 0x32 0x2 Huh The EFI Shell didn't recognize it as a command. Hopefully this isn't bad news.

[Image: liDRpVm.jpg]

Edit: I also tried this within my grub bootloader itself since I'm running Kubuntu on this laptop, no luck.

Does anyone have any input on this? I'd like to return this backlit keyboard if I can't enable it through a bios mod Confused
Wow, those images are way to huge to post on a forum like that!!

You have to boot to grub, not same as EFI Shell, I am not sure about Kubuntu grub? Windows bootx64.efi file is the only one I know of that's used for what I meant, you can rename it per what the filename your BIOS says it's looking for when hovering the "boot to EFI shell" option on the exit page. Here is that file -

And yes that is all you enter at the grub prompt
0x32 0x2 << This sets setting to "Both"
0x32 0x0 << This sets setting to "ThinkLight Only"
0x32 0x1 << This sets setting to "Keyboard Backlight Only"

If you just enter 0x32 and hit enter it will output info and show you current setting which if you have not already changed should be as shown in my first image from your BIOS = Value = 0x1 (Default), I'd set 0x2 both to see if it's going to work or not.

Other than that, can you confirm the keyboard you received has backlight keys, test on another system? Keys do not look like backlight type to me, but that could be the image/angle/lighting

Also, I see here and several other places, some FN combos might not apply to all systems the same, so check your manual to verify it's same for your system (FN+Space can be Off, Low, High)
First of all, my bad for not resizing the images haha I just took pictures with my Sony DSLR Camera since that was easier than trying to copy pictures off my phone. So this was interesting, I loaded up the grub efi shell you linked and it posted to the grub terminal. I tried typing 0x32 0x2, but grub said the command wasn't found. I figured there must have been some prefix to the 0x32 0x2 that I was missing. I ran "help" in grub to see what kinds of commands it supports, and I saw a command called "read_byte". So in my curiosity I tried running read_byte 0x32, and sure enough, after running that, it gave me 0x0 as a response. So I tried running write_byte 0x32 0x2, and the command went through, but the keyboard didn't light up. Sad Re-running "read_byte" in grub confirms that the value of 0x32 was changed to 0x2, but no effect on the keyboard itself. Is it possible that there's a different command in grub I should be using, or another hex variable that needs to be changed to enable the backlit keyboard? This isn't sounding very promising Confused

Size is OK, if you didn't want to resize, but putting them in a zip would be best for images that huge Smile Now the format is all broken and sprawled out across the internet (even on my 2560 monitor)

Show me an image of the "grub" you booted to in your description above, only exactly what I wrote is needed, so thinking maybe you still didn't get right grub possibly, somehow? Or, yes you are at correct grub and either some traces on the board are missing to power the LED, or keyboard is not LED type or LED is broken? hard to know for sure on this one.
I resized all of the images from my camera's stock 24MP (6000x4000) resolution haha, I noticed how bad it looked when I went to go write this reply. I've resized all of them to 1400x933, so hopefully it doesn't look too huge and the images still look visible. I'll post a picture of the grub screen as well as the keyboards, and the connections of the keyboard to the motherboard. The first picture is of the grub screen running the given commands, the second is of the motherboard keyboard connectors, the third is of the keyboard's appearances (they're identical in size), the fourth is of the back of both keyboards and their ribbon cables (which are also identical).

[Image: 3j9wht5.jpg]
[Image: zPkAWjs.jpg]
[Image: bVkzd9x.jpg]
[Image: eEVx8IJ.jpg]
Update: I ended up assembling my ThinkPad back together with the E480 backlit keyboard to use it again even though the backlight functionality doesn't work (for now). One thing I noticed is the left and right click physical buttons at the bottom of the keyboard for the trackpad are non-functional with this E480 keyboard, odd. This leads me to believe that one of the ribbon cables is in fact for the keyboard itself and the other must be for the trackpad physical left and right click buttons.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in