Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gigabyte GA-D525TUD [PXE/gPXE]
#1
Hi,

I'm the proud owner of a Gigabyte GA-D525TUD
Currently Bios: F3 (Newest version) Award

Currently the PXE part is not functional it will not boot correctly. PXE is working when i use a USB stick and boot gPXE from this.

Some extra info:
Realtek NIC Realtek RTL8111E
| lspci -n -s 01:00.0 01:00.0 0200: 10ec:8168 (rev 06)|

It has Family Controller Series v2.35 installed [PXE]

I tried to patch the bios myself but failed.

My request would be if it is possible to:
A. Patch the newest Realtek version 2.39 or see the attachment

and/or second bios B. Patch it with the gPXE rom for this NIC that I have made from the gPXE source see attachment or here for the TAR

Thanks in advance


Attached Files
.rom   gpxe10ec8168.rom (Size: 57.5 KB / Downloads: 13)
.zip   RTEGPXE.239.zip (Size: 150.03 KB / Downloads: 18)
.zip   D525F3.zip (Size: 377.58 KB / Downloads: 2)
find
quote
#2
Two options, one with RPXE 2.39, one with GPXE... both updated JMicron JMB363 OROM to 1.08.01 (which only works sometimes, apparently... but you should be okay without RAID, I think)

I took a look in Modbin and noticed non-selectable RAID-mode but I don't know if it will work with NM10 so I didn't touch it... Does AHCI mode work for you? I don't see a PCI OROM for AHCI...


Attached Files
.zip   d525tud-JM10801-RPXE239.zip (Size: 360.76 KB / Downloads: 1)
.zip   d525tud-JM10801-GPXE101.zip (Size: 388.91 KB / Downloads: 11)

Feel free to use/link/host any BIOS I post, no credit necessary. However, this is at your own risk and I take no responsibility. Always keep a backup of a known-good BIOS. Don't flash a motherboard if you don't have a backup computer just in case.

Always use RAID mode. RAIDFix
find
quote
#3
(02-02-2011, 02:30 PM)Dansolo Wrote: Two options, one with RPXE 2.39, one with GPXE... both updated JMicron JMB363 OROM to 1.08.01 (which only works sometimes, apparently... but you should be okay without RAID, I think)

I took a look in Modbin and noticed non-selectable RAID-mode but I don't know if it will work with NM10 so I didn't touch it... Does AHCI mode work for you? I don't see a PCI OROM for AHCI...

Boths roms work, the gPXE one fixed my issue regarding the network boot setup. It is set to IDE haven't checked AHCI yet, i can try if the RAID solution works if you enable it Big Grin

find
quote
#4
(02-03-2011, 05:18 AM)Kaicho Wrote: Boths roms work, the gPXE one fixed my issue regarding the network boot setup. It is set to IDE haven't checked AHCI yet, i can try if the RAID solution works if you enable it Big Grin

Kaicho,

What did you use to flash your 10ec:8168? I have one too (in a TP-Link 3468 card).

I have looked for flashers, but I'm not sure how to load the .ROM. Anything you can help with would be greatly appreciated!

find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in