Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Toshiba Satellite L850 BIOS Un...
Last Post: hiriotapa
Today 10:50 PM
» Replies: 46
» Views: 55109
[REQUEST] Lenovo G580 (62CNxxWW) Whiteli...
Last Post: pangzibupang
Today 08:59 PM
» Replies: 835
» Views: 227301
[REQUEST] IDEAPAD 3 (Ryzen) 15ALC6 (GLCN...
Last Post: Dudu2002
Today 04:10 PM
» Replies: 1
» Views: 72
i7 4790 support for HP Z230 SFF
Last Post: DeathBringer
Today 11:52 AM
» Replies: 1
» Views: 243
[REQUEST] Lenovo IdeaPad U310 & U410 (65...
Last Post: Dudu2002
Today 06:51 AM
» Replies: 1841
» Views: 343837
Acer Aspire 8930G: Quad core CPU support
Last Post: DeathBringer
Today 12:33 AM
» Replies: 7
» Views: 2289
Help HP Pavilion dv6 6120us
Last Post: DeathBringer
Today 12:28 AM
» Replies: 1
» Views: 150
[Request] ROG Strix G15 Advantage Editio...
Last Post: H34TO
Yesterday 08:56 PM
» Replies: 77
» Views: 21042
[REQUEST] aorus 15g xc bios unlock
Last Post: Liamcronshaw1
Yesterday 03:02 PM
» Replies: 4
» Views: 252
[REQUEST] Sony Vaio SVF15N1S2ES Fit Mult...
Last Post: Z3PHYR
Yesterday 01:52 PM
» Replies: 0
» Views: 80
[Request] Unlocking Voltages of i7 12700...
Last Post: Jarit.lal
Yesterday 12:38 PM
» Replies: 7
» Views: 259
[REQUEST] Asus ROG G771JM bios unlock
Last Post: feluchi
Yesterday 06:54 AM
» Replies: 79
» Views: 27508
[REQUEST] Hystou S200 BIOS unlock
Last Post: mkjohn
Yesterday 06:24 AM
» Replies: 32
» Views: 8852
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: mma21
Yesterday 04:07 AM
» Replies: 2108
» Views: 507116
[REQUEST] HP Mini 110-3100 No option to ...
Last Post: abeja5
Yesterday 03:54 AM
» Replies: 2
» Views: 885
[REQUEST] HP Pavilion g6-1300 (AMD) BIOS...
Last Post: tomato
Yesterday 02:16 AM
» Replies: 52
» Views: 15236
[REQUEST] Lenovo B50-70 (9DCNxxWW) BIOS ...
Last Post: Urry
Yesterday 01:15 AM
» Replies: 104
» Views: 26797
[REQUEST] Acer Nitro 5 AN515-55 BIOS Unl...
Last Post: Dudu2002
Yesterday 01:11 AM
» Replies: 121
» Views: 35408
[REQUEST] GL504GS BIOS unlock
Last Post: genius239
08-13-2022 09:38 PM
» Replies: 72
» Views: 20062
Clevo P775TM1-G BIOS
Last Post: feluchi
08-13-2022 04:00 PM
» Replies: 145
» Views: 51572

MEMINIT.BIN
#1
I have noticed that inside MEMINIT.BIN, it has a string that references the AGESA version. If one is to update the AGESA code, does MEMINIT have to be updated, too? Is the MEMINIT module independent from the board it is installed on? ie, interchangeable with other boards?
find
#2
this is very interesting and could possibly be why some of our CPU Support mods havent worked , i will be looking into this! Big Grin

Thank you for your help!

Admin
find
#3
I am trying to get the latest AGESA code into my Gigabyte BIOS (Socket AM2, M61P-S3), but unfortunately it only has a 512KB FLASH and the new AGESA + MEMINIT is over by less than 1KB Sad

I have a version where I've disabled the NV RAID feature via MODBIN and removed the NVRAID PCI BIOS to make room. We'll see if it works when I get my EPROM programmer (bricked my MB yesterday, OOPS!)

The donor BIOS is from another Gigabyte board with the same chipset. The ACPI table is 2K smaller...I'm not sure what to think about that. Have you found that using the ACPI table from the donor BIOS is necessary? It may free up enough space.
find
#4
I have been doing extensive research in the matter and I have concluded a couple things. Think of the AGESA as a library, that contains all of the books on the shelves. But how do you know where to find you books without an OPAC or a method of finding the books with a call number. Tthis is where the MEMINIT as well as the CPUCODE.BIN come into play. The meminit doesnt necesarily always have to be upgraded, but in the AMD series boards its what sets the Hyper Transport between the memory and CPU, as well as other memory architecture settings, so most of the time youll need this. Then you deal with the CPU microcode strings, which call the proccessor information from the AGESA table. Without this updated, it will be as if you've done nothing. If you read Presola's thread, youll see we simply upgraded the AGESA ROM only, and it did nothing because you can add books to a library, but if you still only know where the old ones are, then you dont know that new ones are there. Yoyu can customize the AGESA ROMS so they include the CPU code you need to save space. The latest version 3.5.3.1 is like 37KB (YIKES!) but some older versions have the support without the extra baggage.

Hope this helps,
TheWiz
www find
#5
Well I have resurrected my board after a bad flash. I had to solder leads to the chip (there is no SPI header) and build a small circuit and parallel port cable. I used the SPIPGM utility to do the programming.

I tried the experimental BIOS mentioned in my previous post and it did not work -- the board would not POST at all. Perhaps it needed the update ACPI tables. I am done for now in attempting to upgrade this board because it is such a pain to fix if it won't boot. I may try again later if I can figure out a easier way to reprogram if an experimental BIOS doesn't work.
find


Forum Jump:


Users browsing this thread: 1 Guest(s)