Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help with bios on Acer Predator
Hi all!

First, sorry for my english, it's not my first language.

I really need help and I don't know how to resolve my problem.

Let me explain.

I have an Acer Predator G9-793

Lately, I was having some weird sound buzzing, and I send my computer back to acer customer care. They changed the motherboard and the fans.

I got back my computer two days ago.

Yesterday, I wanted to use it and see if everything was working fine. Win 10 booted all ok, I surfed a little bit on facebook, and launched steam to make the games updates.

In 5 minutes, my computer completely froze. The mouse/trackpad didn't move, alt-ctrl-del doesn't work. My only solution was to hard shutdown with the power button.

When I wanted to boot again, the leds and the backlight keyboard lighted, but the screen remained black. The fans turn on a little bit then stops. And I'm stuck with a black screen.

I tried to restart the computer with some of the tricks provided (Push power button for 30s, reset battery with little hole in the back of the computer)

I went to the acer forums, and found some old thread spoke about a maybe a bios problem to recover.

And with some more googling I found this place.

Ok that's it for the story Smile

Actually, I'm completely broke and can't afford another repair and lose 3 weeks again my computer if I can repair the problem myself. I really hope someone here can help me.

So... After what I read here and there, I think that I can try a bios recovery for my computer, but I'm a little stuck.

If I understood well, I must format an usb key in FAT and put the good bios file with a good name, then boot my computer with a manipulation (Fn + esc, power button then release all keys) and the new bios should install.

I downloaded the latest bios for my computer on acer website (ver. 1.13):

I decompressed it and found two files that seems to be the bios files (MU5DC.bin and MURDC.bin)
I tried to load them in phoenixtool to find their recovery name, but I can't find these names anywhere. Also, I don't know wich one I must use.

Can someone help me to go further in my adventure to make my computer great again ? Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in