Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Acer Predator Helios 300 PH315...
Last Post: cerebroso120
Yesterday 11:29 PM
» Replies: 12
» Views: 2522
[Request] Thunderobot Zero
Last Post: genius239
Yesterday 09:10 PM
» Replies: 60
» Views: 7082
[REQUEST] Lenovo V580(c) (H1ETxxWW) Whit...
Last Post: Dudu2002
Yesterday 05:09 PM
» Replies: 621
» Views: 102654
[REQUEST] Acer Aspire VN7-791(G) BIOS Un...
Last Post: Dudu2002
Yesterday 04:59 PM
» Replies: 94
» Views: 56078
[REQUEST] Lenovo B50-70 (9DCNxxWW) White...
Last Post: Dudu2002
Yesterday 02:54 PM
» Replies: 188
» Views: 38311
[REQUEST] ASUS ROG GL504GM BIOS unlock
Last Post: Cone
Yesterday 01:04 PM
» Replies: 1
» Views: 61
[Request] zen+ support for ASUS GL702ZC
Last Post: Roland83
Yesterday 11:44 AM
» Replies: 0
» Views: 64
[REQUEST] Asus IPIBL-LB Bios Unlock
Last Post: davidep99
Yesterday 05:03 AM
» Replies: 27
» Views: 23668
[REQUEST] Lenovo IdeaPad U310 & U410 (65...
Last Post: Dudu2002
Yesterday 03:43 AM
» Replies: 1826
» Views: 264026
[REQUEST] Asus EX-B250-V7 unhide iGPU co...
Last Post: genius239
Yesterday 01:07 AM
» Replies: 44
» Views: 3942
[Request] ROG Strix G15 Advantage Editio...
Last Post: Sml6397
Yesterday 01:06 AM
» Replies: 67
» Views: 9997
[Request] Lenovo E545 (AMD) TDP+Advanced...
Last Post: HP_ENVY_User_32
11-29-2021 11:33 PM
» Replies: 41
» Views: 3012
[REQUEST] Lenovo Y50-70 (9ECNxxWW) BIOS ...
Last Post: alis1204
11-29-2021 08:15 PM
» Replies: 2295
» Views: 525398
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: Dudu2002
11-29-2021 04:12 PM
» Replies: 770
» Views: 129866
IBM Thinkpad 701c battery mod
Last Post: Ghostdog85
11-29-2021 03:37 PM
» Replies: 0
» Views: 61
[REQUEST]clevo pb50 (hasee x9-cu7pk)
Last Post: Dudu2002
11-29-2021 01:20 PM
» Replies: 1
» Views: 76
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: Dudu2002
11-29-2021 01:13 PM
» Replies: 502
» Views: 88388
[REQUEST]Bios Unlock LG CL600W
Last Post: lufan
11-29-2021 12:05 PM
» Replies: 7
» Views: 259
Help reflashing wiped EEPROM after bad f...
Last Post: Maxinator500
11-29-2021 11:49 AM
» Replies: 3
» Views: 235
ASUS K75VM need bios flashing file for W...
Last Post: Vaako
11-29-2021 11:37 AM
» Replies: 0
» Views: 56

[REQUEST] Acer Predator Orion 3000 (h470)
#1
Hi BIOS Gurus

I got my hands on the above and trying to set it free from factory limitations. The only thing I need it for is to be able to remove the XTU interface block and be able to lower CPU voltage by offset so that it gets cool and quiet.

So far I have
a. opened the original file with AMIBCP 5.02 and set a few options to "USER" as found in one of the guides, saving into same file
b. tried to flash it back with AFUWINGUI and got error 18...

Any ideas apart from taking the flash IC off and read/write it with a programmer? Would be my last option though - would likely void warranty.

Original file link: https://global-download.acer.com/GDFiles...3377220834

Update:
Tried parsing the file and setting/changing variables with offset 0x88E, 0x17 and 0x1B8 from UEFI shell, would not change anything, still read only...
Followed this - https://www.win-raid.com/t3993f16-Tool-G...riter.html
Update2:
Examined the board - bios is stored on GD25B127CSIG.
Tried reading with a Pomona clip using a flasher (tried 3 different devices). Reading is OK.
Tried writing - no can do - have to take the IC off, W/P is pulled down with something... desoldering will sure void the warranty. Stuck. Looking for SW method...
find
quote
#2
@vov4ik_il
Writing 0x0 to offset 0x17 is in order to disable option BIOS Lock ,only when this options is disable ,you just can write back a modified bios via Intel fpt tool. But i check you attached file ,this option is already disable by default. So ,you could attempt to dump and flash the bios via intel fpt(flash programming tool) version 14.


I own a Acer t3-715 mainboard ,in order to understand how to unlock bios menus in an Acer lga1151 board ,so i purchased it and spent much time to research it. After hardly learn a while ,finally i know how to unlock bios menus in this board.
But i checked you attached bios file ,i found it has new type menu structure and it different with my t3-715 bios ,or should say there is a new method blocked AMI menu(Advance ,Chipset..etc) by Acer official. So maybe it's not easy to unlock menus in this machine.

Good luck.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#3
Hi @genius239,
Thank you for looking into it,
I tried FPT and it only lets me write BIOS region, when I try to write the whole file it fails.


Attached Files
.txt   log.txt (Size: 7.02 KB / Downloads: 8)
find
quote
#4
@vov4ik_il

Check Bios Lock states in current bios , if it's enable ,disable it again.
Then try command lines like this : fptw64.exe -f modded_dump.bin -bios .


Edit=============
I didn't noticed you can flash the bios region.
Unlock menus only need to write bios region ,so now you could take a try to edit it by yourself.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#5
Video 
Thanks for the advice, 
I have tried only writing the BIOS region with root overclocking menu set to USER (and changing default XTU interface state option to Enable) and then loading defaults. Absolutely no effect...


[Image: 3HBjZwH.png]
find
quote
#6
@vov4ik_il

If you wanna activate ThrottleStop or Intel XTU ,please also need to disable CFG Lock and Overclocking Lock. Try it then reply to the result. Good luck!
[Image: 3000.png]

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#7
Tried that. Did not go so well:
- FPT failed mid-flashing
- Tried to repeat multiple times - failed on every attempt
- Tried flashing the original .CAP with Acer supplied utility - system rebooted and did not POST anymore
- Brought high current programmer and wrote the modded file directly...
- System posted and booted but nothing has changed, the options I need are still unavailable
[Image: Urtd44f.png]


Attached Files
.txt   log (2).txt (Size: 5.78 KB / Downloads: 0)
find
quote
#8
@vov4ik_il
If you mean that these options were not appear in the bios after you edit via AMIBCP. I feel it's very normal ,only used AMIBCP to edit is impossible to unlock all options. From Intel 7th gen start ,you already can't unlock all hidden options via AMIBCP.

So ,you could only do is change settings value on AMIBCP to get your target.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#9
Thanks for advice, found the missing parts on 4PDA, indeed required some tinkering but not impossible...
[Image: 2tZPEQG.png]
find
quote
#10
@@vov4ik_il

You're great~
Yes , inject or swap tabs in not a hard thing ,it seems that you swapped some stock tab(Main) to OverClocking Performance Menu. But i'm not interesting in this , because it's not hard. Currently I'm interesting is what new methods Acer used to blocked the AMI menus(advanced ,chipset..etc) ,now i probably know how to unlock it ,i seem found it out in the ida pro.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote


Forum Jump:


Users browsing this thread: 3 Guest(s)