Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 13 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] Lenovo X220 (8DETxxWW) Whitelist Removal
#11
Yes 1.25 works for me too, I am using an atheros card. One complication - I had Diagnostic Boot set before the flash, and it got stuck in a POST loop after programming. I had to cold boot and press F1 repeatedly and then select Quick Boot instead. Now it POSTs twice but eventually boots to grub. I tried loading defaults too. A minor inconvenience, but worth it for a working de-whitelist.

Thanks camiloml! Smile
find
quote
#12
(11-30-2011, 01:33 PM)camiloml Wrote: http://dl.dropbox.com/u/45117524/bios-mo...miloml.exe

I wait your news Wink

Unfortunately it does not work - winflash says it "Cannot launch UEFI emulator".

What component is missing on my system ?
find
quote
#13
Do not know, what did you do EXACTLY step by step with the modded bios EXE file you downloaded?

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#14
Extract the self-extracting archive, launch winflash, select Fvrecovery.fd and click flash.

using "svs -sa" quits with the alert "PLease select corrct BIOS image !"

OS is Win7 x64 - if it makes a difference.
find
quote
#15
BEEEP!!! Wrong.

Why don't just run the EXE?

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#16
[Request] Lenovo X220 Bios 1.26 whitelist removal
-Manufacturer: LENOVO
-Model: X220
-Bios revision: 1.26-1.13
-Bios Type: UEFI
-Bios Download Link: http://support.lenovo.com/en_US/download...D=DS018805
-Card I want to use: Ericsson F3507G FRU PN 43Y6479

Although Lenovo seems mentioned that F3507g is supported by X220, it's definitely not Sad (this link http://support.lenovo.com/en_US/download...D=DS001273)

I've search for the same request, it seems the lastes version was 1.25 (link: http://www.bios-mods.com/forum/Thread-Re...st-removal). The problem is, I've already patch my BIOS to 1.26. I do afraid to downgrade back to 1.25.

Can someone here help me to remove the whitelist WWAN in Lenovo ThinkPad X220 BIOS v1.26? I appreciate for your attention and any help.
find
quote
#17
You should have no problems rolling back to 1.25

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#18
Um, are you sure it is safe camiloml? If you say so... I will try it.

Are you planning to make for the v1.26? Since it's introduced capability to to enable WWAN and WLAN device simultaneously.
find
quote
#19
Okay, I've done it. Rolling back to v1.25, no problem. Restart to see everything runs well, then shutdown and installed my F3507G with it's main and aux antenna cable. Boot up, there's no error like happened before.

But know, the device manager it's not showing any new devices. Weird. I've looked up in SIW, PCI showing no/unrecognized devices... Does anyone have a clue how to make sure the WWAN is properly installed?
find
quote
#20
x3r0, how is your success?
Do you see your modem in the device manager after laptop soft reboot?
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in