Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] MSI X58 Platinum BIOS Unlock
#1
Since I've gone from 6 to 8GB RAM, I've been having problems with my motherboard. Every time I do a cold boot, Windows (10) hangs after a couple of minutes. When I restart, Windows is only using 6GB RAM (but CPU-Z still reports 8GB). After another restart, everything is back to normal, and it will stay like that till the next cold boot.

I believe this is my problem, but no one talks about Windows hanging. Still it seems the X58 is the only motherboard with this problem, so I'm going to guess it's also the cause of my problem. I don't think it's because of faulty RAM / slots because it only happens right after a cold boot.

To solve it, I need to change some values, but my OEM BIOS (Medion) doesn't let me. I only got the basic settings, and certainly no overclocking settings. Additionally, I also can't control my fans, so I hope to fix that as well. I could flash the generic X58 Platinum AMI BIOS,

So my questions:
- Is it possible to unlock this ROM or maybe add the functionality?
- Would flashing the generic (and more up to date) X58 Platinum BIOS be better? I don't want to brick my BIOS, but I've found some successful reports on forums with similar configurations. I can't seem to find my BIOS chip, so I'm afraid it's soldered, which makes it a lot more difficult to replace it.
- Maybe someone has experience with this particular problem?

I've added my current ROM and the results from 'BACKUP_Tools', but the latter gives an error. I've also added the latest official MSI ROM.

System Info:
========
MSI X58 Platinum (MS-7522)
i7 930
8GB RAM
Windows 10


Attached Files
.zip   BIOS Files.zip (Size: 1.84 MB / Downloads: 3)
find
quote
#2
Hello,

I have successfully flashed an Medion OEM MSI X58 Platinum Board to the officially latest MSI Bios so that it support Xeons and the full MSI Bios with OC options is possible to use.

Bios I have on the Board is now this one:
https://www.msi.com/Motherboard/support/X58_Platinum

Medion is an german electronic company and sold this OEM MSI X58 Platinum Boards in an PC over discounter Aldi, the OEM Boards are missing 1,2 I/O ports and had other Bios with limited options without OC and without Xeon x... Support. Otherwise the look and have the exact the same as the MSI X58 Platinum.

After sucessfull flash of the Bios I have now an x5670 running on the Board fine, but I can't adjust the CPU Voltage somehow.

The Voltage under Windows shown with CPU-Z is 1.04 - 1.10 Vcore and any adjustments I do at Bios will be ignored. Voltage seems to be correct, when I use prime with 100% load all 12 cores 20 minutes I only have 40 degrees celsius with my Dark Rock 3 Be quiet cooler, that is very, very low temperature for x58 Xeon with much room for OC.

But as said I can't OC because I can't adjust Vcore, I can set higher in Bios and save but under Windows nothing happens with Vcore and even the slightest OC is crashing PC and I have to do a Cmos clear. All other Bios options work fine, I can adjust fans, boot order, whatever, I also can adjust FSB or Ram Speed. Other Power Supply I tried, both have 700 Watt, really enough...

Someone in german forum said maybe medion/the oem producer of this Board have maybe ssembled an other CPU Voltage Chip on Board as MSI, so that the MSI Bios is adressing the false Chip for CPU voltage and so nothing is happening?

Could this be? And could this be changed in Bios so that I can OC/increase CPU Voltage?

I can support as good as I can when I get instructed - I'm not a noob and used to PC handling, at least I flashed it succesfully Smile

I really would appreciate support/Input, I want to OC, I have all, x58 board with xeon X,  big cooler, big power supply and now only 1,1 Vcore, really that can't be...Smile

Thanks!
find
quote
#3
You may need to raise TDP Limits, or it simply may be that you need to flash in mod BIOS with updated CPU microcodes for that CPU, the stock BIOS has 2009/2010. This CPU wasn't released until 2010, so even that one may not be best for the CPU, there is 2011, 2015 and 2018 microcodes for these, I'd test the 2015 before 2018 and would suggest the 2011 one as minimum one for anyone due to uncore bugs in the previous versions.

How are you flashing the BIOS now, since you've flashed over, can you flash stock MSI BIOS using stock method from within the BIOS? If yes, maybe you can flash mod that way too. Here is mod BIOS x2, do not put these on with programmer because these are stock BIOS and you'll loose serial and LAN MAC ID etc. Flash via built in flash method, put on root of USB and keep original file names otherwise it wont let you flash.
http://s000.tinyupload.com/index.php?fil...5934757162
find
quote
#4
thanks, I now flashed the Bios recommend me above and also I found an inofficial Mod Bios with a Spectre Patch here:

https://www.techpowerup.com/forums/threa...ds.246163/

All 3 Bios run fine, but unfortunately I still can't adjust Vcore with any of the three, any CPU Vcore setting change in Bios will be ignored in Windows and CPU Vcore is extreme low with 1.04 Vcore under load hindering any OC above 3,1 GHZ (337 FSB).

Any hindering Bios option regarding TDP or something is not in Bios, so it must be something else why I can't raise Vcore.

Somebody in german forum meant the Vcore chip could be an other on the OEM Board and could be read out with an EEPROM Reader.

Could someone help me here?

Thanks!
find
quote
#5
Show me image of CPU Voltage you are changing (Should be named CPU voltage, not vcore - "vcore" labelled one is non-functional even in MSI BIOS).
I ask for image to see if you can see both, or just one and if only one which it is.

TDP settings are in Turbo Boot Tech Config, you can see this menu correct? It should be one submenu entry above QPI Config

Also, at >> Advanced BIOS Features >> CPU Feature >> Did you disable >> "Overspeed Protection"

As for the "Spectre" BIOS, that would be similar to the one I sent you in 2018 folder, which I updated the microcode only for your Xeon CPU though, no others will have 2018 microcode (only 206C2)

It could be this Medion board is missing the voltage controller IC. Can you change voltage with regular CPU, like i7-920?
find
quote
#6
many thanks for trying to help me, much appreciated!
to Bios first
- I have 6 voltage Options in Bios (CPU Voltage, CPU PLL Voltage, QPI Voltage, DRAM Voltage, NB Voltage, ICH Voltage), raised all a bit without difference for CPU Voltage in CPU-Z, getting crashes with slightest OC at 3,2 GHZ because only 1.04 Voltage on CPU under load as explained before.
- Overspeed protection I can disable or have on enabled, no difference vcore can't be raised
- TDP Settings I don't have in Bios, looked really all submenus. Bios option Turbo Boost Tech only gives Enabled or Disabled with no submenu under and also no difference if enabled or enabled.
- There is Mainmenu called Green Power in Bios, this give CPU Phase Control, IOH Phase Control, DDR Phase Control and Motherboard LED Control options, all 4 with option for setting Disabled or Auto. But again, equal if on Auto for all or Disabled for all no raise of CPU Vcore possible.

for trying with other CPU:
Yeah had this (last) idea also. I don't have the i7-950 which I used for flashing of the MSI OEM Bios anymore, what I still have is an W3520 CPU. It's same Bloomfield Generation as an i7-9xx, so should be a try worth if I can raise Vcore with this one, or? If yes I would do at weekend.

If you have other idea meanwhile would like to hear, thanks!
find
quote
#7
CPU Voltage is the one that should be working. Did you try setting a big jump to see if it's actually not changing? Try setting 1.2-1.3 and boot to windows real quick and check

Show me image of Turbo Boot Tech Config page, so I can unlock rest of the settings for you.

ON CPU, I meant any regular desktop type CPU, like 920-990X etc. W3520 would work for my concerns, this is same as desktop 920 and more compatible than your other Xeon you're trying to use. Yes, try that one and see if it lets you raise CPU Voltage or not. And before that, be sure you're trying a large enough change for it to be visible minus normal expected vdrop. Moving just a little might not register is what I'm getting at there, like if you set 1.05 and only see 1.04 in windows, a change to 1.08 or 1.10 might still show up as 1.04, so be sure to try 1.2-1.3 etc so you're 100% sure it's not changing at all.

Also, make sure you are using latest CPU-z. You did compare and see same/similar voltages with HWINFO64 or MSI Softwares correct?
find
quote
#8
Thanks for Input again.

In short,
- tried huge additional voltage on top (even then in Bios red marked area where then under Windows should be an output of somewhere 1.4-1.5 Vcore...)
- no result under Windows every times 1.168 Vcore and - under heavy prime load - droop to 1.04 Vcore with no chance to get any OC in place

But I found something, this Turbo Boot Tech Config you refer to is not existing at all three Bioses for myself, its not visible at all (not even gray):

This should be there but at my Bios is only option above Intel Turbo Tech available with setting enable/disable
https://www.manualslib.com/manual/789772...=61#manual
https://www.manualslib.com/manual/789772...=63#manual

So if you could somehow visible / enable this Turbo Boot Tech Config page in any of Bios - latest MSI, one 2015, or 2018 one - I would say there is good chance to get problem solved. I could raise there all TDP limits and then something should be possible.

I really, really look forward if possible Smile
Thanks!
find
quote
#9
Thanks for testing large voltage change.

Please take images of your BIOS, all pages, and put into 7zip archive, then I will unlock all settings hidden from you.
Manual will not help me, I need to see your actual BIOS. You might be able to screenshot via F12 hotkey to USB, if not, use a camera and resize images please I don't need 3-5MB images of your BIOS, small 1MB or less images please, especially since there will be a lot. Do all pages of BIOS, even inside submenus too.
find
quote
#10
Hi,

was over weekend on travel and couldn't make pictures. Here we go now, only made pictures of the relevant Bios stuff, missing is to my knowledge/research really only this turbo tech config page - 8 picture -, all other I have. Bios in place is the second one you send my above in your first answer. Look forward if you can unlook this turbo tech config!

[Image: p11803875wkao.jpg]
[Image: p11803881mjvy.jpg]
[Image: p1180389abj15.jpg]
[Image: p1180390qfko8.jpg]
[Image: p1180391m6kz1.jpg]
[Image: p1180392yejlv.jpg]
[Image: p1180393wqk4r.jpg]
[Image: p1180394g5jbr.jpg]
[Image: p1180395clk4c.jpg]
[Image: p11803968vkx9.jpg]
[Image: p11803971jje8.jpg]
[Image: p1180398hdjgo.jpg]
[Image: p1180399jdjr8.jpg]
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in