Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Lenovo IdeaPad 3 14ALC6 (GLCNx...
Last Post: Dudu2002
Today 02:24 PM
» Replies: 4
» Views: 0
[REQUEST] Lenovo Flex 2-14 (A0CNxxWW) Wh...
Last Post: Dudu2002
Today 02:22 PM
» Replies: 275
» Views: 61439
[REQUEST] Acer Aspire 3 A317-53 BIOS Unl...
Last Post: Dudu2002
Today 02:18 PM
» Replies: 4
» Views: 0
[REQUEST] Unlocked BIOS for Dell PowerEd...
Last Post: Capt Swirly
Today 01:15 PM
» Replies: 0
» Views: 0
locked Bios unable to flash
Last Post: SPARTAN_II
Today 10:20 AM
» Replies: 0
» Views: 0
[REQUEST] Acer Nitro 5 AN515-54 BIOS Unl...
Last Post: Dudu2002
Today 03:52 AM
» Replies: 107
» Views: 20875
[REQUEST] Lenovo ThinkPad T450(s) (JBETx...
Last Post: Dudu2002
Today 03:50 AM
» Replies: 166
» Views: 66871
[REQUEST] Acer TMB311R-31 Travelmate Spi...
Last Post: Dudu2002
Today 03:48 AM
» Replies: 1
» Views: 0
[REQUEST] ASUS FX504GM BIOS Unlock
Last Post: yiorgas
Yesterday 11:20 PM
» Replies: 11
» Views: 2692
[REQUEST] Medion Akoya E1318T BIOS Unloc...
Last Post: Maxinator500
Yesterday 10:50 PM
» Replies: 12
» Views: 4002
Making forms visible
Last Post: erfto1
Yesterday 05:00 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad T440p (GLETxxW...
Last Post: Dudu2002
Yesterday 04:44 PM
» Replies: 695
» Views: 154529
dell bios a09 unlockable?
Last Post: 3dguy
Yesterday 12:23 PM
» Replies: 0
» Views: 0
[Request] F.18 (HP Omen), based on AMI
Last Post: Bizzi
Yesterday 11:53 AM
» Replies: 0
» Views: 0
[Request] Redmibook 16 intel bios unlock
Last Post: Dudu2002
Yesterday 11:16 AM
» Replies: 1
» Views: 0
[REQUEST] Packard Bell EasyNote TE11BZ B...
Last Post: Maxinator500
Yesterday 12:37 AM
» Replies: 18
» Views: 3662
[REQUEST] Bios Unlock Asus ROG GL552VW
Last Post: feluchi
02-06-2023 01:06 PM
» Replies: 204
» Views: 59313
[Request] Adding 7th Gen CPU support to ...
Last Post: Mamouth_74
02-06-2023 12:18 PM
» Replies: 2
» Views: 0
Extract hp 32mb bios
Last Post: Maxinator500
02-06-2023 11:06 AM
» Replies: 1
» Views: 0
ADVANCED OPTIONS BIOS VRAM
Last Post: Benjiiiita
02-06-2023 10:35 AM
» Replies: 0
» Views: 0

[Request] Fujitsu D3402-B11 Kaby Lake (7th gen) support
#1
Hi,
I have a Fujitsu D3402-B11 motherboard and want to use it with an i5-7500 CPU. I chose this hardware combination because I wanted low power consumption for which Fujitsu motherboards are known and also HD 630 iGPU - this is going to be a home server/nas build. I am also using 3200 MHz CL16 RAM - it should work at reduced speed.

According to Fujitsu, D3402-B11 only supports 6th gen Skylake CPUs. However there also exists a seperate variant of this motherboard D3402-B21 - it supports both 6th and 7th gen Kaby Lake CPUs. Here is the datasheet for both models:

Datasheet

I compared pictures of both models and they appear ideantical hardware wise. This document from Fujitsu confirms the only difference is the BIOS:

Fujitsu ECN

So my plan was to swap the B21 BIOS to my B11 motherboard. Because I don't have a Skylake CPU, I wanted to use a CH341A programmer to program the BIOS chip directly. Here are the BIOS files from Fujitsu:

D3402-B11 bios files from Fujitsu website
D3402-B21 bios files from Fujitsu website

My D3402-B11 motherboard uses an mx25l12850f bios chip. I used AsProgrammer software with the CH341A programmer but there was no 50f chip on the supported chip list, so I chose the mx25l12845e. I managed to successfully download the bin file from my bios chip:

BIOS bin downloaded from the chip

BIN file downloaded from the chip is 16384 KB in size and this is also the maximum capacity of the chip. First I tried swapping the microcodes from the B21 bios to my bios file downloaded from the chip and writing it back to the motherboard. I used CoffeeTime 0.99 tool to do this and it didn't work - the motherboard is basically bricked and doeasn't react to the power button. It powers on immediately after turning on power. The 7500 CPU and motherboard power stages get really hot but nothing happens. There is no picture from the iGPU (DVI). 

Now after reading more on the forum I know that simply swapping microcodes is not going to work. The ideal plan would be to just flash the B21 bios from Fujitsu website to the B11 motherboard, basically transforming it into a B21 model. However there is a problem. Only useful files Fujitsu provides is a ROM file - 8192 KB in size and a UPD file (DOS folder) - 23561 KB in size. These file sizes are the same for both B11 and B21 models. This makes the ROM file too small and the UPD file too big to fit on the chip. 

I think the proper way of doing this would be to use the B21 UPD file - it is identical in structure to the bin file i got from my chip (checked with UEFITool). The difference in size is from the extra Padding added to the B21 UPD. By subtracting this padding the file size would be identical to my chip capacity - 16384 KB. I don't know how to mod this file to fit into my chip.

So what should I do? I have experience in working with electronics but none in bios modding. Can you please help me solve this? Thank you in advance.
find
quote
#2
Just truncate D3402-B2.UPD to 16384 KB and flash.
find
quote
#3
(01-21-2023, 07:16 AM)DeathBringer Wrote: Just truncate D3402-B2.UPD to 16384 KB and flash.

I truncated the file as you described and it actually worked. Thank you!
I am attatching the bios file if anyone wants to replicate this mod in the future.


Attached Files
.zip   D3402-B2_short.zip (Size: 6.79 MB / Downloads: 1)
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)