Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
Where do you prefer to live?
Last Post: Lakshmiplayablo
Today 01:31 AM
» Replies: 8
» Views: 7755
HP Spectre X360 BIOS Corruption
Last Post: managerharry
Yesterday 11:40 PM
» Replies: 1
» Views: 59
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: hall9
Yesterday 10:23 PM
» Replies: 2090
» Views: 492238
[REQUEST]AfterShock APEX 15 LITE AMI Bio...
Last Post: genius239
Yesterday 07:52 PM
» Replies: 8
» Views: 378
Pegatron M2N68-LA/HP Ivy8-GL6: CPU Upgra...
Last Post: erpster9e
Yesterday 06:26 PM
» Replies: 41
» Views: 17311
[REQUEST] HP Envy 17 3D 1.gen Bios: F.1D
Last Post: brabus86
Yesterday 11:54 AM
» Replies: 13
» Views: 964
[REQUEST] BIOS Unlock for Gigabyte Aero ...
Last Post: SampleX
Yesterday 09:10 AM
» Replies: 0
» Views: 76
[REQUEST] Bios Unlock Gigabyte AERO 15 K...
Last Post: NYCgrimesolver
Yesterday 02:29 AM
» Replies: 4
» Views: 545
[REQUEST] Lenovo G500 (78CNxxWW) Whiteli...
Last Post: Manoeler
07-05-2022 11:38 PM
» Replies: 1259
» Views: 234914
[Request] Thinkpad E14 - Unlock DVMT set...
Last Post: ly4dsg
07-05-2022 10:06 PM
» Replies: 0
» Views: 102
HP victus F11 advanced controler
Last Post: Postovali
07-05-2022 10:02 PM
» Replies: 0
» Views: 81
Microcode Update on Elitedesk 800 G1
Last Post: DeathBringer
07-05-2022 11:37 AM
» Replies: 27
» Views: 7718
[REQUEST] Asus B85M-G NVME support
Last Post: peperitz@hotmail.com
07-05-2022 02:48 AM
» Replies: 2
» Views: 4043
[Request] Zotac Magnus One AMI Bios unlo...
Last Post: genius239
07-04-2022 09:07 PM
» Replies: 58
» Views: 7167
[REQUEST] Asus P5BV-C BIOS unlocking
Last Post: Jackorsomething
07-04-2022 08:41 PM
» Replies: 0
» Views: 163
[REQUEST] Dell Optiplex 3010 BIOS Unlock
Last Post: zantetsuken
07-04-2022 02:44 PM
» Replies: 11
» Views: 1964
HP Probook 4510s [WHITELIST REQUEST]
Last Post: tequissx
07-04-2022 11:38 AM
» Replies: 4
» Views: 5557
HP ProDesk 600 G4 support for 9th gen CP...
Last Post: DeathBringer
07-04-2022 11:37 AM
» Replies: 1
» Views: 203
[REQUEST] Acer Aspire E1-431 BIOS Unlock
Last Post: absorbios
07-04-2022 11:12 AM
» Replies: 10
» Views: 10267
[REQUEST] Lenovo IdeaPad U330, U430 & U5...
Last Post: Dudu2002
07-04-2022 07:10 AM
» Replies: 469
» Views: 98923

[Request] Thinkstation S30 Ivy Bridge Support
#1
Please add Ivy Bridge CPU support to this BIOS 

https://download.lenovo.com/pccbbs/think...361usa.zip

There are apparently two different machines being sold as the Thinkstation S30, the 43XX series which support Ivy Bridge (Xeon E5-26XX V2 CPUs) and the 05XX series (which I have, only supports E5-26XX V1 cpus)
find
quote
#2
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with current CPU.
find
quote
#3
(01-07-2018, 01:42 PM)DeathBringer Wrote: Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with current CPU.

might take a little bit, it's running macOS 10.13.2 and all of my SATA ports are populated and set up as a massive RAID0+Fusion drive.  Is Windows to go still a thing, or did M$ bail on that idea?  I might be able to bootcamp the SSD portion of my fusion drive, but I'm going to need to make a Time Machine backup first.
find
quote
#4
Use Windows LiveCD
BTW: Tell exact model number
find
quote
#5
(01-07-2018, 01:52 PM)DeathBringer Wrote: Use Windows LiveCD
BTW: Tell exact model number

In the process of building out a Windows To Go USB.  Stand by...
find
quote
#6
(01-07-2018, 01:52 PM)DeathBringer Wrote: Use Windows LiveCD
BTW: Tell exact model number
[Image: AVFNZPd.png]

[Image: h7SdckD.png]

My computer model number is Thinkstation S30 M1-M 0568-47U.  Serial Number is MJPPLLH if that helps.  I've also included the .txt report from CPU-Z just in case.  I'd really rather not have to reboot into Windows again as every time I do, it borks the bootloader.  The UEFI implementation on this workstation is wonky, anytime you boot an OS, it adds an entry to the EFI boot list (without a menu in BIOS to adjust said boot list).  Also, fun fact: it REQUIRES the first boot entry to be named either "Windows Boot Manager" or "Red Hat Enterprise Linux" or it will refuse to boot on its own, throwing a super un-helpful 1962 error.  In order to fix my bootloader after booting Windows (or Redhat for that matter) I have to boot another Linux distro, eg; Ubuntu and create a dummy entry in EFI, eg;

sudo efibootmgr -c -d /dev/sda -p 1 -l '\EFI\CLOVER\CLOVERX64.efi' -L "Windows Boot Manager"

but anyway...


Attached Files
.txt   DESKTOP-TQDRNUU.txt (Size: 141.08 KB / Downloads: 3)
find
quote
#7
Make BIOS backup by Universal BIOS Backup ToolKit 2.0.
Did you tried to flash BIOS for ThinkStation S30 (type 4351, 4352)?
Have you hardware programmer to recover BIOS?
find
quote
#8
(01-08-2018, 04:14 AM)DeathBringer Wrote: Make BIOS backup by Universal BIOS Backup ToolKit 2.0.

[Image: PDv4C7s.png]
No such luck
find
quote
#9
Try to set custom size: 8192K & 16284K
find
quote
#10
(01-09-2018, 03:35 AM)DeathBringer Wrote: Try to set custom size: 8192K & 16284K

I tried dumping it with a bunch of different settings.  Let me know if this works.

https://drive.google.com/file/d/1UM7o7yF...sp=sharing
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)