Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
need help for 25L064CVIG bios and CH341A
#1
Hello

I changed a setting in the bios of my tablet, and it turned into a brick.
They say the only solution to fix it is to flash its bios chip, so I did buy a CH341A along with a 1.8v converter.

But the software CH341A_130.exe says "Access violation at address 0097EA42. Read of address 0097EA42." when I click "detect".
I do not find any solution searching for this error.

To beggin with, did I plug everything correctly ?
           

This is the bios. (It is not in the list of the software.)
       
The red wire is where the circle is on the chip.

I tried another version of the software, it can detect and read the chip, but there are only 00 's ...
find
quote
#2
This looks like GD25LQ64CVIG - Try Gigadevice GD25LQ64 1.8V, or choose Common 25X64. you'll need version 1.34 software, it's here in this package I post for everyone - http://s000.tinyupload.com/index.php?fil...5007472602
ASProgrammer 1.40 also has similar ID you can use, but it doesn't specify 1.8V (GD25Q64)

Here is guide on how to set everything up correctly, treat your adapter as a flash chip or SOIC Cable, pin one on it needs to match up to pin one on the programmer in same place as cable or DIP chip
https://www.bios-mods.com/forum/Thread-G...programmer

Make sure you cable is connected to the correct set of pin holed in the black part, some cables have 10 holes in the adapter/cable end when only 8 are used. Looks correctly setup, but hard to tell for sure. So probably just need to choose the right ID and it will be working.

Sometimes there is always error, ignore and continue, then check produced file with BIOS tools, hex editors etc and make sure it's a valid complete BIOS before you write anything. Ideally you don't want to write stock BIOS to the board, you'll loose your serial, UUID, LAN MAC ID Ect, hopefully this is still preserved in the bricked BIOS and can be transferred over once you're ready to write.

Do not use "Auto" function until you are sure you're ready to write, it's first action = erase!
Read, verify, and if verified in app, then hit save and check to make sure actual BIOS and not all FF or 00.
find
quote
#3
Thank you very much for these explanations.
Just to be sure : 1 4 5 8 on the SOIC must match 1 4 5 8 on the adapter, near the lever, doesn't it ? I have a doubt because on the CH341A the SOIC or the chip would be at the other side.

Still no luck though with 1.34, neither with Gigadevice GD25LQ64 1.8V nor Common 25X64.
It keeps saying "Detection fails, could not find the chip." when I try to detect or read.
find
quote
#4
Yes, pin one is on the lever side of both adapter and programmer, but it's in the middle block not the block near end of device (On programmer, it's opposite that on adapter) Remove that green PCB, unless it's soldered, it may be causing you issues/confusion.

Adapter side, the cable goes into slot of 4 closest to the lever, but not in the programmer, on programmer it goes to block furthest from lever (Pin 1 always on lever side though)

Chip may be dead/faulty, but probably not if you just flashed an incorrect BIOS to it. Try with power connected to the device and see if that changes anything, first try with main battery installed, then if no changes try with main power connected too. Sometimes this is needed, depends on device.

Be sure you have the jumper on pins 1-2 on the other side of the programmer, not visible in your images
find
quote
#5
It just keeps saying it can't find the chip. Sad
During all my tries yesterday I ended up putting the SOIC the wrong way on the chip. Could it be dead because of it ?

I never flashed it yet. I turned on some option in the bios and saved, it turned off and it never woke up again.

If there is nothing else I can try, then I guess the only option left for me is to buy a new chip, flash it and solder it in place of this one. I doubt it can be done with a regular soldering iron, does it ?
find
quote
#6
You need to drop the chip and install it on the platform, then the programmer will determine it, and with a clothespin, nothing will come out of you

He could not identify the chip with the clothespin, and when he installed it on the platform, it was immediately definitive. You must be very careful with the chip fragile legs
find
quote
#7
Keep at it, you will get it. No, I doubt it's dead from backwards, I've done this many times with chip in programmer accidently, it just gets super hot very quickly. I'm sure maybe if left there then it's possible to kill a chip this way, but I think it would take long time, at least more than a few minutes.

Did you try with main battery installed, and or power supply connected too? Some systems you need one or both of those otherwise nothing detected.

If you have good soldering skills, or low melt solder, then removing a BIOS chip isn't hard and yes can be done with soldering iron. But, if you have neither of those then yes it's hard due to most boards no use lead free solder and it's very difficult to get flowing without being familiar with the process and how to do safely without burning the board or lifting traces etc.
find
quote
#8
I did not unplug the battery, its wires are soldered on the pcb. Do I have to ?
I also tried with power plugged in.

I noticed that one of the pins on the SOIC clip is shorter. It may be too short to touch the legs of the chip.
   
So I am ordering another one. 

While I am at it, I am also buying a GD25LQ64CVIG bios chip, in case this one ends up broken if I unsolder it or if it is dead. I guess I need a socket adapter to put it on the 1.8v adapter and CH341A, but I do not find any, they all have more than 8 legs.

But I hope that the shorter pin is the explanation why it does not work so far, so I do not have to unsolder it. It is very tiny, and there are minuscule other component next to it. I can see myself sliping with the solder iron and breaking these.
find
quote
#9
In that case no, about the battery (even if you meant main battery, not CMOS)

That could be about the pin, you could try to extend it somehow.

If you plan to desolder chip, then I think you want one of these to easier put into adapter
https://www.ebay.com/itm/173018583512

Send me a copy of the BIOS for this system, and I can show you what all chips are compatible.

Yes, it's very hard to remove chip in that position with everything around if, if you are not skilled in doing that, I suggest against it. Post the full model and motherboard printed name etc, all identifying numbers you can, maybe I or someone else can find schematic for you, sometimes boards like this can program the BIOS through KB ribbon cable too.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in