Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[request] xeon x5675 support on dfi lanparty dk x58
#1
Hello everyone,
I have a little modding project on my dfi lanparty dk x58.
I wanna run a xeon x5675 on it like on other x58 motherboard, but there is no bios that supports it directly.
The latest bios does support i7 980x and xeon of the w3xxx series.
Iam not sure if its possible to make it work and i guess it might be quite a bit of work. Anyway here is the Information:

Bios: see atachment (this is the latest one and might have use for the community since the official dfi website is down and you cant find all the bios files on the internet anymore)
what happens: motherboard does not post and just shows a black sceen
cpuid Revision of current cpu: 000106A5h
cpuid Revision of cpu i want to add: 000206c2 (looked up on the internet pls confirm this)
Microcode of the new cpu : see attachment (maybe there is a newer one, if someone can find please post it)

For example the asus p6t ws has support for the xeon cpus. The bios for those boards can be found here: 
http://dlcdnet.asus.com/pub/ASUS/mb/sock...1469915138

Iam Interested in bios modding myself and even if noone can mod it iam still thankful for any tips someone can give me to make my board support this cpu. I tried to add support myself with the following command:

cbrom195.exe x58dfi.bin /nc_cpucode cpu000206c2_plat00000003_ver00000013_date20100907.bin

but it does not seem to add the cpuid to the bios. Running intelmicrocodelist.exe x58dfi.bin does not show the new cpuid in the table. Any suggestion why that is ?

Greetings
vekx


Attached Files
.bin   x58dfi.bin (Size: 1 MB / Downloads: 9)
.bin   cpu000206c2_plat00000003_ver0000000f_date20100618.bin (Size: 7 KB / Downloads: 3)
.bin   cpu000206c2_plat00000003_ver00000013_date20100907.bin (Size: 7 KB / Downloads: 4)
find
quote
#2
Please tell the full name of the motherboard and sSpec of your Xeon X5675.
Post the screenshots of third (Mainboard) tab of CPU-Z with supported CPU.
find
quote
#3
(07-31-2016, 02:19 AM)DeathBringer Wrote: Please tell the full name of the motherboard and sSpec of your Xeon X5675.
Post the screenshots of third (Mainboard) tab of CPU-Z with supported CPU.

Hello Deathbringer,
i updated my first post with the correct information. Here the is the site from which i got the information for the cpu which support i want to add:
http://www.cpu-world.com/sspec/SL/SLBYL.html

Information of the Motherboard gathered from aida 64 is the following:

Motherboard ID 09/08/2010-Tylersburg-8A79TD4YC-00
Motherboard Name DFI LANParty DK X58-T3eH6

I hope it helps you. Please read first post again for updated information since i researched a bit last night and got some basic knowlede on adding cpu support myself. If u need anything else please let me know.

Edit here is the screenshot that you requested:
[Image: info.png]
Greetings 
vekx
find
quote
#4
Your motherboard has Diagnostic LED.
What's the code on it when you try to boot X5675?
find
quote
#5
I tried it yesterday and it did not show any code at all on the diagnostic led. Then i reinstalled the old cpu again and it just booted up.
find
quote
#6
So new CPU isn't supplied with a power at all and BIOS isn't loaded.
BIOS modding can't help yet.
find
quote
#7
To add new microcode make empty file NCPUCODE.BIN and run:
Code:
CBROM196 x58dfi.bin /nc_cpucode NCPUCODE.BIN
copy /b NCPUCODE.BIN+cpu000206c2_plat00000003_ver00000013_date20100907.bin NCPUCODE.BIN
attrib +R NCPUCODE.BIN
CBROM196 x58dfi.bin /nc_cpucode NCPUCODE.BIN
find
quote
#8
(07-31-2016, 03:33 AM)DeathBringer Wrote: To add new microcode make empty file NCPUCODE.BIN and run:
Code:
CBROM196 x58dfi.bin /nc_cpucode NCPUCODE.BIN
copy /b NCPUCODE.BIN+cpu000206c2_plat00000003_ver00000013_date20100907.bin NCPUCODE.BIN
attrib +R NCPUCODE.BIN
CBROM196 x58dfi.bin /nc_cpucode NCPUCODE.BIN

Thank you for your help. I followed your instructions
[Image: info.png]

as u can see it removed some entrys in the cpuid table and added the one i wanted. Is that normal?
find
quote
#9
What's removed?
And you don't follow my post. You didn't ran CBROM twice.
find
quote
#10
(07-31-2016, 03:50 AM)DeathBringer Wrote: What's removed?

as you can see on the screenshot it removed cpuid 206c0 and cpuid 206c1

yes you are right i didnt run twice my bad i will do it again.

Edit: Ok now everything seems to be updated the right way. Thank you very much for your help. Even if the cpu does not seem to get power i still learned a bit.
I might try to flash the modded bios and see if there is any difference, but chances are slim i think.

Edit2: Oki i flashed the modded bios and it still does not boot up. Anyway thank you for your help.

Edit3: Tried to install it once again. This time i left out alle the memory modules and now the post LED showed code "88"
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in