Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[Request] Lenovo V50t-13imb whitelist re...
Last Post: Tweaknap
Today 04:44 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: VALSIDALV2110
Yesterday 08:18 AM
» Replies: 863
» Views: 176888
[REQUEST] Lenovo X270 (R0IETxxW) Whiteli...
Last Post: Dudu2002
02-28-2024 11:36 AM
» Replies: 19
» Views: 2602
Where to safely download AMIBCP?
Last Post: daphnehernandez
02-27-2024 11:55 PM
» Replies: 0
» Views: 0
[REQUEST[ Acer Nitro 5 AN515-46 BIOS Unl...
Last Post: ThuskedHelli
02-27-2024 11:36 AM
» Replies: 8
» Views: 0
[REQUEST] Acer Aspire V3-772G BIOS Unloc...
Last Post: Vln
02-27-2024 08:17 AM
» Replies: 460
» Views: 150547
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: potforiak
02-26-2024 01:20 AM
» Replies: 761
» Views: 151572
Lenovo T480 Bios Mod
Last Post: Dudu2002
02-25-2024 07:24 AM
» Replies: 4
» Views: 0
Last Post: Eclipse1407
02-24-2024 09:18 PM
» Replies: 0
» Views: 0
Core 2 Mobile BSEL mod
Last Post: HorseRider
02-24-2024 11:02 AM
» Replies: 0
» Views: 0
[Request] Lenovo T540p (GMETxxWW) BIOS U...
Last Post: beastie38
02-24-2024 09:49 AM
» Replies: 56
» Views: 28018
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: LenovoInsydeH2O
02-24-2024 08:18 AM
» Replies: 1725
» Views: 520365
Lenovo G50-70 bios recovery
Last Post: 13YTe
02-23-2024 02:42 PM
» Replies: 5
» Views: 7189
uCode update for Fujitsu-Siemens Amilo D...
Last Post: shiz_balls101
02-23-2024 08:12 AM
» Replies: 12
» Views: 0
[REQUEST] helios 500 ph517-61 BIOS Unloc...
Last Post: Irito
02-23-2024 06:08 AM
» Replies: 2
» Views: 0
[Accepting Requests] HP Probook 4530s WL...
Last Post: Maxinator500
02-22-2024 10:47 PM
» Replies: 1
» Views: 0
Add NVM Express support to H110M Pro VH ...
Last Post: wavedevice
02-22-2024 07:44 PM
» Replies: 5
» Views: 0
Forgotten tools from HP
Last Post: Maxinator500
02-22-2024 01:21 PM
» Replies: 3
» Views: 0
[Question] Acer Aspire R7 572G Haswell t...
Last Post: DeathBringer
02-22-2024 08:42 AM
» Replies: 3
» Views: 0
[REQUEST] Lenovo IdeaPad Gaming 3 15IMH0...
Last Post: ideapad3-15IMH05
02-22-2024 02:15 AM
» Replies: 71
» Views: 12320

[Request] Adding 7th Gen CPU support to Fujitsu D3430-A1
Hi, I purchased a FUJITSU ESPRIMO D556/E85 a long time ago.

It currently has an Intel® Celeron® CPU G3900 (Spec code SR2HV) installed and I have a spare i5-7500t (Spec code SR337) that i would like to put inside.

Thing is, the FUJITSU ESPRIMO D556/E85 motherboard (D3430-A1) only supports 6th gen while is conterpart FUJITSU ESPRIMO D556/2/E85 motherboard (D3430-U) supports 7th gen (cf:

They both run the same chipset but have two different motheboard model.

Mine (D3430) has a BIOS update that you can find here:

while the one supporting 7th gen(D3430-U) has a BIOS update that you can find here:

While i tried putting my i5-7500t in the slot, it would not boot. The cpu would just get hot but nothing would show on screen.

I was tempted to try and update by D3430 with the D3430-U BIOS update but my knowledge in BIOS is really weak and I would prefer not to brick my Motherboard without anyone's advice.

What would you suggest ?

Just truncate D3430-U1.UPD to 8192 KB and flash by a hardware programmer.
Am I supposed to flash the truncated .upd file ? I was thinking about using a ch341a.
Desired CPU compatibilty from (microcode donor): FUJITSU ESPRIMO D556/2/E85+ (MoBo model D3430-Ux, Latest BIOS from manufacturer) can run 7th gen. Intel processors

My (slightly older model) PC: FUJITSU ESPRIMO D556/E85+ (MoBo model D3430-Ax, Latest BIOS from manufacturer) can not run 7th gen. besides running same H110 chipset and similar MoBo.

Hi guys,
I fell into some issues with the Fujitsu Esprimo D556/E85+ (MoBo: A3430-A14 GS 2). It runs an Intel G4400 CPU (6th gen.) without issues. I`ve seen online same PCs running 7th gen. processors (as it`s got an H110 chipset, I thought it would be plausible), so I bought an i3-7100. Unfortunately it doesn`t start. So I went to the Fujitsu CPU compatibility list, and bought another CPU, an i5-6500. Doesn`t run either. After some research I found some guys running into similar problems have modded the original Fujitsu BIOS with upgraded microcoede for gen.7 processors, unfortunately I haven`t found ready-to-flash file, so I ask you kindly to help me with that matter. Maybe you have that BIOS ROM-file ready to post here, or maybe you can guide me through the modding process.

CPU compatibility list for both MoBos.
Post a screenshot of Mainboard tab of CPU-Z.

(09-26-2023, 01:31 PM)mihauuu Wrote: and bought another CPU, an i5-6500. Doesn`t run either.
Check it with other motherboard.
(09-26-2023, 02:41 PM)DeathBringer Wrote: Post a screenshot of Mainboard tab of CPU-Z.
*I need few days for doing that, after checking back and forth with all these CPUs unfortunately I run out of thermal paste (I like to use good/proven one, like the Noctua NT-H1). Ordered fresh one today, but expected delivery is on the 4.10.2023 (would come on 2.10. normally, but that day I took off, and that is because 3.10. is independence day in Germany). So can't do the screenshot now.

(09-26-2023, 02:41 PM)DeathBringer Wrote: Check it with other motherboard.
*Only have this Fujitsu D556 and another mobo for 4th gen. Intels, so no possibility to check at this moment. I will ask some friends if someone else runs on LGA1151. Also, the seller assured me he tested the processor before shipping. 

Meantime I also tried your suggested solution from another post on same BIOS, but I failed (yes, I bought this "CH341A pro" J-Tag only for that purpose, I am struggeling with these CPUs for some time now....). (Thats the reason why the thermal paste went gone too, haha.)
Not sure if I should post the detailed results here in this thread, or should answer in the other thread. I am not very familiar with posting on any forums (somehow barely needed that tool in the past), sorry about that.

Thank you for your support that far anyway!  Heart
Use trunc.exe in Windows:
trunc D3430-U1.UPD 8388608
(09-28-2023, 03:14 PM)DeathBringer Wrote: Use trunc.exe in Windows:
trunc D3430-U1.UPD 8388608

Itried but I think I made wrong file size.
I used CH341A Pro. The chip on the MoBo was W25R64JVSSIQ. I did not find same chip in Neoprogrammer repository, so I chosse a close one. Dont have the trunc.exe file in Windows10 Pro, nor does this software work when I copy it on my HDD. So I used another method: fsutil.exe. After truncating I was able to programm the EEPROM with this *.UPD file, but after the flash the BIOS went dead (no problem as I got the contact pliers, and I made backup, and I have another 2 PC with same configuration...)
I think I truncated to 9000000 or bad Smile
I will try to correct in few days when I am back at home.
Once again, I appretiate your help, DeathBringer!
After examining all these CPUs, I run out of thermal paste (I use the Noctua NT-H1). It takes a few days. Ordered a new one today, but it won't arrive until 4.10.2023 (we took off on 2.10. since 3.10. is German independence day). We can't screenshot currently.  space bar clicker

Forum Jump:

Users browsing this thread: 1 Guest(s)