Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: Dudu2002
Today 04:36 PM
» Replies: 863
» Views: 177247
Asus N73SM & i7-2920XM
Last Post: uRbAsOn
Today 04:06 PM
» Replies: 2
» Views: 55
Lenovo IdeaPad 3 17ADA05 BIOS Bricked
Last Post: SamyoFox
Today 02:00 PM
» Replies: 0
» Views: 48
[REQUEST] HP Mini 210-4000 series BIOS U...
Last Post: DarioX7
Today 10:28 AM
» Replies: 55
» Views: 18896
HP 17-cn0053CL BIOS Unlock {Request}
Last Post: thetechysasquatch
Today 10:08 AM
» Replies: 0
» Views: 82
[REQUEST] Lenovo G510 (79CNxxWW) Whiteli...
Last Post: Dudu2002
Today 08:08 AM
» Replies: 650
» Views: 158648
Gericom X5 Bios - mod
Last Post: BootlegScarce
Today 07:46 AM
» Replies: 2
» Views: 87
Unlock all hidden options for insydeh20 ...
Last Post: alin.tecsan
Today 06:42 AM
» Replies: 266
» Views: 1012052
[REQUEST] Asus eeepc 1025C
Last Post: Cocones
Today 06:27 AM
» Replies: 85
» Views: 106181
[Request] bc-250 bios unlock
Last Post: Buraz25
Yesterday 03:41 PM
» Replies: 0
» Views: 74
[Request] Lenovo V50t-13imb whitelist re...
Last Post: Tweaknap
03-01-2024 04:44 AM
» Replies: 0
» Views: 59
[REQUEST] Lenovo X270 (R0IETxxW) Whiteli...
Last Post: Dudu2002
02-28-2024 11:36 AM
» Replies: 19
» Views: 2771
Where to safely download AMIBCP?
Last Post: daphnehernandez
02-27-2024 11:55 PM
» Replies: 0
» Views: 65
[REQUEST[ Acer Nitro 5 AN515-46 BIOS Unl...
Last Post: ThuskedHelli
02-27-2024 11:36 AM
» Replies: 8
» Views: 72
[REQUEST] Acer Aspire V3-772G BIOS Unloc...
Last Post: Vln
02-27-2024 08:17 AM
» Replies: 460
» Views: 151150
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: potforiak
02-26-2024 01:20 AM
» Replies: 761
» Views: 151861
Lenovo T480 Bios Mod
Last Post: Dudu2002
02-25-2024 07:24 AM
» Replies: 4
» Views: 94
Last Post: Eclipse1407
02-24-2024 09:18 PM
» Replies: 0
» Views: 48
Core 2 Mobile BSEL mod
Last Post: HorseRider
02-24-2024 11:02 AM
» Replies: 0
» Views: 46
[Request] Lenovo T540p (GMETxxWW) BIOS U...
Last Post: beastie38
02-24-2024 09:49 AM
» Replies: 56
» Views: 28152

T430 will not flash bios

My T430 will not update BIOS, currently running 1.16 (first version Bios). 

Originally, tried updating with Lenovo Vantage app. When the computer restarts, it boots as normal with no BIOS updating screen. 

I have tried the standalone app from Lenovo's website, and the result is the same. 

I have tried several app versions from 1.17 to the newest. 

I have tried the 'Lenovo System Update' app. 

I have tried using the bootable .iso from Lenovo via a USB Key with Ventoy

Once with the bootable USB method I saw 'Flashing Embedded Controller. Do Not Poweroff' screen upon startup. It flickered for one second and then the screen turned black with power light ring on for 5-10 minutes before booting normally. There was no change to the bios. Subsequent attempts of this method did not produce the same result, just booting as normal. 

I don't have a CD burner to actually burn the image to a disc, if that would make any difference, but I doubt it at this point. I am trying to get one. 

I am running Windows 10. I have turned off fast startup. I have tried all methods booting in Legacy Bios mode and UEFI. I have tried the bootable USB with hard drive removed. 

Attached is a screenshot of "winuptp.txt" which I assume is a log from the Lenovo firmware flash software. It says the flash was completed successfully. 

I am potentially starting to suspect a hardware error. Since this PC is still not he very first BIOS version, perhaps the flash function never worked at all. 

I am an electronic technician in my day job, but mostly work with analog and early digital electronics, not computers. If I could buy the BIOS chip and flash it externally, then solder it in, I may try that if it could potentially fix the issue. Is there anywhere I could see what chips are used for the BIOS prior to opening up my PC? 

Any thoughts or tips are appreciated. My original goal was to run 1vyRain to use a new Wi-Fi card, but am now just trying to get the Bios update to work first. 

I also noticed the EC version is 1.13, but the EC distributed with 1.16 BIOS should be 1.07.

When I bought this computer, it had a 3rd party battery in it, and a stick from a refurbisher. I wonder if they did something to lock the bios flash? Is this possible?

I tried updating to EC 1.14 (the latest version), but it also did not work. Stuck at 1.13.


Attached Files Thumbnail(s)

Forum Jump:

Users browsing this thread: 1 Guest(s)