Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASUS M11AD > Haswell Refresh
Hello All,

I have an old desktop which I am using as a home server. I have a spare i5-4690k that I want to put in, however, while the motherboard is ASUS H81M-A it is a modified one:
Model M11AD (SOCKET 1150)
Version Rev X.0x
Brand American Megatrends Inc.
Version 0602
Date 3/19/2014

The latest BIOS for that motherboard is already installed but my i5 won't POST. Since the H81M-A definitely supports Haswell Refresh, I tried flashing the latest H81M-A bios onto my motherboard, however, it fails "Security Verification Failed". I have very little experience with modding BIOS and a lot of googling was not of success. 

Please help!
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with native CPU.
Did you tested your i5-4690K on other motherboard?
The CPU is currently working fine on my Z97 motherboard.
Here are the tabs you requested.

[Image: sX7Q09R.png]  [Image: Tfo3ePs.png]
Current BIOS has support for Haswell Refresh.
Look at configurations with Pentium G3240, i3-4150 and i5-4460.
I think the problem is unlocked multiplier.
P.S. I've found some useful information about M11AD & i7-4790S.
Try to disable EPU.
Thank you so much for the help. I got my hands on both a Haswell i3 and i5 CPUs. Neither worked. Like the person from Tomshardware said it really does look that ASUS locked each bios to ONLY the CPU the desktop shipped with... I tried running factory defaults on the BIOS and played with a number of settings and nothing worked. I guess i'm going to have to stick to my Pentium CPU... I think it is bizarre what they did since not even Dell or HP do things like that... If somebody is able to alter the BIOS to make it accept CPUs other than the one it shipped with I would be super happy, if not oh well... Smile

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in