Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 10 Vote(s) - 3.7 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CLEVO BIOS Mods
#21
With EC FW Modding, i think we can assign a key to Load Fail-Safe Settings. I have changed the key for BIOS Setup Entrance once. But then turned back to original image.
find
quote
#22
EDIT: Moved software links to OP


The AmiSCE documentation says it has the folowing bios requirements:

Token: SDSMGR_IN_RUNTIME = ON

Token: SMI_INTERFACE_FOR_SDSMGR_FUNC = ON

Anyone here, who could do something about that?
Being able to dump and rewrite the NVRAM would enable us to change almost everything without even touching the bios directly!




Quote:Everything has a price! The price to be paid for enduring happiness is Divine Love. Without Love, no object can give you real happiness!
Big Grin PREMA'S BIOS MODS Big Grin
www find
quote
#23
Waow thank you so much and of course another big thanks to Borg Number One!

We can not open our images with VeB because VeB is a project based developer tool with a compiler but not a 'decompiler'. That's why we get 'Out Of Memory' error when trying to open the images supplied from Clevo FTP.
I presumed that VeB would have a decompiler tool bundled with..

Up to now i am very demoralized with that Sad Unless we have decompiled the images or get the source codes, we'll have to stick with AMIBCP Sad
Btw, there is a token about SMI under Chipset/PCH-IO which is disabled.. And also there is a token named BIOS Lock and it is enabled.
find
quote
#24
I can't believe it...it looks like this guy can overclock his CPU with the 3D model..if this turns out to be true, then he must have an XTU BIOS:

http://tw.page.bid.yahoo.com/tw/auction/1216735610

[Image: 1216735610-ac-6910xf3x0590x0501-m.jpg]

EDIT: (THX@DXG) He did that screenshot on non 3D version... :'(



Quote:Everything has a price! The price to be paid for enduring happiness is Divine Love. Without Love, no object can give you real happiness!
Big Grin PREMA'S BIOS MODS Big Grin
www find
quote
#25
Hi Prema,

Have you figure out how to use Fn+B? Smile
find
quote
#26
Ah, good to have YOU here... Wink

As you know, it's the BIOS recovery mode. It looks for a BIOS image in the CD-ROM, but Clevo doesn't even tell their own resellers how to name the
BIOS file. I heard Sager themselves have to send it to the one and only service center stateside in case of a bad BIOS flash...guess that's how they make some extra cash.

BTW, I have this old BIOS revision with XTU for 3D Sager version...
Normaly it would brick a Clevo, but if you flash EC and BIOS without reboot in between it works to go back and forth! Smile
Thing is I have a 2960XM, which was not released yet when that BIOS came out.
So it would at least need a microcode update...

Quote:Everything has a price! The price to be paid for enduring happiness is Divine Love. Without Love, no object can give you real happiness!
Big Grin PREMA'S BIOS MODS Big Grin
www find
quote
#27
Yes, i know it is recovery mode. I have just bricked my BIOS and trying un-brick. Sad
I search the regular BIOS file in Clevo FTP with hex editor and Andy's tool to find that filename. Both in Andy's tool and in hex editor i find the filename as P170HMx.rom
Because of blank POST screen, i can only understand that my laptop enters the recovery mode by examing led & USB movements.
But i dont know what to do next. Laptop gives a response by trying to read USB Flashes and CDrom. But nothing more.

My exact steps are:

1. Power on the laptop(both battery and power cord plugged in).
2. As soon as it powers on, pressed Fn+B
3. Laptop tries to read USBs(just 2.0 ones) and the optical drive.

Is there any other key sequence to initiate the recovery flash?

Thank you
find
quote
#28
OK I have initiated flash process, i guess..

edit: false alarm Sad sorry


edit2: Prema, if you are using the default BIOS 1.01.05 & EC1.00.09 can you please share your BIOS dump(from AFUWIN) in here? Thank you
find
quote
#29
(02-07-2012, 02:04 PM)Naman Wrote: OK I have initiated flash process, i guess..

edit: false alarm Sad sorry


edit2: Prema, if you are using the default BIOS 1.01.05 & EC1.00.09 can you please share your BIOS dump(from AFUWIN) in here? Thank you

I am traveling without my Notebook...I did dump the BIOS with afuwin before but I am afraid it got stolen by the FBI along with Megaupload...

What exactly did you change in BIOS or ec?

What you could also try, except clearing cmos, is to remove all rams and boot, then put one back in and boot again. (All ram changes with battery out and no power cord attached)

BTW: This should trigger the recovery procedure (if we would know the correct filename. Regular file name is AMIBOOT.ROM but Clevo altered it)

EDIT: removed wrong information

Quote:Everything has a price! The price to be paid for enduring happiness is Divine Love. Without Love, no object can give you real happiness!
Big Grin PREMA'S BIOS MODS Big Grin
www find
quote
#30
I just re-flashed the stock images without flashing the bootblock.. Addition to that, laptop booted successfully. Everything wnet wrong after i load Optimized Settings in BIOS Setup by pressing F3.

I have 4 memory modules normally. I tried the 1st procedure.. I removed all the SODIMMs(w/o power+battery, of course) and turned on the machine. And then power off. Installed just 1 module and powered-back again. Nothing has changed Sad

I can not finish the 2nd procedure. I stuck on 6th step. While holding Fn+B i plugged the power adapter(step 4&5). And i pressed power button while still holding the Fn+B. Machine didnt power up because Fn+Power combination feature enables charging devices on the left USB2.0 port. So i can not boot with Fn+B+Power combination.
I can only made read the optical by pressing Fn+B a milisecond after pressing Power Button.

I think my problem is NVRAM.. If we figure out how to reset it, it will boot again Sad

Filename;

I have another laptop(lenovo) with a Aptio Bios aswell.. I dumped its BIOS and opened with a hex editor. Get the recovery filename and renamed the file that i dumped. THen i erased the Main Block just to be able to do a recovery session. And it worked. I have un-bricked the BIOS.

With the same tactic i am getting a filename 'P170HMx.rom'(case sens.) from all P170HM-Non3D, P170HM-3D BIOSes and from the EC images. I think the correct filename is P170HMx.rom ... But it didn't work either. May be i can not logon to recovery mode successfully. I don't know, i am just dealing with a blank screen Smile
(Tried external displays they are blank too.)

Yeah the FBI thing costs me a lot of resources in MegaUpload Sad

Have a good journey Smile
find
quote


Forum Jump:


Users browsing this thread: genius239, 2 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in