Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HP pegatron APX78-BN AGESA update
#1
hello @ll,

Since this Week End I'm trying to update the latest bios for the APX78-BN motherboard from HP to support a "new CPU".
At this time, this configuration is running latest HP available bios (5.12, file sp43067.exe I canpost if you need it) and uses CPU ADX250OCK23GQ.
I want to use CPU athlon 2 x2 280 model ADX280OCK23GM[url=https://en.wikipedia.org/wiki/List_of_AMD_Athlon_X2_microprocessors#cite_note-7][/url].
So I had  alook using mmtool and add some cpupatch from other motherboard such as M3N78-VM-ASUS-1801.ROM.
I flashed my bios using afuwin but still my x2 280 is not recognize, I get unsupported cpu mesage.
So I think it's time to ask for some help, since I'm pretty sure it is not enough (I mean patching) and it's linked to AGESA version which is !!AGESA V3.3.2 (I get it by editing the original bios with my hex editor).

So do you have a way to go or can you help me adding this CPU to the supported list ?

Thanks a lot.

PS: I've all the files if you need to get them, just let me know.
find
quote
#2
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with native CPU.
And make & post a foto of the screen with error.
find
quote
#3
(09-19-2016, 06:54 AM)DeathBringer Wrote: Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with native CPU.
And make & post a foto of the screen with error.

Hello,

Thanks for your interest. Sorry to say that the error is from bios string and very fast displayed before any POST (so that after 5 seconds of power the computer immediatly shuts down). Anyway I'll post you ASAP a screenshot of CPUZ (CPU and mainboard) with the working athlon 2 x2 250.

Regards.
find
quote
#4
Your case looks like this one.
Try to flash my mod.
If new CPU boots than make & post a screenshot of regedit with expanded key HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0
A new screenshot of CPU-Z is needed too.
find
quote
#5
(09-19-2016, 08:57 AM)DeathBringer Wrote: Your case looks like this one.
Try to flash my mod.
If new CPU boots than make & post a screenshot of regedit with expanded key HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0
A new screenshot of CPU-Z is needed too.

Hello again,

I'm back to all my servers and PCs.
So first thanks for this mod I'll give it a try in a few minutes.
But as per request here are the screenshots from CPUZ.
Don't know how you guess I was running Windows .... :p So that's a chance since I plan to run also Ubuntu 16.04. So that I'll be able to send you the registry entry also.

Regards


Attached Files Thumbnail(s)
       
find
quote
#6
(09-19-2016, 08:57 AM)DeathBringer Wrote: Your case looks like this one.
Try to flash my mod.
If new CPU boots than make & post a screenshot of regedit with expanded key HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0
A new screenshot of CPU-Z is needed too.
Here it is !!

So it's booting fine and detecting the model and speed.
Here is the exported reg entry (sorry I forgot I mentionned running afuwin so that of course you were aware I was running that OS:-)).

[HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0]
"Component Information"=hex:00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"Identifier"="AMD64 Family 16 Model 6 Stepping 3"
"Configuration Data"=hex(9):ff,ff,ff,ff,ff,ff,ff,ff,00,00,00,00,00,00,00,00
"ProcessorNameString"="AMD Athlon™ X2 280 Processor"
"VendorIdentifier"="AuthenticAMD"
"FeatureSet"=hex(4):fe,7d,3b,24,00,00,00,00
"~MHz"=dword:00000e10
"Update Revision"=dword:010000c8
"Update Status"="Success"
"Previous Update Revision"=dword:00000000
"Platform Specific Field1"=dword:010000c8

Then some differences with previous CPU I can see, stepping and revision, also seems the enhanced speed step makes it running at lower speed when idle but I get a look on the speed when launching some apps and it's reaching the full 3.6 GHZ speed.

One question: which piece of soft do you use to get the assembler code ? (my understanding is that you made a tricky working mod)...

thanks,

regards.

ps : just let me know if you need to have some other try or trace.


Attached Files Thumbnail(s)
   
find
quote
#7
I've made new mod with updated microcode.
Please flash it & make updated "exported reg entry".
P.S. I use usual disassembler.
find
quote
#8
(09-19-2016, 02:43 PM)DeathBringer Wrote: I've made new mod with updated microcode.
Please flash it & make updated "exported reg entry".
P.S. I use usual disassembler.

 Hello DB,

Thanks again. New BIOS downloaded.
I won't be able to flash until this afternoon (in France) but as soon as flashed I'll post you the reg entry.
Also I've already tryed the the following mod but it was not working (added cpu patch, see screenshot please).

Regards.


Attached Files Thumbnail(s)
   
find
quote
#9
(09-19-2016, 02:43 PM)DeathBringer Wrote: I've made new mod with updated microcode.
Please flash it & make updated "exported reg entry".
P.S. I use usual disassembler.

Hello,

flash done with mod2 provided rom.
Anything still seems running fine.
And I cannot see any change in CPUZ or even in the registry entry.
Anyway here they are posted.

[HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0]
"Component Information"=hex:00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"Identifier"="AMD64 Family 16 Model 6 Stepping 3"
"Configuration Data"=hex(9):ff,ff,ff,ff,ff,ff,ff,ff,00,00,00,00,00,00,00,00
"ProcessorNameString"="AMD Athlon™ X2 280 Processor"
"VendorIdentifier"="AuthenticAMD"
"FeatureSet"=hex(4):fe,7d,3b,24,00,00,00,00
"~MHz"=dword:00000e10
"Update Revision"=dword:010000c8
"Update Status"="Success"
"Previous Update Revision"=dword:00000000
"Platform Specific Field1"=dword:010000c8

Let me know if you want to add comment/other thing inside I should be able to test.

Got a question : did you let the loop jump pointer in place (don't remember if the words are correct for that since it's a long time ago from my studies...) ? or did you implement something else (other than the cpu patch) ?
My thought is HP is locking their mobo and also the model of supported CPU/hardware, even if any componenet is able to drive newer CPU (I choose the X2 280 because I was pretty sure it was working without any mod but ... you know I was wrong on one side but true since the motherboard is very happy with it running now with your mod)

Thanks,

Regards.


Attached Files Thumbnail(s)
   
find
quote
#10
Microcode isn't loaded from BIOS. Sad
Try to flash my new mod.
Make new "exported reg entry" after flashing and reboot. New screenshot of CPU-Z isn't needed.
P.S. In my first mod I've make the jump over printing error string & rebooting. Now I try to fix microcode loading. It's very important for Ubuntu.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in