Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to update vBIOS for Clevo W110ER?
I don't know about imgur images, remember, and I thought that was about BIOS flashing not vBIOS editing anyway?
I meant there was two Intel onboard vBIOS too, but I mentioned there being three before I checked things out, and saw you had edited the correct one. There's actually four, two Intel EFI Roms, and an Intel orom, and then NVidia orom. You did edit the correct vBIOS, the other ones I was referring to are for Intel onboard usage.

On the base clock, that's up to you, not sure what your intended changes were is why I mentioned you only edited boost clock. Setting higher boost clock only increased max allowed, not sure if that would show up in whatever you are checking with post-flash (GPU-z?)

I also mentioned due to what you said about not seeing changes reflected. All that may be due to the BIOS was rebuilt incorrectly, so the vBIOS may not have been updated during the reflash due to incorrect checksums (Skipped over during update possibly) Only way for you to know for sure is to reflash the BIOS I posted above, then if you see changed reflected you initially expected to see then you'll know that's what happened.

Nothing noob there, we all have to learn sometime, and BIOS is very tricky, especially editing vBIOS too.

I do not, would not, use PhoenixTool for this, or really wouldn't use MMTool either, but that's just me Big Grin Obviously one of those, probably PhoenixTool is not rebuilding the BIOS correctly, but it's hard to say which for sure since I did not check BIOS after each edit throughout your process. The file I attached above has only one edit, with UEFITool, I edited stock BIOS, and reinserted your edited vBIOS body, checksums are corrected on rebuild/save. vBIOS checksum itself was correct in your edited vBIOS, but in the header the contents data checksum was incorrect due to your changes, and then whatever tool rebuilt after reinsertion did not correct that, and it also messed up the microcode file on rebuild (unaligned)
The fixed rom flash ok but still not seeing the changed block speed.

can't work out how to edit the other vbios roms, i mean i edited them from BIOS0.BIOS and BIOS10.BIOS
but when i try and add the back phoenix tool says "Submodule to be inserted has invalid common header"
i also got "module count mismatch"

tried UEFITool but have no idea how to edit anything.
Show me what you are looking at where you are wanting to see a change, like screenshot of GPU-z or whatever you are seeing the speeds with.

You do not need to edit any other vBIOS roms, those are for onboard graphics not NVidia, stop now while you are ahead Big Grin
As I also mentioned, I would not suggest using PhoenixTool for editing this BIOS, it's purpose has nothing to do with modifying BIOS in this regard and is only used for stuff like this when there is no other options or other tools fail to do something the way you want. This BIOS can be modified properly and easily with UEFITool.

To use UEFITool you find the module you want to edit and extract then edit, but some things must be extracted in certain ways, which is why phoenixtool is failing you too.

Show me what you want to see changed for GPU speeds, and I will edit vBIOS for you again.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in