Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MSI GS63VR 7RF unlock bios with fan control
#1
My bios is already unlocked to a certain extent, but I have no fan control. This is essential for my hackintosh. My hackintosh is working properly on catalina, but under load the fans barely ramp and it thermal throttles even with liquid metal application. Is it possible to unlock the fan control from BIOS? the bios version is E16K2IMS.31B, downloadable directly from the MSI website. I've tried multiple fan control applications on MAC and none of them recognize my fans. on windows with MSI dragoncenter under load I'm hitting high 70's only under load which is perfect. I believe the reason its thermal throttling in MAC OS is because I disabled the GTX1060 because it's not compatible, which also disables the dual fans connected to the same heat spreader used by the CPU. It would be amazing if I could run the GPU fans and CPU fans without the GTX 1060 enabled VIA bios. Any help or information on the topic would be greatly appreciated.
find
quote
#2
Hi!
Fans settings placed in EC firmware, not in bios. Therefore you cant regulate fans speed in bios, even in unlocked bios.
So, just flash this EC firmware: https://www.sendspace.com/file/ic56k0
In this EC firmware I already correct some settings to increase fans speed.
find
quote
#3
(11-19-2019, 06:34 AM)feluchi Wrote: Hi!
Fans settings placed in EC firmware, not in bios. Therefore you cant regulate fans speed in bios, even in unlocked bios.
So, just flash this EC firmware:  https://www.sendspace.com/file/ic56k0
In this EC firmware I already correct some settings to increase fans speed.

GPU fans still dont spin =\. Any way I can control them?
find
quote
#4
(11-19-2019, 06:34 AM)feluchi Wrote: Hi!
Fans settings placed in EC firmware, not in bios. Therefore you cant regulate fans speed in bios, even in unlocked bios.
So, just flash this EC firmware:  https://www.sendspace.com/file/ic56k0
In this EC firmware I already correct some settings to increase fans speed.

If not is there any way you can give me an EC firmware with GPU fans at 40% permanently?
find
quote
#5
In original EC firmware GPU fan starts only when GPU Temp more then 50°C. In modified EC firmware I already set it to 0°C (this value mean permanently).
find
quote
#6
(11-19-2019, 04:24 PM)feluchi Wrote: In original EC firmware GPU fan starts only when GPU Temp more then 50°C. In modified EC firmware I already set it to 0°C (this value mean permanently).

I guess they won't spin if the 1060 is turned off then, even with custom EC Sad, because under load they still don't spin at all. Is there any way to have the GPU fans spin without the 1060 turned on? I turn if off in the BIOS because it's not compatible with my hackintosh dual boot, but I need them to spin since the copper heat spreader is shared between the cpu and GPU.
find
quote
#7
You turned off your 1060 with these parameters?

Internal Graphics - Enabled
Primary display - IGFX
find
quote
#8
(11-20-2019, 02:44 AM)feluchi Wrote: You turned of your 1060 with these parameters?

Internal Graphics - Enabled
Primary display - IGFX

I had it set to 

Internal Graphics - Auto
Primary display - IGFX

The fans are barely spinning now, its better than nothing i guess. It would be best if the GPU fans spun at the same rate as the CPU fans for the best cooling potential.
find
quote
#9
(11-20-2019, 07:03 AM)jcb1234 Wrote:
(11-20-2019, 02:44 AM)feluchi Wrote: You turned of your 1060 with these parameters?

Internal Graphics - Enabled
Primary display - IGFX

I had it set to 

Internal Graphics - Auto
Primary display - IGFX

The fans are barely spinning now, its better than nothing i guess. It would be best if the GPU fans spun at the same rate as the CPU fans for the best cooling potential.


Try to flash this variant:  https://www.sendspace.com/file/1aewn8
find
quote
#10
(11-20-2019, 07:40 AM)feluchi Wrote:
(11-20-2019, 07:03 AM)jcb1234 Wrote:
(11-20-2019, 02:44 AM)feluchi Wrote: You turned of your 1060 with these parameters?

Internal Graphics - Enabled
Primary display - IGFX

I had it set to 

Internal Graphics - Auto
Primary display - IGFX

The fans are barely spinning now, its better than nothing i guess. It would be best if the GPU fans spun at the same rate as the CPU fans for the best cooling potential.


Try to flash this variant:  https://www.sendspace.com/file/1aewn8

Unfortunately GPU fans are still barely spinning =\. Thanks for trying tho! is there any way you can modify the EC to have the GPU fans ramp according the CPU temp or certain thermal zone temps? or just set a really high fan curve for the GPU fans? Either way thanks for all your efforts! EDIT: or even mirror the CPU fan speeds? that would be optimal.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in