Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nokia Booklet 3G (Phoenix SecureCore) (Post #26)
(05-10-2016, 12:48 AM)petri.eerikainen Wrote: I have succesfully flashed bios and it seems to work even though I had to remove battery at the end to get it reboot. Now I can see Intel menu with all new options. Thanks!
I am trying to replace WWAN PCI-E card with bcm70015 (broadcom chrystal hd), but the computer doesn't recognise it in PCI-E port 2. I also tried to put wifi in port 2 and bcm70015 to port 1, but port 2 doesn't recognise any other card than the original 3g card.
Is there a some option in new menus that I can enable to get this working? I would appreciate the help.

btw. I'm using Win 10 and it works great!

As I undastood Nokia Booklet BIOS ii whatelisted hardware. Some times ago I have update FW for Option modem and it stop working. To restore it I forced to install modem to another one notebook and hardly find original FW for it to reflash. So I suppose it whitelisted. Fortunatelly there is no any whitelist to upgrade HDD to new one or to SSD.
(05-25-2015, 06:07 PM)Sml6397 Wrote: Hello all,

This BIOS mod is complete! The modified BIOS image can be found at the bottom of this post.

The most prominent aspect of this BIOS mod is the addition of a new INTEL Menu. Under it are 4 sub-menus containing a vast array of useful settings. In addition to this, a few keyboard timing settings have been added to the Advanced Menu.

In the few hours ot testing this mod I'm frustrated a lil. Even with Intel enabled menu a good half ot enabling items do nothin. Change for video memory usage and enablin/disablin Intel Vonderpool options is useless. 12st is always use 256 MB of system memory and 2nd is always in enabled state. I found workin only enablin some system ports and device but I believe it's disabled coz it's can't be used in this configuretion (it's Intel USB ethernet adapter port, 2nd PCI-PCI bridge and 2nd PCI-E slot). Maybe I'm wrong and have awful advice but thta's it. Please correct me if I'm wrong. I'm interessting in reduse video memory usage at least. All other options is good to see but to me it's useless.
Hello hooddy,

It is likely that your particular device does not support many of these settings. A large amount of the settings that are unlockable in most Old-Style and New-Style Phoenix BIOS images are generic settings pre-included for the manufacturer to use or not use according to their needs. The graphics memory settings are especially notorious for being generic, dysfunctional settings. The VT-x setting's usefulness depends primarily on your CPU model.


If you have flashed my modified BIOS image and found it to be useful, please consider making a donation. Thank you. Smile Donate Here Sml6397 | MDL: ArcticFreeze | StevenL
www find
Hello there
I need a mod bios for nokia.
Is it possible to share again?
Hi there,

i tried an Upgrade with your modded roms, but get an error by flashing with phlash4 1.82 "file open failed on Platform.bin"
Phlashing operates via bootable usb-stick with freedos on it.
I use : "phlash /c /v /bu bios.rom"
Can anybody help me?
hello i can not find the link
something went wrong, when I tried to update the Bios to V2.00.T01!

Does anybody know the key-combo for the Nokia Booklet 3G to start a Bios update via USB-Stick (WinKey+B respectively Fn+B is not working)?

Thank's for your help, druk13

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in