Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST/HELP] HP Prodesk 600 G2 SFF
Last Post: Marce002
Today 02:59 PM
» Replies: 1
» Views: 0
[READ FIRST] Access Advanced settings th...
Last Post: tohichok
Yesterday 10:53 AM
» Replies: 422
» Views: 553673
[REQUEST] Lenovo T440(S) (GJETxxWW) Whit...
Last Post: Dudu2002
Yesterday 06:29 AM
» Replies: 565
» Views: 144697
[Success] [Bios Mod] Dell XPS L321X EFI ...
Last Post: Maxinator500
Yesterday 02:55 AM
» Replies: 14
» Views: 0
[REQUEST] Maingear Vector Pro 17 AMD BIO...
Last Post: razercortex
01-29-2023 09:38 PM
» Replies: 16
» Views: 1191
[REQUEST] Whitelist Removal Lenovo L440
Last Post: Dudu2002
01-29-2023 06:14 PM
» Replies: 166
» Views: 43522
[REQUEST] Samsung NP-R560-AS03 unlock pl...
Last Post: LordSven
01-29-2023 06:07 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
01-29-2023 02:52 PM
» Replies: 2139
» Views: 520365
Remove white list HP Probook 4740s
Last Post: edvard69
01-29-2023 02:50 PM
» Replies: 2
» Views: 183
[REQUEST] Lenovo Thinkpad W540 (GNETxxWW...
Last Post: Dudu2002
01-29-2023 01:24 PM
» Replies: 48
» Views: 15642
[REQUEST] Lenovo IdeaPad U330, U430 & U5...
Last Post: Dudu2002
01-29-2023 01:17 PM
» Replies: 477
» Views: 103737
[REQUEST] Change Bios bootlogo for Lenov...
Last Post: ZigmaS
01-29-2023 12:04 PM
» Replies: 0
» Views: 0
acer aspire 5920g bios request
Last Post: Remdale
01-29-2023 09:32 AM
» Replies: 17
» Views: 10872
Asus GL702VM Unlocking Menus
Last Post: Bastardo
01-29-2023 07:48 AM
» Replies: 97
» Views: 34477
Need BIOS for ASUS GL10CS
Last Post: Viktorian
01-29-2023 02:45 AM
» Replies: 0
» Views: 0
HP MCP61PM-HM (Nettle2) 5.27 With Unlock...
Last Post: TheWiz
01-28-2023 09:29 PM
» Replies: 870
» Views: 697175
GA-970A-UD3 back to Award rev 3.0
Last Post: mjd79
01-28-2023 05:49 PM
» Replies: 0
» Views: 0
[REQUEST] HP Pavilion G7 unlock bios
Last Post: alpitu21
01-28-2023 04:59 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad T540p (GMETxxW...
Last Post: Dudu2002
01-28-2023 01:45 PM
» Replies: 108
» Views: 32928
Request: Nitro 5 AN515-45-R0B6 BIOS unlo...
Last Post: Dudu2002
01-28-2023 01:42 PM
» Replies: 13
» Views: 1677

Pegatron IPISB-CH & GTX 960
#1
Hello, i recently bought GTX 960 4GB, but it won't boot up. Basically my MOBO need BIOS update, but HP is not going to update old MOBO BIOS.

( Found a post about this whole thing - http://h30434.www3.hp.com/t5/Desktop-Boo...-p/4856809 ).

And i wouldn't want to buy new MOBO, moving whole system to new MOBO its not that easy and of course you need to pay for new MOBO ( which is also downside ). So i was wondering, maybe you guys could make modded and updated BIOS for this MOBO. 

And here is the BIOS - https://www.dropbox.com/s/7bhins183nbx34...8.exe?dl=0


Attached Files Thumbnail(s)
   
find
quote
#2
It's well-known problem without known solution. Motherboards (with old BIOS) and Intel 6&7 series chipsets are incompatible with NVIDIA graphics cards 9xx series.
find
quote
#3
(08-01-2016, 09:04 AM)DeathBringer Wrote: It's well-known problem without known solution. Motherboards (with old BIOS) and Intel 6&7 series chipsets are incompatible with NVIDIA graphics cards 9xx series.

So, i have no choice, but to get new MOBO?
find
quote
#4
Unfortunately...
find
quote
#5
Well, thanks for info, now i wonder which MOBO should i get for i3 2100 and that GTX 960.
find
quote
#6
Hello. the motherboard is the last bios 7.15
https://ftp.hp.com/pub/softpaq/sp55501-5...p55548.exe

I bought a new video card radeon rx 560, but it does not start. (On newer computers worked)
I also read here that someone was able to update the BIOS to support new graphics card:

"I found this forum and read about the possibility of modding the bios to show hidden options, used amibcp 4.55, and voila! i found a lot of hidden settings. I unhidden them all (or most of them i think), went to PCI rom priority and switched it to Legacy ROM, as well as putting video oprom to disabled unless uefi etcetc. Gave the darn thing a reboot with the new gpu and it worked! Not a problem since"
https://www.win-raid.com/t2941f13-moddin...l#msg40405

I modified bios with amibcp 4.55, but I cant flash mod BIOS, - write protect error. tell me how to do it? on motherboard have jumper flash_override, but didn't work.
Thank you.
find
quote
#7
flashed using hardware programmer - graphics card has worked!
find
quote
#8
(12-22-2019, 10:38 AM)contr Wrote: flashed using hardware programmer - graphics card has worked!

Hello,

I am exactly in the same situation with a slightly different board version, the PEGATRON 2AB5.

@contr, can you please share what you did with AMIBCP, or even share your ROM file so it helps other people in the same situation ? It would be really nice from you!

This way, I could do the same with the 2AB5 version!

I was able to "switch to legacy ROM" with AMIBCP, but not set video OpRom to "disabled unless uefi"...

Thank you.
find
quote
#9
(05-02-2020, 06:46 AM)dealth Wrote: can you please share what you did with AMIBCP, or even share your ROM file so it helps other people in the same situation ? It would be really nice from you!

http://www.filedropper.com/origmodpci

bios without serials, UUID etc
modified from the original (using amibcp 4.55 utility)
changed in the modification:
Advanced option (second branch) - PCI Subsystem Settings - PCI ROM Priority - Legacy ROM, and its visibility in the menu of bios (access\use - USER)

this mod bios flashed (with hardware programmer) and worked for me, but you probably need to add your serials, UUID etc.
find
quote
#10
Hi,

Thanks for your quick reply! I was able to sort it out yesterday by unlocking the menus using this guide : MDL Unlock Menus (follow everything except that you need to extract the body of the "freeform" and NOT the compressed section, to give to IRFExtractor)

I read the whole chip using my CH341A programmer, then modded the bios using UEFITool, big thanks to its authors, then flashed it back (erase chip + blank check before writing).

Then I went to the menus and set PCI ROM Priority to Legacy ROM, just as you said with AMIbcp. There is indeed no other option such as "disabled unless uefi" required for the Graphics Card to work.

When you boot, right before the POST screen there is the "legacy oprom" of the GTX 1060 that initializes, and somehow makes it work.

Thanks for the file, it could help people to maybe flash it using afudos, to keep their serials,..   Smile

I hope it will help other people with the same motherboard (IPISB-CH2), to extend the lifespan of their PCs..
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)