Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Lenovo Thinkpad T440p (GLETxxW...
Last Post: Tezzmeret
Yesterday 11:22 PM
» Replies: 681
» Views: 154529
ASUS P9D-I NON-ECC RAM SUPPORT
Last Post: Daniel6745
Yesterday 05:56 PM
» Replies: 0
» Views: 0
HP Bios Unlock
Last Post: filmmaker11736
Yesterday 02:44 PM
» Replies: 0
» Views: 0
Acer predator orion 3000
Last Post: neogamer0909
Yesterday 12:48 PM
» Replies: 27
» Views: 1870
NP300E5Z-S06AE: upgrade i5-2450m to i7-2...
Last Post: georgekevorkian
Yesterday 09:29 AM
» Replies: 2
» Views: 0
[REQUEST] Lenovo G780 (5ECNxxWW) Whiteli...
Last Post: yeahyeah
Yesterday 09:15 AM
» Replies: 963
» Views: 274416
Asus M5A78L-M LX Plus SLIC 2.1 request
Last Post: interwb
Yesterday 08:58 AM
» Replies: 11
» Views: 9715
[REQUEST] Gigabyte Aorus 15p XD Unlock
Last Post: Pratty
11-27-2022 11:37 PM
» Replies: 4
» Views: 303
ASUS P9X79 WS TPM 2.0 Module
Last Post: dynamic_duo
11-27-2022 04:37 PM
» Replies: 0
» Views: 0
Asus X670E Extreme Bios Mod
Last Post: Robr
11-27-2022 03:37 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo B590 (H1ETxxWW) Whiteli...
Last Post: Tommy_1984
11-27-2022 02:10 PM
» Replies: 910
» Views: 272382
Dell Optiplex 7010 bios M.2 NVMe support
Last Post: lexa1812
11-27-2022 01:52 PM
» Replies: 1
» Views: 2252
[REQUEST] Lenovo Flex 2-14 (A0CNxxWW) Wh...
Last Post: Dudu2002
11-27-2022 01:52 PM
» Replies: 273
» Views: 61439
[REQUEST] Asus ZenBook UX582HM bios unlo...
Last Post: Fluffinko
11-27-2022 01:18 PM
» Replies: 3
» Views: 474
[REQUEST] Asus x99-a 3.1 4x4x4x4x bifurc...
Last Post: molegan
11-27-2022 12:36 PM
» Replies: 14
» Views: 2146
[REQUEST] Lenovo Ideapad Z710 (7FCNxxWW)...
Last Post: Dudu2002
11-27-2022 12:08 PM
» Replies: 258
» Views: 77061
[REQUEST] Lenovo IdeaPad Gaming 3 15IMH0...
Last Post: Dudu2002
11-27-2022 10:44 AM
» Replies: 50
» Views: 12320
Acer Laptop New Keyboard , Layout Proble...
Last Post: Copersonality
11-27-2022 04:22 AM
» Replies: 0
» Views: 0
[REQUEST] Asus ROG Strix GL702ZC BIOS Un...
Last Post: tempest22
11-27-2022 03:35 AM
» Replies: 164
» Views: 63583
sony vaio pcg-71712n CPU upgrade from In...
Last Post: Starlingc
11-26-2022 11:11 AM
» Replies: 2
» Views: 0

[REQUEST] Lenovo IdeaPad P400, P500, Z400, Z500 (71CNxxWW) BIOS Unlock
#1
-Motherboard Manufacturer and Model: Lenovo Ideapad z500
-Bios Version : 3.7
-Bios Type : InsydeH20
-Bios Link : http://www.mediafire.com/download.php?h4bmwt3utb33zk7
-Rw-everything : http://www.mediafire.com/download.php?7b5dlc844z22acy many thanks[/size]
find
quote
#2
I would like to get this unlock too.

thanks for your work anyways!
find
quote
#3
me too... i'm looking for a whitelist removed bios..

edit: according donation via PayPal
find
quote
#4
I'm trying w/o luck trying to unlock the pci-e wireless whitelist on my lenovo P400 Touch (I have an intel 7620 AC to put in it).

This BIOS is also for the similar P500, Z400, and Z500 (regular AND touch).

It is an Insyde EFI BIOS (hence why I posted here).

I tried unpacking the core... but aside from a couple "wireless setup" entries, I didn't see anything that screamed "whitelist" to me. Perhaps somebody around here has better luck.

The file from lenovo an be found here:

http://download.lenovo.com/consumer/mobi...cn51ww.exe

( I tried attaching it, to no avail. even .zip'd it).
find
quote
#5
I tried again... here's as far as I got:

The warning message that pops up is in the 11D378C2-B472-412F-AD87-1BE4CD8B33A6_0_1236.ROM file in the Dump. Also known as UEFIL05BIOSLock

However, I couldn't get it to play with the free version of ida (whined that it was a z80 file, yeah right)... and online disassemblers were useless.

Yes, I temporarily removed the data before the MZ in the ROM...

I used this guide:

http://donovan6000.blogspot.com/2013/06/...lists.html

I know it ain't much, but I hope this helps out... if i had some guidance on where and how to continue, then I'd be more than willing to continue myself... however, my knowledge is more with embedded C, not assembly (as they don't teach it much in college EET anymore, I was lucky to get Atmel AVR).
find
quote
#6
Just by your description I can't tell if it's Insyde Secure Flash or a different problem. Lets just use Intel's Flash Programmign Tool, fptw, to bypass anything. Get the utility here.

And run the following and send me the output.bin that it generates
Code:
fptw.exe -d output.bin -BIOS
find
quote
#7
FYI: the linked tool doesn't work (as this is a 7 series laptop). This did work though.

.bin is here.
find
quote
#8
I always assume everyone has a series 6 chipset for some reason. Glad you were able to get the right version.

Here's the modded rom. Flash it back with:

Code:
fptw.exe -f output_mod.bin -BIOS

And just to be safe, verify it with:

Code:
fptw.exe -VERIFY output_mod.bin -BIOS
find
quote
#9
(01-24-2014, 02:48 AM)donovan6000 Wrote: I always assume everyone has a series 6 chipset for some reason. Glad you were able to get the right version.

Here's the modded rom. Flash it back with:

Code:
fptw.exe -f output_mod.bin -BIOS

And just to be safe, verify it with:

Code:
fptw.exe -VERIFY output_mod.bin -BIOS

This darn thing refuses to give up:

[Image: attachment.php?aid=6022]


Attached Files Thumbnail(s)
   
find
quote
#10
[censored]! This is where I'm stuck with these kind of bios. Insyde Secure Flash is used by the previous rom to verify the newly flashed rom before passing control to it. Since we can't modify the currently installed rom, then we can't bypass this. and the flash descriptor sets a lock on writing to your bios region, so we can't use fptw to flash it. Lol it seems like the hardest part about bios modding now is actually flashing it Sad

Until we discover more about Insyde Secure Flash, then these kind of bios are unmoddable at the moment. Sorry Sad
find
quote


Forum Jump:


Users browsing this thread: 3 Guest(s)