Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] WINTEC board. Adding support of Atom D525
Hello there!

Got a Wintec motherboard with Atom D425 onboard. Replaced a processor (BGA) to Intel Atom D525 (SLBXC) but had no luck starting the board because of some BIOS obstacles. I have continuous beeping while running without memory. I also tried different DDR3 memory modules - nothing. It is being stuck while running POST.  Sad

I tried flashing BIOS from ASUS AT5NM10T-I mobo with similar configuration (ITE SIO, NM10, D525) and voila! Blush  It works, splashes ASUS logo and shows "Press F1 to continue... etc" but keyboard doesn't work because of different SIO models. 

Original BIOS manufacturer is Phoenix. I researched it and found the same microcodes as those present in ASUS AT5NM10T-I. I don't really know what BIOS module may cause my Wintec mobo not to work with its original BIOS. Can somebody please help me?

Thanks a lot in advance! Sleepy

Uploaded original Wintec BIOS dump and BIOS image from ASUS AT5NM10T-I.

Attached Files
.zip (Size: 1,002.42 KB / Downloads: 8)
Anyone looked?
I can try soldering POST indicator to LPC BUS to see the POST codes. Maybe actual stopping POST code may help to find out what BIOS module is wrong or incompatible.
(04-25-2018, 06:03 AM)Svyatpro Wrote: Anyone looked?
I can try soldering POST indicator to LPC BUS to see the POST codes. Maybe actual stopping POST code may help to find out what BIOS module is wrong or incompatible.

bios isnt corrupted i realized intel has added some weird security and an extra 1mb for the bios of this board no matter where i look for it i dont think anything is incompatible id just message them to ask for cpu microcode update or find someway to open their bios or some tool they give their users or something ihave no idea but yeah i think if you got post codes you could probably debug the bios you threw on their til it works or find work arounds but asfor wrong or incompatible module i think its more a case of missing propietary module your trying to overcome intel has something else in bios that board absolutely requires or they just offset filesize so its harder to open in modding tools and making it [censored] to get back to standarized 512kb chunks of code...... if you can work on dissasembling old bios or trying to contact intel to add microcode for you .... other than that there was this bios update in 2013 for that board but i doubt it would have new microcodes not too sure cause cant get bios from intel open the other one is an ami bios and maybe you can figure something out with how intel did it from that one bought as best i can help out haah sucks venturing into unexplored territory wish more people modded stuff these days or at least tinkered hahaha im a fan if you get that working bga reball cpu upgrade lol thats awesome one day i wanna figure out something to make pins and connect cpus to laptop sockets hahaha honestly for the bga alone the good work i would have been a month of retrying til i got a post beep hahah
This is not Intel board, this is WINTEC board. WINTEC in an embedded hardware vendor.
I looked, but can't even unpack. The USB keyboard is worked with ASUS bios ? Which your SIO model and revision ?
No, USB keyboard didn't work properly with ASUS BIOS. My SIO is IT8782F AXS.

PhienixTool is able to unpack. Also PhoenixBios Editor successfuly opens it.
By default option Legacy USB Support is Auto, and boot after RTCRST# or wrong CMOS checksum is turn on usb keyboard(i checked on other motherboard with this option setting).
On ASUS AT5NM10T-I, SIO is IT8718F-S and both have same LDN=5 for KBC(keyboard) Configuration Registers and many common Registers, set Global Control Registers 0x29 bit 6 do also function.
Yes, PhoenixBios Editor can open/save this bios file with some not critical warnings.
Quote:Maybe actual stopping POST code may help
It's may be intresting.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in