Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Request] Core2 Quad / E54XX 45nm CPU support for AW9D
#1
Hi guys and girls,

Well one of my d975xbx2 has bit the dust cos I did something really stupid to it. That south bridge heat sink was really tough to remove.... whoops.

Anyway I got a AW9D (non max) to replace the d975xbx2 I use only for WCG Computing for Clean Energy Phase 2.

Now here comes the sticky bit. The Bios....:-(

-bios links
Link to bios 17 http://www.hwdrivers.com/ftp/fd_-slash-M...aw9d17.zip

Link to the very last bios for the Aw9d http://www.mediafire.com/download/su10ug...w9d_18.zip PhoenixAward bios

Link to last beta E0 stepping bios Kindly provided by Keda_P and Bambooz http://b4mbooz.dlinkddns.com/abit-e0/aw9...epping.zip

Liink to delidded microcode file http://www.delidded.com/lga-771-775-micr...7x-6Fx.bin

Potential bios to use for the mod might be based on the MSI 975x Platinum Powerup bios which runs Kentsfield Core2Quads. According to the page it can handle 65nm Core2quads so I suppose there is a slim chance it'll work with a 45nm CPU. Last bios dated 2008-11-03. The MSI 975xPPE uses a Intel 975X+ICH7DH chipset combo as apposed to the 975x+ICH7R on the AW9D.

http://www.msi.com/support/mb/975X_Plati...#down-bios
Just change the .790 file extension to .bin and you're good to go!

27/7/14
Okay I just found out that the.BIO file can opened using Phoenixtool256. So here is the link to the last D975xbx2 bios.
https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=16896&lang=eng&ProdId=2578
I've extracted the files but I have no idea what I'm looking for or what ROM files can modded and shifted to the AW9D bios.

-whats happens: I.e. It doesn't boot / it shows an error (which? post a picture)
Go to the very bottom of this post.

-screenshot from aida64>motherboard>cpuid ( OF THE TARGET CPU)
These pic is from the d975xbx2 with a L5420
[Image: 99djmd.jpg]




-CPU spec codes
E5405 SLAP2 SLBBP
E4510 SLANW SLBBC
L5420 SLARP SLBBR
L5430 SLBBQ
All quad core Xeons.The Xeons should work on the motherboard if the motherboard is core 2 quad compatible.

---------------------------------------------------

I've got myself so far as" Multiprocessor_configuration_not_supported" after turning off auto restart feature while running windows 8 with the Pen D945 installed and uninstalling the Pen D945 CPU in windows device manager before swapping over the D 945 for one of the Xeons.

---------------------------------------------------

This is how far I've managed to get myself.... On the off chance I swapped a L5410 for a E5405 and I managed to get this far. Windows takes it sweet time loading though after a few random resets. Checkout the device manager 4 cpus then check the other programs, 2 cpus :-S. Confused!
[Image: 1rvjt5.jpg]

[Image: 35idg1l.jpg]

[Image: 213mdkp.jpg]

Thanks for all the help. It's been a blast working with the community here at Bios Mods.........

My next move next week will be to see if Linux can utilize the cpu properly but before that it might be a good idea to see if one can actually install windows from scratch with this Franken-bios!

Weird thing happend. Have two bios chips as had to order one when I updated the bios to the last available firmware and then found out that the motherboard wouldn't boot with my GT440 oem plugged in. Tested with the new bios and same thing , no boot. Replaced the graphics card and the thing booted up! Okay now the weird part. Had a bios crash and had to swap over to the spare bios chip, booted up then had to hot swap and re-flash the corrupt bios chip! Never hot swapped and flashed before but it worked! Awesome!

Okay something strange has happened. Got all four cores to work on the Xeon E5405. It's a random thing, as the first time the board was booted up with the evaluation bios somebody sent me it only used 2 cores and only used 1/2 of the cache. So now it's using all core and all the cache but the down side is it's only running at a default 72.2 fsb so the E5405@433MHz. Windows 8 is still usable and it functions okay. While it's using the four cores I've gone into msconfig and changed boot advanced and ticked number of processors to make windows use all 4.

Still some way to go. Will try and post a picture. Here it is.
[Image: 4qmzh1.jpg]

Now lets see what happens after a reboot! Reboot @ 72fsb is fine but can't get back into the bios so had to clear. Now upped the fsb to 144 and everything seems fine.
trying to up the fsb even more but I'm getting error code 4E. Which if you look here http://www.manualslib.com/manual/205138/...ml?page=80 means
1. Program MTRR of M1 CPU
2. Initialize L2 cache for P6 class CPU & program CPU with proper cacheable range
3. Initialize the APIC for P6 class CPU
4. On MP platform, adjust the cacheable range to smaller one in case the cacheable ranges between each CPU are not identical

Slowly upping the fsb until I get the 4E error. Got up to 182 before the bios locked up. Taken it back down to 180fsb. Have to take it down more as starting to get 4E errors and windows boot crashes. Okay after a few resets and reboots I can boot up at 162fsb with N/B 1333 strap, mem at 163spd DDR2-326. Voltage to auto.
that's it for today.

Xeon E5405@164fsb
[Image: 29q0d43.jpg]

25/7/14 Had a random boot up at 333fsb. Had to pump load of volts into it though.
[Image: 16apt9w.jpg]
Rebooted and then fell apart at 333fsb again so went back to 164fsb and all is okay.

Tried the L5410 and I got BSOD "Multiprocessor configuration not supported" message. In other words that's Windows way of saying "Your names not down. You're not coming in!"
After reading this http://answers.microsoft.com/en-us/windo...161ad43169
I think I better disable 2 of the 4 E5405 cores in windows8 64bit, swap out the E5405 with L5410 to see if W8 will boot up on the L5410. Or maybe uninstall the CPU's from device manager before swapping.

26/7/14
Unistalled the CPU's in device manager, shut down then swapped the E5405 for the L5410 and this is what I got. I kept the multiplier for the L5410 at 6 which is the same as as the E5405.
[Image: 34nmgia.jpg]
Windows is a bit confused at to what CPU is in it though. :-S CPU-Z and W8 think it's a E5405, but HWinfo64 has got it spot on. I wonder what will happen when I tell W8 to scan for hardware changes in device manager as right now there is no CPU in device manager!
Rebooted and got hit by the Multiprocessor config BSOD. Before I rebooted though I did un-tick the number of processor box in msconfig: boot:advanced options. Will turn it back on and leave it on when I swap the E5405 back and start again.
Some interesting bits of software from Intel here. https://downloadcenter.intel.com/SearchResult.aspx?lang=&ProductID=2371&ProdId=2371
Checkout BIOS Implementation Test Suite (BITS). Could be just what the Dr ordered! http://biosbits.org/
http://linuxplumbersconf.net/2011/ocw/sy...l/bits.pdf

28/7/14
Spot the difference.
[Image: 2hf2gpf.jpg]
After cleaning up and modding another bios file I managed to get this far. Previously I disabled 3 cores in order to see what would happen but it was Friday and time to go home and it was getting late. I forgot I'd done that before I modded and flashed the bios I was working on. So if W8 booted up the L5410 because of the bios or the fact that it was only using 1 core is what I need to find out now. Went back into msconfig and turned off the number of processor box in msconfig: boot:advanced options, rebooted, upped the fsb to 266 and got hit by the multiproccessor config bsod again I've gone back down to 164 and W8 is taking it's sweet time loading again. Will see what happens. Okay W8 is stuck in an Auto repair loop. Will swap the L5410 for the E5405 and drop the number of cores back to 1.
find
quote
#2
Here is the full manuals http://manualsbrain.com/en/manuals/1187806/
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in