Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] ASUS G750JZ - Modified bios marked as "invalid" ? Pls help?
#1
So I have the said laptop.
I love this machine. It's superb.

There is only ONE thing I want to turn off.
Hyper-threading.

Now, as you might have already guessed... there is no option to do so.
I downloaded the "AMIBCP" tool - thanks to Prema's Clevo thread.

-----
In the CPU section, I found the Hyper-Threading option immediately.
Here comes the twist. I save the file with and without "String optimization" (just in case.)

1) If I just edit the option, it says the build date is older than my current BIOS.

2) So I grabbed a Hex editor, and bumped up the bios file version to 209 from 208, and made the build a day younger.

3) Now ASUS WinFlash says its a valid file..but then it refuses to flash it after I click next.

4) BIOS flash tool (Ezflash?) outright refuses to flash the file. It didn't even complain about the date or version. It just said the same, invalid file.


What am I missing?
How can I produce a valid image for the BIOS flash tool?
I only need THIS one value changed. Nothing else. Just hyper-threading off and thats all I'm not touching anything else in the BIOS file ever.

Thank you in advance!

I would already glad if someone could tell me which HEX value is this (see attached pic). Because I think the AMI tool modifies the entire image, thus it gets ...corrupted (?).

Anyway. If I could just flip this single value, it would be all good.


Attached Files Thumbnail(s)
   

.zip   G750JZAS208.zip (Size: 2.22 MB / Downloads: 8)
find
quote
#2
IF someone can just provide a modified file that I can flash, that would be also totally cool.
(You need to bump version to 209 from 208, and also edit the build date. Make it a day younger like I did.)
find
quote
#3
Solution:
1) Save your BIOS/rom with AFUWIN.
2) Modify settings you want with AMIBCP.
3) Save file.

4) Flash the file with AFUWIN.

You have to enter the BIOS and use "load optimal default" settings to load your settings. But keep in mind I only disabled HT, nothing else.

AND [censored] SURE IT'S THE BEST THING SINCE SLICED BREAD.
This machine is a BEAST without HT. Stupid Intel.
find
quote
#4
hello! i need to do exactly the same as you did but i have an

a55vd- which is k55vd bios, currently im on bios 411 which is the last one.

i could download the bios from the website and modify it AMIBCP

But after trying several times i couldnt make AFUWIN work.

my cpu is 3630QM absolute beast. and is such a pitty see it work at 12% with single core apps.

i tried with AFUWIN 4.42 and it says error loading driver. and the program doesnt show up.

then i tried with AFUWIN 4.40 and when i open AFUWIN or AFUWIN64 my system freezes up.

and i just need to disable hyperthreading as you did.

i would appreciate any help. thank you!
find
quote
#5
You could try installing a virtual XP and run the app there. (With Virtualbox or something.)

Or if you post the bios file, I will modify it for you, and you can check it with a compare tool(to verify I did not do anything fishy with it.)

Btw I just used the OEM 8.1 x64 to do the modding. Maybe try running the tools with right click + run as Administrator.
find
quote
#6
(12-22-2014, 02:58 PM)WhiteJacket Wrote: hello! i need to do exactly the same as you did but i have an

a55vd- which is k55vd bios, currently im on bios 411 which is the last one.

i could download the bios from the website and modify it AMIBCP

But after trying several times i couldnt make AFUWIN work.

my cpu is 3630QM absolute beast. and is such a pitty see it work at 12% with single core apps.

i tried with AFUWIN 4.42 and it says error loading driver. and the program doesnt show up.

then i tried with AFUWIN 4.40 and when i open AFUWIN or AFUWIN64 my system freezes up.

and i just need to disable hyperthreading as you did.

i would appreciate any help. thank you!


Ok friend,
this is the Tutorial :

I have to flash my image on the administrator commandline using afuwinx64 bios_mod.rom /GAN .. Otherwise it gives me a security error (Thanks again CodeRush)

Look what say CodeRush :

It's certanly not so easy for BIOSes with another menu setup, but the whole idea is the same. 
I could also recommend trying AMIBCP to modify menu entries vilibility from "Default"
to "USER", if your menu setup is more complex then a setup above.

About AFUWin :

http://www.ami.com/download-license-agre...tility.zip

I have to flash my image on the administrator commandline using afuwinx64 bios_mod.rom /GAN . . .
Otherwise it gives me a security error (Thanks again CodeRush)

Here many AFU Utilities :

http://forums.mydigitallife.info/threads...ols/page48

I hope You will get your goal !

Regards

Your Brain . . . . It's the best tool U can use ! Wink
Don't FLASH the Bios Mod if You get a Size Alert, You risk a Brick !!!
Donate to me for my work, click here BDM
find
quote
#7
thank you all for your quickly reply!

today i'll try it again. and post the news here

that's how i modified the bios. settings please tell me if u see anything wrong.

or if i need to modify the bios dates or change the version thanks


Attached Files Thumbnail(s)
   
find
quote
#8
ok friends i think im close to the end.

i saved the rom from bios with afuwingui

modified with amibcp

and now tried to flash it with afuwingui

on the page setup it gives me several optionss

first i tried with just main bios image,

but it gave me an error 43 and said i cannot
reboot my system, and that please i keep tryien
to flash the bios till its done successfully.

im going to attach de several options afuwingui gives me,,,,
and im going to wait till someone replies me,
just in case i f*** my system.
thank you loads!


Attached Files Thumbnail(s)
   
find
quote
#9
(12-23-2014, 04:30 PM)WhiteJacket Wrote: ok friends i think im close to the end.

i saved the rom from bios with afuwingui

modified with amibcp

and now tried to flash it with afuwingui

on the page setup it gives me several optionss

first i tried with just main bios image,

but it gave me an error 43 and said i cannot
reboot my system, and that please i keep tryien
to flash the bios till its done successfully.

im going to attach de several options afuwingui gives me,,,,
and im going to wait till someone replies me,
just in case i f*** my system.
thank you loads!





So does it work? I'm also trying to disable ht but i can't find any info about this online.
find
quote
#10
(02-02-2019, 07:37 AM)Draver Wrote:
(12-23-2014, 04:30 PM)WhiteJacket Wrote: ok friends i think im close to the end.

i saved the rom from bios with afuwingui

modified with amibcp

and now tried to flash it with afuwingui

on the page setup it gives me several optionss

first i tried with just main bios image,

but it gave me an error 43 and said i cannot
reboot my system, and that please i keep tryien
to flash the bios till its done successfully.

im going to attach de several options afuwingui gives me,,,,
and im going to wait till someone replies me,
just in case i f*** my system.
thank you loads!





So does it work? I'm also trying to disable ht but i can't find any info about this online.

I********


I COULDNT DO IT, i know it would be quite easy for someone who knows how to do it,
i could even see the hidden bios options,
but unluckly i lost my bios embeded windows key in the process so... thats not cool
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in