Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] X220 v1.42 Modified BIOS
#41
WoW!
1. That's what I call quick fix. Big Grin Thank You, it seemed to work. I didn't push all the buttons to check, but now my keyboard layout seems to be OK.
2. Ok, I'll try that tomorrow. I've read about this "tape over thing" but hoped, that I won't have to mess with this. I've read that some people used nail polish for this, but if I have to resort to such measures, I'd like to do something more reversible. Maybe some small duck tape or whatever.
Thank You very much for the quick response, I'll get back with the results.
Regards,
p
find
quote
#42
Quick question to point 2: I guess it's a strictly hardware specific problem, is it? Just because I have a dual boot system with a Debian Linux as second OS, and the next step will be to set up WiFi and BT for the new card on that too.
Regards,
p
find
quote
#43
This is a Windows driver problem or whatever. You don't need to disable pin 51 if you use Linux.
find
quote
#44
Well, I’d like to use both. That’s the point of a dual boot system. Smile
I hope though that pin 51 is not necessary for BT under Linux. That would be a catch 22...
Than You!
p
find
quote
#45
Update: I've managed to tape over pin 51 on the card. I used a tiny piece of electrical tape. Actually, it was easier than I expected, since pin 51 stands alone on this card, so I didn't have to worry about accidentally covering any neighboring pins. I started the machine with Windows 10, went to device manager, and updated the driver (chose online update). The driver was updated, and the machine asked for a reboot. I rebooted, but the problem was still there. Then I chose to disable the built in "Thinkpad Bluetooth 3.0" device and the "Bluetooth Module", then did an update again on the latter, did another restart, and... voila!... the Bluetooth Module works. Smile
Now I'm wondering if it was really the pin 51 the problem, or simply the system couldn't manage the two BT modules in the laptop together. But I don't really care, it works at last. Since BT on this card is BT 4.0, I'm happy with it. Smile
Now comes the linux part...
@ValdikSS: thank you very much for the tips!
regards,
p
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in